Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Novice Needs Question Answered

New Here ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

I have LR 5.7 installed on my Windows 10 PC and edit photos with it but do not catalog them. I have a 4-month free subscription to the current LR Classic and it's wanting to update my catalog (which I don't use). If I go ahead and do the update, then cancel my new LR subscription after 4 months, will my old 5.7 version still allow me to edit photos? Thanks for anyone's help.

TOPICS
How to

Views

140

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

Allowing Lightroom Classic to update your Lightroom 5.7 Catalog will do no harm, it will create a copy of the catalog and make the copy compatible with Lightroom Classic. So your Lr 5 catalog will be available to you if you have to revert.

However there is no way to convert the Classic catalog compatible with Lr Lightroom 5. There are work arounds you can use to recover most of the editing done in Classic but the new features will not be applied in Lr 5.

 

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.6.1, LrC 11.0.1, Lr 5, Ps 23.0,; Camera OM-D E-M1.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 08, 2021 Jun 08, 2021

Copy link to clipboard

Copied

LATEST

+1 for the answer from @DdeGannes 

However I would read the 'fine print'!

Your 'free 4 months' may bind you to a 12(+4) Months subscription! And cancelling may involve penalties.

 

Regards. My System: Lr-Classic 11.0.1, Photoshop 23.0.2, Lightroom 5.0, Bridge 12.0, Windows-10.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines