Old version of Lightroom for for a graphic card NVIDIA GeForce GT 640M 512 MB

New Here ,
Dec 10, 2021 Dec 10, 2021

Copy link to clipboard

Copied

Could u tell me if Adobe can provide me a old version of Lightroom to work on my  2012 year imac. ( i5 a 2,7 GHz y HDD de 1 TB ) please ? . 

I don´t want to spend right now 2600 €.

 

Thank U in advance

TOPICS
Cross-app workflows , macOS

Views

44

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 10, 2021 Dec 10, 2021

Copy link to clipboard

Copied

LATEST
quote

Could u tell me if Adobe can provide me a old version of Lightroom to work on my  2012 year imac. ( i5 a 2,7 GHz y HDD de 1 TB ) please ? . 

I don´t want to spend right now 2600 €.

 

Thank U in advance


By @kunkana

 

When you say "provide", I assume you mean purchase. The only Lightroom Classic you can purchase from Adobe (by subscription) needs OSX 10.15 (catalina) or higher. If you can install that operating system on your Mac, great, you can run the software. Otherwise you are out of luck.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines