• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

P: Edit in PS from Lightroom does not open the image in PS

Enthusiast ,
Sep 08, 2023 Sep 08, 2023

Copy link to clipboard

Copied

Have an edited image in Lightroom that I want to continue editing with Photoshop. Right click opens PS but the image doesn't move into PS. Instead the Photoshop window opens with my most recent images showing but no way to move the lightroom image to PS.

Windows 11, PS 24.7.0 and LR 12.5

 

[Merged several similar messages into this one thread in order not to have the same question (and suggestion to solve it) in several threads. Mod]

TOPICS
Windows

Views

4.3K

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Sep 10, 2023 Sep 10, 2023
quote

I have been reluctant to process this "fix" as I have installed, Topaz, Nik, Sky replacement images etc etc. I assume I will have to do this again after the PS LR reinstall?

 

Bob


By @Heirloom Bob


Yes, you may have to reinstall some stuff (although you could probably just move the plugins out of the plugins folder and move them back in after reinstalling Photoshop), but do you want to fix this or not? If you want to fix this, then you'll have to accept that it could mean some extra work.

 

Votes

Translate

Translate
Enthusiast ,
Sep 08, 2023 Sep 08, 2023

Copy link to clipboard

Copied

Learned something. If I select the top Edit in Photoshop 2023, the behavior is exactly as I described BUT if I select further down in the list, Photoshop 2023, it opens as it should. Makes no sense to me.

HeirloomBob_1-1694216557826.png

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 08, 2023 Sep 08, 2023

Copy link to clipboard

Copied

I have the same issue as above and a repeat of last month when Lightroom was unable to open an image into Photoshop 2023. I have updated my macOS recently to 13.5.2 and updated all Adobe PS and LR and Beta PS

 

Photoshop 2023 just site there after Cmd E promt and or right click "Edit in Photoshop 2023" The only way around the issue is to open the file from its folder by right click "open in photoshop" and the image then goes to Camera Raw and then into Photoshop. Why has this issue returned after fixes last month. Very frustration

Ken 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2023 Sep 09, 2023

Copy link to clipboard

Copied

What usually works is uninstalling both Lightroom and Photoshop, and then reinstalling Photoshop first and Lightroom second. The order of reinstalling is vital.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 11, 2023 Sep 11, 2023

Copy link to clipboard

Copied

Thank you for the advice. Following the steps you outlined rectified the issue I was having. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 23, 2024 Jan 23, 2024

Copy link to clipboard

Copied

That did not work for me

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 09, 2023 Sep 09, 2023

Copy link to clipboard

Copied

What you have further down the list is a preset that uses Photoshop 2023 as one of the secondary editors. Lightroom opens secondary editors in a different way (in that case Lightroom renders the image and then sends it to the external editor or plugin), so that is why this preset could work but the default method (where Photoshop ACR renders the image in the background) somehow does not.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2023 Sep 09, 2023

Copy link to clipboard

Copied

Same issue here. I've not found a fix for it yet.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 09, 2023 Sep 09, 2023

Copy link to clipboard

Copied

Opening by choosing Open as a Smart Object in Photoshop will open the file and seems to allow edits, but won't allow saving the file. Attempting to save returns an "Error21: undefined is not an object. Line 1"  as an error. Hitting OK still does not allow saving the file. I'm leery of the proposed fix or uninstalling the programs because I'm unsure if that will require reinstalling the various plugins (Imogenic Portraiture and various Topaz files) after the reinstall.  

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 10, 2023 Sep 10, 2023

Copy link to clipboard

Copied

Deinstalled LR and PS and then reinstalled PS then LR Classic in that order. Issue seems to be resolved and I managed to keep all my plugins, presets and actions. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 10, 2023 Sep 10, 2023

Copy link to clipboard

Copied

Hello all,
I have the same problem 😔The "smart object" solution is not viable for me.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 10, 2023 Sep 10, 2023

Copy link to clipboard

Copied

Hi all, I'm seeking a current fix for a problem that looks like it's happened to many of you previously.  I have LR Classic v12.5 and PS v24.7 and am using a Mac with Ventura 13.4.1
All was working fine up until yesterday, but today images will not open in PS from LR.  PS opens, but there are no images visible.  I've closed/opened LR & PS and also restarted the computer, but to no avail.  
Any troubleshooting advice very much appreciated.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 10, 2023 Sep 10, 2023

Copy link to clipboard

Copied

Hello,

I have the same problem

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 10, 2023 Sep 10, 2023

Copy link to clipboard

Copied

To all in this thread: try the uninstall/reinstall suggestion. If you did do that and it did not solve the problem, then report it here. Just saying "I have the same problem" does not help.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 10, 2023 Sep 10, 2023

Copy link to clipboard

Copied

Hello Johan,

 

I have deleted LR + PS. I restarted the computer. I reinstalled PS then LR in order.
I restarted the computer.
Result -> it's OK. It's working again.

Thank You 😀 !

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Sep 10, 2023 Sep 10, 2023

Copy link to clipboard

Copied

I have been reluctant to process this "fix" as I have installed, Topaz, Nik, Sky replacement images etc etc. I assume I will have to do this again after the PS LR reinstall?

 

Bob

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 10, 2023 Sep 10, 2023

Copy link to clipboard

Copied

quote

I have been reluctant to process this "fix" as I have installed, Topaz, Nik, Sky replacement images etc etc. I assume I will have to do this again after the PS LR reinstall?

 

Bob


By @Heirloom Bob


Yes, you may have to reinstall some stuff (although you could probably just move the plugins out of the plugins folder and move them back in after reinstalling Photoshop), but do you want to fix this or not? If you want to fix this, then you'll have to accept that it could mean some extra work.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Sep 10, 2023 Sep 10, 2023

Copy link to clipboard

Copied

Your solution worked just fine.

Thanks  Johan

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 12, 2023 Sep 12, 2023

Copy link to clipboard

Copied

That is not a very helpful suggestion. Remember, we pay good money for this stuff. If I now have to ONCE AGAIN delete and re-install apps, then struggle to get preset and plugins back and working... THIS IS A FULL TIME PRODUCTION ENVIRONMENT and being told, effectively, to "suck it up" is not helpful. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 12, 2023 Sep 12, 2023

Copy link to clipboard

Copied

Thank you for your 'kind' comment. Perhaps you should take into account that I am not an Adobe employee nor being paid by Adobe for trying to help people in this forum. If you don't appreciate that help, then that is not my problem.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 16, 2023 Sep 16, 2023

Copy link to clipboard

Copied

Bonjour,

Quand je choisis "modifier dans Photoshop" depuis LRC, Photoshop s'ouvre mais pas la photo. Je dois envoyer l'image dans Apple Photo puis l'envoyer dans Photoshop. Mes versions de Photoshop (2024) et LRC (12.5) sont à jour. Cela m'arrive régulièrement.

Merci de votre réponse.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Sep 16, 2023 Sep 16, 2023

Copy link to clipboard

Copied

Sigh. Seem this bug is still not fixed for everybody...

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 10, 2023 Oct 10, 2023

Copy link to clipboard

Copied

The same solution worked well for me too 😊👍👍👍

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 11, 2023 Sep 11, 2023

Copy link to clipboard

Copied

Thanks for the fix! I only uninstalled/reinstalled PS and it fixed it, so maybe you don't need to do Lr as well.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 18, 2023 Sep 18, 2023

Copy link to clipboard

Copied

Thanks for the solution. I also uninstalled PS and not LRC and it works. I hope definitly 😉

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines