P:(Windows Only): Select Subject or Select Sky: Unexpected error message "Something went wrong"

Explorer ,
Oct 27, 2021 Oct 27, 2021

Copy link to clipboard

Copied

With the new update, when using  Select Sky or Select Subject, i get an unexpected error message saying something went wrong and the request could not be completed.

TOPICS
Windows

Views

12.1K

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Oct 27, 2021 Oct 27, 2021
In general, please follow https://helpx.adobe.com/lightroom-cc/kb/troubleshoot-gpu.html#solution-4 to update your system with the latest GPU drivers from the respective vendor.

Likes

Translate

Translate
replies 370 Replies 370
Community Beginner ,
Nov 19, 2021 Nov 19, 2021

Copy link to clipboard

Copied

that was the solution; problem is solved; many thanks

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 17, 2021 Nov 17, 2021

Copy link to clipboard

Copied

also

 

Please post your System Information as Lightroom Classic (LrC) reports it. In LrC click on Help, then System Info, then Copy. Paste that information into a reply. Please present all information from first line down to and including Plug-in Info. Info after Plug-in info can be cut as that is just so much dead space to us non-Techs.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2021 Nov 18, 2021

Copy link to clipboard

Copied

defaultzhhqkubq9cd4_0-1637262535595.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 18, 2021 Nov 18, 2021

Copy link to clipboard

Copied

Insufficient

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

I keep getting an error message when I attempt to select sky/subject with the new masking tools, does anyone know how I can fix this   The message says "  there has been an unexpected error and your request could not be completed"

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Can you post a screen capture and state which platform Mac|PC  OS version and Photoshop Version and which select sky|subject menu item  you are having this issue with.

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

@Duncan21853034172q, try updating your graphics driver following the precise instructions in this article:

https://helpx.adobe.com/lightroom-classic/kb/troubleshoot-gpu.html#solution-4

 

A number of people have reported that upgrading their graphics drivers fixed their problems with Select Subject and Sky. If that doesn't help, please do the menu command Help > System Info and copy/paste the entire contents here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

I have tried this and it will still not let me select the sky or the subject using the new masking tool.  I have added in the details about lightroom version installed and computer etc.  maybe that will tell you something that can help me.  Thank you.

 

Lightroom Classic version: 11.1 [ 202112022200-7fd1f998 ]
License: Creative Cloud
Language setting: en
Operating system: Windows 10 - Home Premium Edition
Version: 10.0.19043
Application architecture: x64
System architecture: x64
Logical processor count: 4
Processor speed: 2.4GHz
SqLite Version: 3.36.0
Built-in memory: 8030.8 MB
Real memory available to Lightroom: 8030.8 MB
Real memory used by Lightroom: 795.0 MB (9.9%)
Virtual memory used by Lightroom: 888.9 MB
GDI objects count: 714
USER objects count: 2795
Process handles count: 1607
Memory cache size: 113.7MB
Internal Camera Raw version: 14.1 [ 993 ]
Maximum thread count used by Camera Raw: 3
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 22MB / 4015MB (0%)
Camera Raw real memory: 23MB / 8030MB (0%)
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1360x768
Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No

Graphics Processor Info:
DirectX: Intel(R) HD Graphics 520 (21.20.16.4727)

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jan 12, 2022 Jan 12, 2022

Copy link to clipboard

Copied

@Duncan22615924jqew, you have a 4.5-year-old driver:

 

DirectX: Intel(R) HD Graphics 520 (21.20.16.4727)

 

Many people have reported here that they successfully solved this issue by updating to the most recent driver. You can download the latest driver (12/14/2021) from here:

https://www.intel.com/content/www/us/en/support/products/88355/graphics/graphics-for-6th-generation-... 

 

If the updater tells you to contact your computer manufacturer, and the computer manufacturer hasn't bothered to update their versions of the driver, see the suggestion in this post:

https://community.adobe.com/t5/lightroom-classic-discussions/p-windows-only-select-subject-or-select...

 

A common issue is that these newer AI algorithms rely on using the graphics processor (GPU) to speed them up greatly. That acceleration uses features that trigger bugs in older graphics drivers. Adobe and other software vendors can't be expected to work around every bug in every older graphics driver (but LR could give better error messages when it does encounter the bugs).  

 

Making the situation worse is that at least a couple computer manufacturers don't bother to keep their versions of the graphics drivers up-to-date, so Windows Update isn't providing you with updated drivers automatically.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 20, 2021 Nov 20, 2021

Copy link to clipboard

Copied

Had the same here on my Windows 11 Desktop using the Windows 11 standard drivers for my AMD Radeon RX 580 graphic card. Removing them and replace them with the AMD provided drivers and restart, it all works how it supposed to be 🙂

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 21, 2021 Nov 21, 2021

Copy link to clipboard

Copied

Hi I get this message when selecing "subject or Sky" trying to apply the new masking tools in Develop module. I am fairly new and have been using Lrc on my Windows Laptop with no other issues. Lastest version 11 and shows latest update 5.  All other masking tabs working fine. Any ideas would be great. Thanks.

SueR_0-1637482056141.png

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 21, 2021 Nov 21, 2021

Copy link to clipboard

Copied

@Sue:R:::, try updating your graphics driver following the precise instructions in this article:

https://helpx.adobe.com/lightroom-classic/kb/troubleshoot-gpu.html#solution-4

 

A number of people have reported that upgrading their graphics drivers fixed their problems with Select Subject and Sky. If that doesn't help, please do the menu command Help > System Info and copy/paste the entire contents here.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 21, 2021 Nov 21, 2021

Copy link to clipboard

Copied

Selecting Create New Mask on top of two existing masks creates a blank mask with no functionality. It works correctly in Camera Raw.

Lightrom Classic version 11.01. Windows 10 Version 21H2.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 21, 2021 Nov 21, 2021

Copy link to clipboard

Copied

What type of mask did you select when creating the new mask?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 21, 2021 Nov 21, 2021

Copy link to clipboard

Copied

I selected the Brush, but it looked like the selectios were actually greyed out so what I got was an empty mask.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 21, 2021 Nov 21, 2021

Copy link to clipboard

Copied

@robhit, this thread is about people who get an error message  such as "Something went wrong" when they try to do Select Subject or Sky. Your problem is different, so please start a new discussion thread. Be sure to include more detail about the exact steps you're taking, including the components you selected for each of the three masks.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 21, 2021 Nov 21, 2021

Copy link to clipboard

Copied

Yes,my bad, I agree with johnrellis, this should be in a new post.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 24, 2021 Nov 24, 2021

Copy link to clipboard

Copied

I am having the same issue works on android and apple apps just not on my desktop.  I have upgraded intel graphics

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 24, 2021 Nov 24, 2021

Copy link to clipboard

Copied

What desktop OS and Application versions. If  Photoshop does Photoshop menu Help>GPU Compatibility show your GPU is supported and Drivers are up to date and all features are working OK?

image.png

JJMack

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 24, 2021 Nov 24, 2021

Copy link to clipboard

Copied

JulesHeit_1-1637816086672.png

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 24, 2021 Nov 24, 2021

Copy link to clipboard

Copied

"I have upgraded intel graphics"

 

Please do Help > System Info in Lightroom and copy/paste the entire contents here.  Compatibility with PS does not necessarily ensure compatibility with LR.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 24, 2021 Nov 24, 2021

Copy link to clipboard

Copied

Lightroom version: 5.0 x64 [ 20211012-0002-a1240ed ] (Oct 12 2021)
NGL Version: 1.27.0.12
WF Version: 4.0 8176236
VF Version: 0.1.36.2
HIL Version: 40400
Operating system: Windows 10
OS Version: Windows 10 Home (2009)
Application architecture: x64
System architecture: x64
Computer model: Acer Aspire S5-371T / Intel(R) Core(TM) i7-7500U CPU @ 2.70GHz
Logical processor count: 4
Processor speed: 2.9 GHz
Built-in memory: 8060.1 MB
Real memory available to Lightroom: 8060.1 MB
Real memory used by Lightroom: 1270.5 MB (15.7%)
Virtual memory used by Lightroom: 1450.2 MB
Memory cache size: 1411.5 MB
Internal Camera Raw version: 14.0 [ 950 ]
Maximum thread count used by Camera Raw: 3
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 429MB / 4030MB (10%)
Camera Raw real memory: 430MB / 8060MB (5%)
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1920x1080
Input types: Multitouch: Yes, Integrated touch: Yes, Integrated pen: No, External touch: No, External pen: No, Keyboard: No

Graphics Processor Info: DirectX: Intel(R) HD Graphics 620 (22.20.16.4749)
Graphics Processor Detail: loaded: Yes, supported: Yes, compute: No, init: I2_GPU2, hard: fail_special_file_previous_crash, soft: not_checked, al: No, dl: No
OS Media Capability: true

Application Folder: C:\Program Files\Adobe\Adobe Lightroom CC
Settings Folder: C:\Users\court\AppData\Roaming\Adobe\Lightroom CC
Library Folder: C:\Users\court\AppData\Local\Adobe\Lightroom CC\Data

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 24, 2021 Nov 24, 2021

Copy link to clipboard

Copied

"Graphics Processor Info: DirectX: Intel(R) HD Graphics 620 (22.20.16.4749)"

 

That's a four-year-old driver.  Try updating your graphics driver following the precise instructions in this article:

https://helpx.adobe.com/lightroom-classic/kb/troubleshoot-gpu.html#solution-4

 

A number of people have reported that upgrading their graphics drivers fixed their problems with Select Subject and Sky.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 24, 2021 Nov 24, 2021

Copy link to clipboard

Copied

JulesHeit_0-1637826908353.png

JulesHeit_1-1637827020594.png

 

It is saying that it is up to date.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Nov 25, 2021 Nov 25, 2021

Copy link to clipboard

Copied

From what I can see, the most up to date driver for your Intel(R) HD Graphics 620 is version 30.0.101.1069. You can download it from Intel's driver download site.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines