• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Preference setting for ignoring JPGs on import is not working

Explorer ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

I shoot RAW + JPG but 99% of the time I have no need for the JPG files on my system. Therefore, I untick the box Treat JPG files next to RAW files as separate photos. This is a method that work correctly on previous versions of LRC. Now it does not work I tried ticking restarting them unticking and restarting and I still get the JPGs imported although not always. 

 

Yes, I can work around when sellecting what should be imported but it's an extra process.

 

I am on the latest version of Ventura and Adobe.

TOPICS
macOS

Views

185

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

I thought I illustrate the issue.

And I can also report that the ticked show import dialog is also ignored.Screenshot 2022-11-09 at 10.31.39.jpg

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

As a first troubleshooting step, try resetting LR's preferences:
https://www.lightroomqueen.com/articles-page/how-do-i-reset-lightrooms-preferences/


LR sometimes soils its preferences file, and resetting it can fix all sorts of wonky behavior. That article explains how to restore the old preferences if resetting doesn't help.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

Thank you.

 

Will investigate that option.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

Therefore, I untick the box Treat JPG files next to RAW files as separate photos

Perhaps I am reading into that something not actually stated.

Are you choosing to not treat JPEG as separate photos as to not import them?

That is not what that option does.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

Thank you for responding.

Whilst my preference would be to not import the JPGs - and it seems that incorrectly I assumed that, that was happening. The problem (perhaps only intermittently) is what I have illustrated. With the option unticked when importing photos, both the RAW as well as the JPGs appear as separate. Therefore, I have to ensure that I only tick the RAW files.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

The tick box only seperates them. With it off, the Jpegs are imported as sidecars files. With it on, you see the JPEG seperately and can use File Type in Import to put JPEGS together to deselect them and prevent them from importing. The setting itself has nothing to do with what's imported, just how Lightroom handles the files. 

Sean McCormack. Author. Magazine Writer. Official Fuji X-Photographer.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 09, 2022 Nov 09, 2022

Copy link to clipboard

Copied

"With the option unticked when importing photos, both the RAW as well as the JPGs appear as separate."

 

That should never happen.  Normally, with Test JPEG Files Next To Raw Files As Separate Photos unchecked, when you do an Import from a folder containing both file.nef and file.jpg, only file.nef should be displayed in the Import window and only file.nef will actually get imported.  The presence of the .jpg sidecar will be indicated above the .nef's thumbnail in Library:

johnrellis_0-1668038408787.png

 

Your screenshot of the Import window shows .nef/.jpg pairs (e.g. DSC_5619.NEF and DSC_5619.JPG), which you should not see if that option is indeed unchecked and working normally.  

 

This definitely smells like a corrupted preferences file, so let us know if resetting fixes the issue.

 

"With it off, the Jpegs are imported as sidecars files."

 

To be technically precise, the JPEG isn't actually imported into LR -- the catalog doesn't contain any entry for that JPEG image.  There is just a notation on the .nef image that one of its sidecars has the extension "jpg".

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

Thank you for the suggestion.

I have done a Reset Preferences but alas the Import Screen still shows both RAW and JPG files.

Alas, it has not solved the problem as the Import still offers both file types.

 

I also noticed that wierdly it can be intermittent even during one Import session. See attached.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

Looking at your first screenshot, I wonder if of the three shots, I see a JPEG with one shot, I do not see a JPEG with the two other shots, are those JPEG files simply off screen, and in a different sort order?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

My catalog changes quite dynamically and shots were simply deleted since that screenshot and the order may have been different. The point is that having reset the preferences the problem persists - or does it?
I've been away from my computer since my previous reply and I thought I recreate the sequence by going back to the card itself and guess what, now it's working as it should with no JPGs showing prior or after the import. LR has been dormant for the last 6 hours

Yours confusedly, Geza

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Nov 10, 2022 Nov 10, 2022

Copy link to clipboard

Copied

Post back if its starts misbehaving again. Though I've run out of troubleshooting ideas for now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

LATEST

Alas, it still happens occasionally.

Much more importantly I am having frequent crashes whenever slightly more processing intensive tasks are invoked.

Altogether, in spite of the useful bells an whistles I definitely regret this upgrade.

Importing much slower than before. When I use an external plugin returning to LRC updating the image takes several minutes with a blank screen. Very disappointing. 

I would mention that I am using a 2020 27" iMac with 40MB RAM and plenty of free storage. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines