Problemas con los permisos de las carpetas

Community Beginner ,
Dec 24, 2021 Dec 24, 2021

Copy link to clipboard

Copied

Al iniciar el programa por primera vez una ventana me advierte de que existe un problema con los permisis de lectura y escritura de ciertas carpetas. La ayuda de Adobe proporciona dos procedimentos para su solución, uno mediante el cambio manual de esos permisos en cuatro carpeta y otro mediante un script para la aplicación Terminal de OS. He utilizado ambas, y sigue apareciendo la misma ventana y no puedo utilizar el programa.

TOPICS
macOS

Views

119

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Dec 28, 2021 Dec 28, 2021
Gracias. Lo hice pero no funcionó. ¿Me debería poner en contacto diectamente con Adobe?¿Alguna otra posible solución?

Likes

Translate

Translate
Adobe Employee ,
Dec 24, 2021 Dec 24, 2021

Copy link to clipboard

Copied

Hi Miguel,

 

We're sorry about the trouble with Lightroom Classic. Would you mind telling us the version of Lightroom Classic and the macOS you're on?

 

Just to confirm, Are these are the folder on which you've given the permissions?

  • Users/[user name]/Library/Preferences/
  • /Users/[user name]/Library/Application Support/Adobe/
  • /Users/[user name]/Library/Caches/Adobe/
  • /Users/[user name]/Documents/Adobe/

 

If not then, you may try to permit them. You can also check this link which will tell you how to give permissions: https://support.apple.com/en-in/guide/mac-help/mchlp1203/mac

 

Take a look at the following article and see if that helps: https://helpx.adobe.com/lightroom-classic/kb/lightroom-basic-troubleshooting-fix-most-issues.html

 

If issue persists, try to open Terminal, type "diskutil resetUserPermissions / `id -u`" hit enter.

This will take a while and will reset the permissions in the home folder. Once it's finished, try launching the app again.

 

Let us know if that helps.

 

Regards,

Tarun

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 24, 2021 Dec 24, 2021

Copy link to clipboard

Copied

The issue is probably due to macOS Privacy settings.

 

Open the 'Security and Privacy' > 'Privicay' in System Preferences and scroll to 'Full Disk Access' (see below screenshot), then add Lightroom Classic.

 

Untitled-1.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 24, 2021 Dec 24, 2021

Copy link to clipboard

Copied

Gracias, Ian, lo he hecho pero no ha funcionado. Tendría que haber autorizado también a smbd, como en tu captura de pantalla?

 

Tarun, la versión de Lrc es 11.1. El MacOS Catalina 10.15.7

He llevado a cabo, ya antes de exponer el problema, las dos primeras soluciones que me sugieres, sin resultado alguno. La tercera, teclear em Terminal "diskutil resetUserPermissions / `id -u`" tampoco. Terminal no reconoce esa orden. Tecleo diskutil pero no reconoce resetUserPermissions.

 

Muchas gracias, espero que pueda haber otra solución. Feliz Navidad.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 24, 2021 Dec 24, 2021

Copy link to clipboard

Copied

los permisos modificados

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 24, 2021 Dec 24, 2021

Copy link to clipboard

Copied

I'm sorry that the issue persists. Please go to the System Preferences for your Mac, then Security and Privacy, then select the Privacy tab. Then select Accessibility from the list to the left & check if Lightroom Classic is added to the list with a checkmark in front of it. If Lightroom Classic is not a part of the list, please add it by unlocking the window first using the lock at the bottom left, then clicking the + icon & navigating to the Applications folder. Once done, restart the Mac & check if it helps. 

 

Regards,

Tarun

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 28, 2021 Dec 28, 2021

Copy link to clipboard

Copied

LATEST

Gracias. Lo hice pero no funcionó. ¿Me debería poner en contacto diectamente con Adobe?¿Alguna otra posible solución?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 25, 2021 Dec 25, 2021

Copy link to clipboard

Copied

Thanks, Ian. I did it yesterday but it didn´t work.

Regards

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines