• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

"Export with previous" still doesn't work as expected

Contributor ,
Feb 05, 2023 Feb 05, 2023

Copy link to clipboard

Copied

Some time ago I posted my issues with "Export with previous", you recommended to reset preferences. I tried to do it from menu (twice) but Lightroom were always freezing at that step, so I removed them manually. I know they were removed because Lightroom welcomed me and proposed tutorial tips on start.

 

However the issue still happens, so maybe I will describe my process:

 

1) I browse multiple folders with photos in Lightroom and I put some photos in the target collection

2) I go to my target collection, I edit photo in Photoshop, after that I save the photo and it appears in my collection, so I have NEF then tiff next to each other in my target collection

3) then I go to my NEF (in target collection) and I click "set color label" to purple, to mark photo as processed, so I won't put it in the queue again

4) then I go to my tiff (in target collection) and I click export, I set directory as todays date and it saves jpg in my directory

5) then I go to develop and click "Black & White" to generate BW version of the processed photo

6) then I click "Export with previous" - at this point not my tiff is exported, but my NEF!

7) then I click "Export" - and then my tiff is correctly exported

 

Please analyse my workflow, what may cause problem in point 6?

 

TOPICS
Windows

Views

604

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 05, 2023 Feb 05, 2023

Copy link to clipboard

Copied

it saves jpg in my directory

If I understand your workflow-

"Export with previous" means Export with the last used Export dialog (or Preset). If the Export is set to 'File settings:  JPG'  then you should be getting a JPG for each file you export with "...Previous".

If your original files have the same file name (eg.  ABC.NEF and ABC.TIF) then you should be seeing the "Overwrite?" question because you are trying to export to ABC.JPG in both exports.

 

Regards. My System: Lightroom-Classic 13.2 Photoshop 25.5, ACR 16.2, Lightroom 7.2, Lr-iOS 9.0.1, Bridge 14.0.2, Windows-11.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 05, 2023 Feb 05, 2023

Copy link to clipboard

Copied

File format is not related to the issue at all.

Let me explain by rephrasing.

 

There are two files:

file A which is original source image (in NEF format)

file B which is processed image (in TIFF format)

 

By exporting I create JPG files with my export preset, so yes, each export produces JPG file, however, the issue is what is the source of export

 

file A is the photo I click "edit in Photoshop" and later I set its color label, so I use this file in Lightroom twice: to click edit and to click "set color label"

file B is the photo I want to export, it's created by Photoshop and this is the only file I am interested in while exporting

 

the problem is that after exporting file B correctly with "Export" I then click "Export with previous" and Lightroom is exporting not file B but file A

 

for some reason Lightroom thinks that file A is the one I am interested in

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 05, 2023 Feb 05, 2023

Copy link to clipboard

Copied

Sorry, my tests following your workflow- I cannot re-produce your problem.

1) A.raw > Ps > B.tif

2) Export B.tif > B.jpg on the first ocassion. (OK)

3) If I repeat with B.tif selected and [Export with previous] -the same happens!  > B(unique name).jpg

4) If I want A.raw to [Export with Previous] I must select photo A.raw and [Export with previous].

 

So what image is selected (high-lighted), A or B? when you [Export with previous]?

 

Perhaps you need to apply the 'Universal Panacea' that is Reset Preferences

PREFERENCES RESET

 

Regards. My System: Lightroom-Classic 13.2 Photoshop 25.5, ACR 16.2, Lightroom 7.2, Lr-iOS 9.0.1, Bridge 14.0.2, Windows-11.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 05, 2023 Feb 05, 2023

Copy link to clipboard

Copied

My steps were more complex, are you also using collection and color labelling?

I wrote about resetting preferences in the first sentence.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Feb 05, 2023 Feb 05, 2023

Copy link to clipboard

Copied

I followed your steps exactly and did not have the issue on my Mac.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 05, 2023 Feb 05, 2023

Copy link to clipboard

Copied

I wonder what else can I try to fix that, I assume reinstalling Lightroom is no better than removing preferences. Thanks for checking.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 05, 2023 Feb 05, 2023

Copy link to clipboard

Copied

"...reinstalling Lightroom is no better than removing preferences."  In fact- Not as effective at all! Mostly does nothing.

"...using collection and color labelling?.."

Doesn't alter any Export function!

The SELECTED photo (be that the NEF or the TIF) is the one that exports with [Export with previous].

Can you screen-clip a SELECTED photo (Your photo B), then [Export with previous], and show us the exported JPG please?

 

Regards. My System: Lightroom-Classic 13.2 Photoshop 25.5, ACR 16.2, Lightroom 7.2, Lr-iOS 9.0.1, Bridge 14.0.2, Windows-11.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 09, 2023 Feb 09, 2023

Copy link to clipboard

Copied

I just reproduced the issue again.

There are two photos on the screenshot.

Right one is NEF file which I edited in Photoshop.

Left one is PSD file which was exported by Photoshop.

Lightroom mark them as stacked.

I set color label of right one to purple.

Left one is selected (see bottom line).

Export exports processed one (PSD), Export with previous exports unprocessed one (NEF).

 

Please try to reproduce my steps.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 09, 2023 Feb 09, 2023

Copy link to clipboard

Copied

Unfortunately it's not reproducible each time, because on another photo I used same steps and "Export with previous" exports selected photo.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 10, 2023 Feb 10, 2023

Copy link to clipboard

Copied

I reproduced your steps and this is my experience-

1) Create a TIF (Monochrome)  in Photoshop  from a NEF (Original)

2023-02-10 17_56_00-MONOCHROME WORKSHOP - Adobe Photoshop Lightroom Classic - Library.jpg

2) EXPORT the TIF to a JPG-  Result a monochrome JPG. (Same image as the TIF)

2023-02-10 17_55_36-MONOCHROME WORKSHOP - Adobe Photoshop Lightroom Classic - Library.jpg

3) Select the NEF and EXPORT AS PREVIOUS-   Result a coloured JPG. (Same image as the NEF)

2023-02-10 17_56_47-MONOCHROME WORKSHOP - Adobe Photoshop Lightroom Classic - Library.jpg2023-02-10 17_57_17-MONOCHROME WORKSHOP - Adobe Photoshop Lightroom Classic - Library.jpg

 

Are you certain you understand that 'Export with Previous' means to Export USING THE LAST USED EXPORT PRESET, with all the options as defined in the Export Preset. It will export a SELECTED IMAGE using the last used Preset. It has no relevance to the last exported image!

 

 

 

 

 

Regards. My System: Lightroom-Classic 13.2 Photoshop 25.5, ACR 16.2, Lightroom 7.2, Lr-iOS 9.0.1, Bridge 14.0.2, Windows-11.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 10, 2023 Feb 10, 2023

Copy link to clipboard

Copied

Could you look at my screenshot and read the description? "Left one is selected (see bottom line)."

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Feb 10, 2023 Feb 10, 2023

Copy link to clipboard

Copied

That is a problem for you, but I am out of ideas as to why it is happening for you.

It seems very unusual that an un-selected image would be the one to export.

Hopefully the problem remedies itself, or others can provide some insight into your experienes.

 

 

Regards. My System: Lightroom-Classic 13.2 Photoshop 25.5, ACR 16.2, Lightroom 7.2, Lr-iOS 9.0.1, Bridge 14.0.2, Windows-11.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Feb 10, 2023 Feb 10, 2023

Copy link to clipboard

Copied

LATEST

I use Lightroom since 2013, this issue is quite new (few months) so I was thinking it may be some change in the implementation - or it's somehow related to using collections (I think I started processing photos in collections quite recently).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines