• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

"Photos That Failed To Build a Smart Preview" Issue

Community Beginner ,
May 25, 2023 May 25, 2023

Copy link to clipboard

Copied

Greetings,

 

My catalog shows 2k+ images labelled "Photos That Failed To Build a Smart Preview" however when I create Smart Previews of these images they do not get removed from this set nor does the quantity of photos decline.

 

Screen grab shows an example. Any suggestions for a fix are welcome.

 

TY

Views

891

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 25, 2023 May 25, 2023

Copy link to clipboard

Copied

in the future, to find the best place to post your message, use the list here, https://community.adobe.com/

 

p.s. i don't think the adobe website, and forums in particular, are easy to navigate, so don't spend a lot of time searching that forum list. do your best and we'll move the post if it helps you get responses.

 

<moved from using the community>

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 25, 2023 May 25, 2023

Copy link to clipboard

Copied

A couple of thoughts:

 

1. Try resetting LR's preferences:
https://www.lightroomqueen.com/articles-page/how-do-i-reset-lightrooms-preferences/


LR sometimes soils its preferences file, and resetting it can fix all sorts of wonky behavior. That article explains how to restore the old preferences if resetting doesn't help.

 

2. Use the free trial of the Any Filter plugin to see what the catalog internally reports for the presence of the smart previews. Select the built-in collection  Photos That Failed To Build A Smart Preview, run the Any Filter > Filter command, click the magnifying glass, and select the Has Smart Preview criterion:

johnrellis_1-1685057981928.png

If Any Filter reports that all those photos in fact have smart previews, then the problem is just that the built-in collection isn't getting updated. But if Any Filter reports that those photos don't have smart previews, then the problem is more serious.

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 25, 2023 May 25, 2023

Copy link to clipboard

Copied

Hi John!

 

Resetting preferences did not solve the issue (tried reset a open and while running). So moving on to Any Filter, see attached grabs.

1) I get an error message

2) After I disregard the error message red box'ed some of items of note.

 

Thoughts?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
May 26, 2023 May 26, 2023

Copy link to clipboard

Copied

I have never seen this message, but it looks to me like the smart previews are corrupted. Lightroom can simply rebuild them: Move the <catalog> smart previews.lrdata out of your catalog folder, start Lightroom and try buidling some new smart previews. If that works without a problem, then that was probably it so you can trash the old smart previews and build new ones for all your images.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 26, 2023 May 26, 2023

Copy link to clipboard

Copied

Hi Johan, what you suggest is the first thing I tried.

 

All previews (Smart and not) were moved to a new folder and I open app to rebuild (screen grab). However, the catalog still shows this default selection of images. They are mainly all from one time frame (Mar to April 2022).

 

Additionally, at the bottom of this set of images are duplicates (the grey ones, second screen grab). They're problematic b/c:

 

  • They show no preview
  • They can't be removed or deleted
  • They are all the same file name (_DSF0818.JPG)
  • They can't be located in the finder

 

Thanks in advance for any further thoughts/feeback.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 26, 2023 May 26, 2023

Copy link to clipboard

Copied

"

  • They show no preview
  • They can't be removed or deleted
  • They are all the same file name (_DSF0818.JPG)
  • They can't be located in the finder"

 

That's definitely an inconsistency in the catalog. If you'd like, send me the catalog proper and I'll see if I can fix it, or at a minimum, narrow it down and file a bug report.   

 

In Finder, go to the catalog folder, right-click <catalog>.lrcat, and do Compress. Then upload the .zip file to Dropbox, Google Drive, or similar, and send me the sharing link via private message (click the envelope button in the upper-right corner of this page).

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 26, 2023 May 26, 2023

Copy link to clipboard

Copied

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

johnrellis_0-1685114065589.png

 

This error is coming from LR internals, not the Any Filter plugin itself, strongly suggesting a catalog inconsistency. It's tempting to ignore inconsistencies, but that portends danger down the road.

 

I've never seen that special collection, Photos That Failed To Build A Smart Preview.  I tried to provoke it by changing the permissions on the catalog subfolder "<catalog> Smart Previews.lrdata". LR then displays an error dialog when it fails to build smart previews, but it doesn't create that special collection. 

 

It may be that this special collection is used so infrequently that's it's never been thoroughly tested by Adobe, and the problem could be simply in how that collection is built and accessed by LR, not affecting the rest of the catalog.

 

You could try Johan's suggestion of exiting LR, moving "<catalog> Smart Previews.lrdata" out of the catalog folder, restarting LR, selecting the special collection, and then doing Library > Previews > Build Smart Previews.  If the special collection goes away, then I think you can rest easy. If it doesn't...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 26, 2023 May 26, 2023

Copy link to clipboard

Copied

Hi John, perhaps you saw my note to Johan, I tried moving the Smart Preview and rebuilding. No luck.

 

Right now, I decided to select all the Smart Previews in that collection, discard and then rebuild (or not). However, the app is stuck on the Discard function (it started but then shows no status chnage). Screen grab attached

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 26, 2023 May 26, 2023

Copy link to clipboard

Copied

Hi John, any thooughts on the above?

 

Recap:

  • Photos That Failed To Build A Smart Preview shows 2,549 images some of which have Smart Previews.
  • 65 images show no preview and for metadata display the same data for whatever photo I last looked at. I can't remove or delete these "ghost" images from the catalog
  • I can't Discard any Smart Previews for images in this catalog whoch have Smart Previews

 

Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 27, 2023 May 27, 2023

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 28, 2023 May 28, 2023

Copy link to clipboard

Copied

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

I opened the .lrcat you sent and poked around a bit with my plugins and didn't notice any inconsistencies other than that special collection Photos That Failed To Build A Smart Preview.

 

With respect to that special collectioin, the last 65 entries in that collection are completely bogus and causing all sorts of errors when you try to use them via the LR app or access them via plugins.  Clearly a LR bug somewhere.

 

I was able to delete the special collection by right-clicking it and doing Remove This Temporary Collection: 

johnrellis_0-1685297324971.png

 

After removing the special collection, I recommend going through the procedure again of removing existing smart previews and building new ones (exiting LR, moving "<catalog> Smart Previews.lrdata" out of the catalog folder, restarting LR, then doing Library > Previews > Build Smart Previews).  I'm not able to try that because I don't have access to the actual photos.

 

If building smart previews produces errors, be sure to grab screenshots of any error messages. 

 

And does the special collection come back, and does it again have bogus entries at the end?

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 28, 2023 May 28, 2023

Copy link to clipboard

Copied

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

With respect to the other issues you saw with the Metadata browser in the Library Filter bar, I'm not seeing those when I open the catalog:

johnrellis_0-1685297864086.png

 

After deleting the special collection (see above), are you still seeing this problem with the Metadata browser?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
May 30, 2023 May 30, 2023

Copy link to clipboard

Copied

Hi John,

 

"Right-clicking it and doing Remove This Temporary Collection" - OF COUSE! I'm so sorry I didn't think of this. Worked well, thank you again for your time and effort.

 

On to another bug/question if you don't mind. After importing ~10k iPhone pics (JPGs, HEIC & PNG files):

  • I spot checked and saw not all the images imported (seems like JPGS didn't get added)
  • Next, I tried: Import > Copy as DNG (Source: original folder; To: My catalog) > Selection "New Photos"
  • Instead of the app just selecting "New" images, all the images keep getting selected. I've restarted. Toggles diff destination folders, etc. No luck.

 

I can't think of another way to decipher which images successfully imported and which didn't. Any thoughts? 

 

TY

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 31, 2023 May 31, 2023

Copy link to clipboard

Copied

"Right-clicking it and doing Remove This Temporary Collection" - OF COUSE! I'm so sorry I didn't think of this."

 

Well, nobody else thought of this either.  I don't know anyone who has reported seeing this temporary collection before!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 31, 2023 May 31, 2023

Copy link to clipboard

Copied

"I can't think of another way to decipher which images successfully imported and which didn't. Any thoughts?"

 

I suggest starting a new thread, so more people will see this and hopefully give a good answer.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 03, 2023 Jun 03, 2023

Copy link to clipboard

Copied

Hi John, I sent you a private message FYI.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 04, 2023 Jun 04, 2023

Copy link to clipboard

Copied

LATEST

Hi John, you can disregard my private message.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines