• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Reading Preferences...

Community Beginner ,
Jul 24, 2022 Jul 24, 2022

Copy link to clipboard

Copied

Mac Os X: Mac OS Catalina 10.15.7 

Lightroom Classic 11.4.1 

 

I've tried everything and can't get Lightroom to open correctly. 

 

Tried multiple times to delete the following file and restart my computer. Hold Shift + Option and launch the program to reset the settings. Tried uninstalling Lightroom and installing an older version. 

~/Library/Preferences/com.adobe.LightroomClassicCC7.plist

 

I've managed to bypass the reading preferences page by opening a catalog but the program won't function. When I click on Develop tab I get another error "An error occurred when attempting to change modules."

 

Any help would be appreciated. I've attached 2 text reports after attempting to close the program.

 

All my other Adobe programs are working without any issues.

TOPICS
macOS

Views

494

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 24, 2022 Jul 24, 2022

Copy link to clipboard

Copied

As a first troubleshooting step, grant LR Full Disk Access, as described here:

https://community.adobe.com/t5/lightroom-classic-discussions/quick-tips-how-to-give-full-disk-access... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2022 Jul 24, 2022

Copy link to clipboard

Copied

Thanks for the suggestion. I followed the guide but it did not resolve my problem. Still hangs Reading Preferences. I can get past this screen if I open a catalog but I'm still unable to develop. Keep getting the same module error. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 24, 2022 Jul 24, 2022

Copy link to clipboard

Copied

See:

https://helpx.adobe.com/lightroom-classic/kb/error-changing-modules-lightroom.html

but you have tried most of the steps in the above link.

The recommendation by Johnrellis is basically #6, and is important, try that first.

Have you tried creating a new catalog?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2022 Jul 24, 2022

Copy link to clipboard

Copied

Hello, 

Solution # 6 - Sharing & Permissions is already set to Read & Write for the Lightroom folder.

/Users/Eduardo/Library/Application Support/Adobe/Lightroom

 

Solution #1 - Latest installed.

Solution #2 - Completed multiple times.

Solution #3 - I have reinstalled the latest version multiple times.

Solution #4 - I can bypass the Reading preferences by opening a catalog and then I'm able to create a new catalog. But getting errors when I try to use develop. Lightroom also stops responding and freezes when I quit the program.

Solution #5 - Using the latest lightroom classic

Solution #7 - No resolution.  

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 24, 2022 Jul 24, 2022

Copy link to clipboard

Copied

"Solution # 6 - Sharing & Permissions is already set to Read & Write for the Lightroom folder."

 

That's not the same as granting Full Disk Access.   Full Disk Access is required by LR 11 on Mac OS 12 and the last version of Mac OS 11.  It may be be not be required on your version of Mac OS (10.15.7), but you should give it a try:

https://community.adobe.com/t5/lightroom-classic-discussions/quick-tips-how-to-give-full-disk-access... 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 24, 2022 Jul 24, 2022

Copy link to clipboard

Copied

Hi John,

Sorry, I thought I responded to your suggestion. I did complete and restart my computer but it did not resolve my problem.

Adobe Lightroom Classic is allowed in the following:

1. Accessibility

2. Full Disk Access

3. Files and Folders

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 02, 2022 Aug 02, 2022

Copy link to clipboard

Copied

My only workaround to this mess is rolling back not only once, twice, three, four, five, but SIX times to version 11.1 

This is the last version of Lightroom CC Classic that works for me without any issues. 

Are we expected to be left behind and continue paying for this subscription? 

Can't believe there isn't a simple fix to whatever this problem is. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 03, 2022 Aug 03, 2022

Copy link to clipboard

Copied

Just one additional thought, check and see if there is perhaps a security update for your Mac OS Catalina. Check manually.

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.7.1 BigSur,; LrC 12.0.1, Lr 6.0, Ps 24.0, ACR 15.0,; Camera OM-D E-M1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 03, 2022 Aug 03, 2022

Copy link to clipboard

Copied

You can also disable GPU acceleration in Lightroom Preferences > Performance tab. Then reboot LrC. Worth a try.

 

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.7.1 BigSur,; LrC 12.0.1, Lr 6.0, Ps 24.0, ACR 15.0,; Camera OM-D E-M1

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 18, 2022 Aug 18, 2022

Copy link to clipboard

Copied

Hi,

There's been an update but my mac hasn't been able to install it for some reason. I've tried installing it in safe mode but it doesn't install after the mac restarts. The installation always stops and restarts the mac back to normal without actually installing it.

https://support.apple.com/kb/DL2094?locale=en_US

 

I just updated to Lightroom 11.5 and it's also getting stuck on the splash screen Reading Preferences... I can't even go into preferences. I can only quit the program. But if I revert back to 11.1 no issues. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 18, 2022 Aug 18, 2022

Copy link to clipboard

Copied

UPDATE

- I managed to install the latest security update on my MacBook pro. 10.15.7 (19H2026). I had to disable (System Integrity Protection) after that it updated succesfully.

- Lightroom 11.5 is still stuck on Lightroom splash screen Reading Preferences. 

- Resetting preferences Shift+option doesn't help.

- I've also tried disabling gatekeeper (sudo spctl --master-disable) but that didn't help. Still stuck on the splash screen and I can't eventer the Preferences menu. 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 18, 2022 Aug 18, 2022

Copy link to clipboard

Copied

UPDATE

- I don't believe my problem has to do with GPU acceleration. I managed to bypass the splash screen by going to File > Open Catalog >  Opens the last catalog I was working with on version 11.1. I managed to get into preferences > Performance > Turned off GPU. 

- I then checked the file com.adobe.LightroomClassicCC7.plist and it added useAutoBahn (Boolean) = NO

- I then restarted lightroom and still getting stuck on the splash screen reading preferences...

- Again, I can bypass the splash screen by opening a catalog but then I'm unable to use the Develop page because I receive an error "An error occurred when attempting to change modules." Making Lightroom 11.5 practically useless.

 

Any other ideas?

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 24, 2022 Aug 24, 2022

Copy link to clipboard

Copied

UPDATE 

I jumped on a call with Adobe Support. We screen shared and they repeated the steps I took. 

1. I updated my Macbook Pro to the latest possible software update - MacOs Big Sur 11.6.8 (20G730)

2. Granting permissions (Read & Write) to all users and folders contained within the Adobe folders. Confirm the accessibility and full disk access was granted.

3. Adobe support deleted com.adobe.LightroomClassicCC7.plist from the Preferences folder.

 

 

In the end, the Adobe support representative advised that I roll back to the last version that worked with my system (11.1). They stated that I would need to upgrade my system to use a newer version of Lightroom Classic.

 

That makes no sense why all the other Adobe apps (Photoshop, Premiere Pro, After Effects, Media Encoder, Audition, Bridge) work with the latest updates but Adobe Lightroom Classic will not work past update 11.1.

 

My system specs

macOS Big Sur

Version: 11.6.8 (20G730)

MacBook Pro (Retina, 15-inch, Late 2013)

Processor: 2.3 GHz Quad-Core Intel Core i7

Memory: 16 GB 1600 MHz DDR3

Graphics: Intel Iris Pro 1536 MB / NVIDIA GeForce GT 750M 2 GB

Storage: 500GB APPLE SSD SM0512F

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 30, 2022 Aug 30, 2022

Copy link to clipboard

Copied

"In the end, the Adobe support representative advised that I roll back to the last version that worked with my system (11.1). They stated that I would need to upgrade my system to use a newer version of Lightroom Classic.

 

"That makes no sense why all the other Adobe apps (Photoshop, Premiere Pro, After Effects, Media Encoder, Audition, Bridge) work with the latest updates but Adobe Lightroom Classic will not work past update 11.1."

 

According to Adobe documentation, all versions of LR 11 are supported on Mac OS 11:

https://helpx.adobe.com/lightroom-classic/system-requirements.html 

 

It sounds like Adobe Support's primary goal was to find some workaround that would let you run a relatively recent version of LR 11.  But it's often the case that Support says random things that can't be trusted.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 21, 2022 Sep 21, 2022

Copy link to clipboard

Copied

This is an Adobe bug, no doubt. They broke something past 11.1 and have no plans to fix it (so it seems).

I'm having the exact same issue as you, tried everything including fresh install of OSX, no luck to run anything past 11.1.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 27, 2022 Oct 27, 2022

Copy link to clipboard

Copied

I just installed 12.0 in hopes that this issue would be resolved. It has not. 

 

With this update, Lightroom actually opens and I can view the catalog but when I try to switch to develop I get the same error.

"An error occurred when attempting to change modules.

 

I'm also now having issues with Premier pro. I basically need to get out of Metal otherwise all I see is a green screen.

 

My guess is that they are no longer allowing the programs to work with older video cards. I happen to have a Late 2013 Macbook Pro with an Nvidia card. It wasn't until after Nvidia and Apple decided to stop updating the drivers. Now I'm getting all of these problems trying to use the latest Adobe updates. 

 

What a nightmare.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

I have this same problem - doesn't seem to be GPU related. I have an Vega56 and a EGPU RX 6600 XT and the problem persits with both.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 02, 2022 Nov 02, 2022

Copy link to clipboard

Copied

Hi,

Are you running macOS? I'm on macOS Big Sur 11.7.1. This is the most up to date I can go with my Late 2013 Macbook Pro. 

 

I rolled back to Lightroom 11.1 so I can use the Develop module. Otherwise everything after that continues to fail.

 

It's rediculous they can continue to charge for a monthly subscription but don't allow you to use the latest updates and features and come up with some excuse for compatibility. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 03, 2022 Nov 03, 2022

Copy link to clipboard

Copied

Yes - iMac Pro w. Monterey and Ventura on seperate SSDs. Doesn't work on either. 11.1 is the latest working w. me as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 04, 2022 Nov 04, 2022

Copy link to clipboard

Copied

LATEST

My five cents: lightroom 11.5 worked for me about two weeks ago. I have the same as reported here error switching to developer module Today. I have not done any system or Adobe updates, mystery, but thanks for letting me know that I can go back to 11.1 - suckes, but better than nothing for now.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines