• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
5

Restore files after hdd crash

Explorer ,
Dec 20, 2023 Dec 20, 2023

Copy link to clipboard

Copied

Lost 2 hdd, Restored files from Backblaze, Can't use find missing file to add to LR, should I remove original files from LR or keep trying to find missing files and point to the restored images?

 

I am using LRCC 13.1

Windows 10. ver. 22H2, OS build 19045.3803

The files are now missing on LR. When I try to use "Find Missing folder" I get...

 

ERROR An Internal error has occurred: ?:0: attempt to index filed 'source' (a nil value)

Views

522

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 20, 2023 Dec 20, 2023

Copy link to clipboard

Copied

You need to ask program questions in the forum for the program you are using
To ask in the forum for your program please start at https://community.adobe.com/
Moving from Using the Community (which is about the forums) to the correct forum

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Dec 20, 2023 Dec 20, 2023

Copy link to clipboard

Copied

Posted in the wrong forum (Ecosystem) - moving to Lightroom Classic

Rikk Flohr - Customer Advocacy: Adobe Photography Products

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 21, 2023 Dec 21, 2023

Copy link to clipboard

Copied

Moderators.

 

It looks like their are two instances of this post.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 20, 2023 Dec 20, 2023

Copy link to clipboard

Copied

Lost 2 hdd, Restored files from Backblaze, Can't use find missing file to add to LR, should I remove original files from LR or keep trying to find missing files and point to the restored images?

 

I am using LRCC 13.1

Windows 10. ver. 22H2, OS build 19045.3803

The files are now missing on LR. When I try to use "Find Missing folder" I get...

 

ERROR An Internal error has occurred: ?:0: attempt to index filed 'source' (a nil value)

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 21, 2023 Dec 21, 2023

Copy link to clipboard

Copied

You have to point LrC to the location where the photo files are now located. See https://www.computer-darkroom.com/lr2_find_folder/find-folder.htm. You can do this on an entire "tree" of folders at once, see Figure 4 in particular.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 21, 2023 Dec 21, 2023

Copy link to clipboard

Copied

I did, that's when the invalid message came up. 

Lightroom is showing the files as missing because the drives are missing not moved outside of LR. I learned along time ago, "Everything begins and ends in Lightroom" Scott Kelby and Tim Gray. Its easier and faster to handle files outside of LR but its makes a mess.

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 21, 2023 Dec 21, 2023

Copy link to clipboard

Copied

Lightroom is showing the files as missing because the drives are missing not moved outside of LR. I learned along time ago, "Everything begins and ends in Lightroom" Scott Kelby and Tim Gray. Its easier and faster to handle files outside of LR but its makes a mess.

 

Disagree completely with Scott Kelby and Tim Gray. The best way to move things is in your operating system and reconnect, as described in the document I linked to. It works flawlessly if you take some time to learn and understand the method. I have done it many times when moving my Lightroom Classic catalog and files to a new computer.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 21, 2023 Dec 21, 2023

Copy link to clipboard

Copied

Was the catalog also restored? In your first screenshot you try to relink a missing folder that shows 'invalid' rather than the number of missing images in that folder. That looks like catalog corruption... And why don't you try to relink the 'Photos' top folder rather than some day folder? Relinking the top folder will relink all its subfolders as well.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 21, 2023 Dec 21, 2023

Copy link to clipboard

Copied

I did that first, thats when the invalid came up. So I tried to link the day.

What if I reimport the files and add to the catalog instead of copying them, then try to relink them. That's how I have done it in the past with a Backblaze external restore drive. I connected the external drive and added to the catalog. then relinked the folders. It worked but doing that also builds a library of duplicate files, which is one of my main problems with my library (1.8 million images, I shoot sports).

 

No, the catalog was not restored only the data from the 2 hard drives (Older Seagate barracuda 3TB sata, and a Samsung SSD 870 EVO 1TB) were restored by zip file. I believe the zip file may have been the issue. It took for ever to download it.

 

I had 4 drives act as though they were dead, but after disconnecting the problem drive a Samsung 870 EVO 1TB SSD the other drives came back. I immediatley began moving files off of the the old drives to newer drives (inside LR), and beginning a restore. I wanted to try and recover the data without having to wait for Backblaze to send me the files on an external drive. I had to build 3 seperate zip files to get all the data back. I extracted the data from the zip file to a file on another hard drive (WD EXT 18TB already in LR) so that I could relink the files.

 

Thank you, for your input.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 21, 2023 Dec 21, 2023

Copy link to clipboard

Copied

What if I reimport the files and add to the catalog instead of copying them, then try to relink them.

 

Re-importing is the worst thing you can do. You will lose collections, virtual copies, pick flags, edit history and a few other things. Depending on certain other things, you could lose your edits and lose your user-provided metadata.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 21, 2023 Dec 21, 2023

Copy link to clipboard

Copied

Seems pretty clear, and dj_paige answered it.

 

111.png

 

112.png

The catalog, the database, has the folder in your F drive. When you went looking for the photos, you found them in your N dive. Now if you follow the link that dj-Paige provided, and specifically if you look at Part 2, if you simply right click on the F drive in the Folders panel in LrC, and select Update Folder Location (looks like you were almost their) and select that N drive, it should get resolved (to be clear, did you try that?)

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 21, 2023 Dec 21, 2023

Copy link to clipboard

Copied

quote

Now if you follow the link that dj-Paige provided, and specifically if you look at Part 2, if you simply right click on the F drive in the Folders panel in LrC, and select Update Folder Location (looks like you were almost their) and select that N drive, it should get resolved (to be clear, did you try that?)


By @GoldingD


The menu is 'Update Folder Location' if you right-click on a folder that is not missing. If you right-click on a folder that is missing, then the menu is 'Find Missing Folder'.

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 28, 2023 Dec 28, 2023

Copy link to clipboard

Copied

I found this showing how to for the code you received, maybe you can look into it. 
https://community.adobe.com/t5/lightroom-classic-discussions/an-internal-error-occurred-0-attempt-to...

 

Lee- Graphic Designer, Print Specialist, Photographer

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 28, 2023 Dec 28, 2023

Copy link to clipboard

Copied

LATEST

 

ERROR An Internal error has occurred: ?:0: attempt to index filed 'source' (a nil value)

 

Well dirty word, I should have inquired. Do you perhaps have the Logitech LogiOptions plugin installed and active?

If not, never mind.

 

That particular plugin is known to be buggy. It is not the driver nor the control app for the mouse or keyboard (but a similar name), but is a plugin to allow you to assign buttons on a Logitech Mouse (if supported) and/or one particular Logitech keyboards Wheel to assign LrC, PS, actions (similar to using a lopupedeck) if you do not do that on your mouse, then it is of no use.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines