Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Self-confused LRC Newbie needs help working in LRC on a clone of his pictures folder (2,300 images)

Community Beginner ,
Oct 31, 2021 Oct 31, 2021

Copy link to clipboard

Copied

Using LRC 10, I opened my 2300-image Pictures folder, built a great Keywords list, and applied keywords to hundreds of images.  But the image collection was original organized via many dozens of folders and subfolders, making it very confusing to achieve a methodical keywording process.

So I decided (for safety's sake) to make a copy of my 2300-image Pictures folder into [NewPicturesFolder], de-folderize all images in [NewPicturesFolder] , to make it easier to apply my great keywords to them, one by one, without having to deal with folders and subfolders.

 

So after completing the copying process,  I opened LRC, selected [NewPicturesFolder] as Source, created a new Catalog named [NewCatalog], and was about to start importing images.

 

Then I noticed in the right panel, that under "Apply During Import\Metadata" and "Keywords", the default was set to "None" .

 

How do I get "Apply During Import\Metadata" and "Keywords" to display my great Keywords list that I created in [Original Catalog] so that after I click on IMPORT, and import is completed,  I can resume tagging [NewPicturesFolder] images in [New Catalog] with keywords from [Original Catalog]?

 

TOPICS
Windows

Views

49

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Contributor , Nov 02, 2021 Nov 02, 2021
You're probably working with jpg's.  xmp sidecar files are only created for RAW files.  For jpg's the data is written directly into the file itself.

Likes

Translate

Translate
LEGEND ,
Oct 31, 2021 Oct 31, 2021

Copy link to clipboard

Copied

Using LRC 10, I opened my 2300-image Pictures folder, built a great Keywords list, and applied keywords to hundreds of images. But the image collection was original organized via many dozens of folders and subfolders, making it very confusing to achieve a methodical keywording process.

 

So I decided (for safety's sake) to make a copy of my 2300-image Pictures folder into [NewPicturesFolder], de-folderize all images in [NewPicturesFolder] , to make it easier to apply my great keywords to them, one by one, without having to deal with folders and subfolders.

 

Since folders are independent of keywords, I really don't understand the problem you are having here.

 

So after completing the copying process, I opened LRC, selected [NewPicturesFolder] as Source, created a new Catalog named [NewCatalog], and was about to start importing images.

 

Then I noticed in the right panel, that under "Apply During Import\Metadata" and "Keywords", the default was set to "None" .

 

How do I get "Apply During Import\Metadata" and "Keywords" to display my great Keywords list that I created in [Original Catalog] so that after I click on IMPORT, and import is completed, I can resume tagging [NewPicturesFolder] images in [New Catalog] with keywords from [Original Catalog]?

 

Your keywords may not be stored with the photos themselves. The default behavior of Lightroom Classic is to store the keywords ONLY in the catalog and not with the photos. You can override the default so that keywords are stored in both the catalog and with the photo files, by setting an option to automatically store the metadata in xmp. So did you set this option in the first catalog?

 

But honestly, the easiest thing to do is to use the first catalog, with the folders and keywords. I really don't understand the issues here. I have folders by capture year and then subfolders by capture date, and they work seamlessly with my keywords.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

Thank you, dj_paige.

I took your advice and stayed with the original catalog.

And I went to Edit\Catalog Settings\Metadata tab\ and selected "Automatically write changes into XMP".

Next, in LRC,  I added a couple of keywords to a test image, and closed LRC.

Next, in Windows Explorer, I opened the test image and viewed its File\Properties.

The keywords ("Tags", in WindowsSpeak) that I had added from within LRC, were still there.

So I added a couple of keywords  via Windows File\Properties.

I closed and saved the test image, relaunched LRC, and sure enough, all the keywords and 'Tags' were showing up when viewing the test image in LRC.

So this tells me that all those keywords and 'Tags" are embedded within the test image, which is what I wanted.

I see no "XMP" sidecar files anywhere, so I have to conclude "Automatically write changes into XMP" simply means 'embed changes into the image file itself, as XMP metadata". (Why don't they just say that?)

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Contributor ,
Nov 02, 2021 Nov 02, 2021

Copy link to clipboard

Copied

LATEST

You're probably working with jpg's.  xmp sidecar files are only created for RAW files.  For jpg's the data is written directly into the file itself.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines