Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Strange and inconsistent behavior when entering keywords

Community Beginner ,
Jun 17, 2021 Jun 17, 2021

Copy link to clipboard

Copied

I often enter keywords by typing then in the Keyword Tags box during import.  Usually, after I type part of the keyword, LrC suggests the completion.  After typing a keyword, if I type a comma and a space, it invariably suggests an entire keyword, namely Lucy Parish.  I have edited my Keyword List, deleting that keyword (there were no photographs referencing it).  After that, I stopped and restarted LrC.

This keyword has no meaning for me.  I have no photos that include it.  I have no idea where it came from.  How can I get rid of it?

TOPICS
Bug

Views

238

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Community Professional , Jun 18, 2021 Jun 18, 2021
Strangely, it seems possible to have a word with a leading [space] in the name. This would have the result that the 'Auro-complete' suggestions would show any KW beginning with a [space] character when the [Comma][space] is typed. Search the KW List for "[space]Lucy Parish". I am interested to know the result.

Likes

Translate

Translate
LEGEND ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

In Lightroom, do the menu command Catalog Settings > Metadata > Clear All Suggestion Lists.  Then exit Lightroom. In Finder or File Explorer, navigate to your catalog folder and delete "<catalog-name> Helper.lrdata".  That stores the keyword auto-complete suggestions and it is harmless to delete. Be very careful not to delete anything else in that folder!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

That makes sense.  Unfortunately, it did not work.  I did Clear All Suggestion Lists, found my catalog folder in Finder and deleted Helper.lrdata.  Then I restarted the computer and LrC.  The unwanted keyword suggestion still shows up.  Specifically, it appears when I type any keyword, followed by comma, followed by blank.  If I begin typing another keyword after the comma, without a blank, the unwanted suggestion does not appear.   

I even went into Catalog Settings > Metadata and unchecked "Offer suggestions from recently entered values."

The problem occurs when I am in Import mode or, inconsistently, when I am editing the keywords of an already cataloged file.

(I did say it was strange.)

For the record, I am on macOS Catalina Version 10.15.7 and Lightroom Classic 10.3

Tom

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

[This post contains formatting and embedded images that don't appear in email. View the post in your Web browser.]

 

Hmm.

 

Go to the Keyword List panel and type in Lucy in the Filter Keywords box, ensuring All is selected:

 

johnrellis_0-1624046183824.png

 

Does the problem keyword appear?  If so, delete it.

 

If the keyword doesn't appear, try accepting the auto-complete suggestion so that it gets added to a photo. Then go back to the Keyword List, type in "Lucy", and then explicitly delete the keyword.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 18, 2021 Jun 18, 2021

Copy link to clipboard

Copied

Strangely, it seems possible to have a word with a leading [space] in the name.

This would have the result that the 'Auro-complete' suggestions would show any KW beginning with a [space] character when the [Comma][space] is typed.

Search the KW List for "[space]Lucy Parish".

I am interested to know the result.

 

Regards. My System: Lr-Classic 10.4, Photoshop 22.5, Lightroom 4.4, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jun 22, 2021 Jun 22, 2021

Copy link to clipboard

Copied

LATEST

The space is the key!  How it got there is another question!  My problem was that in scrolling through the keyword list, I initially found "Lucy Parish" and deleted it.  I failed to go further into the list, where, thanks to your suggestion, I found

" Lucy Parish".  Once I deleted that, the problem seems to have gone away.

 

The funny thing is how this came about in the first place.  I seem to have entered the keyword initially as St. Lucy Parish, which Lightroom seems to have interpreted as

>St
    > Lucy Parish

I guess the right answer is to leave off the period, typing St Lucy Parish, or perhaps spelling out Saint Lucy Parish.  The image that was initially keyworded was shot in St. Lucy Parish, Barbados.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines