• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
2

SYNC is stuck in Lightroom Classic without Errors

Explorer ,
Jan 26, 2024 Jan 26, 2024

Copy link to clipboard

Copied

My sync is stuck at this point. In the preferences for LIGHTROOM SYNC, I do not see any SYNC ACTIVITY.

I did RESET SYNC DATA but that did not do anything either, I always end up with the screen below. The icon stops turning after a minute or so. 

 

Can anybody help??? 

 

roverdublin_0-1706294722360.png

 

TOPICS
Windows

Views

187

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jan 29, 2024 Jan 29, 2024

Copy link to clipboard

Copied

Hey, @roverdublin. Welcome to Lightroom Classic Community. I'll help you figure this out.

What version of Lightroom Classic & the operating system are you working on? Where do you keep your Lightroom Catalog? Internal drive or an external drive?

 

Apply a flag or rating to some images already syncing in Lightroom Classic & let Lightroom sit idle for 30-40 minutes to finish syncing.

 

Also, log on to Lightroom Web (https://adobe.ly/488zVWp) & check for any sync issues on the web. Before making any changes to sync issues, locate & back up these images away from Lightroom. Lightroom sync might not function as expected as there are sync issues.

 

Let me know how it goes. Thanks!
Sameer K

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 04, 2024 Feb 04, 2024

Copy link to clipboard

Copied

Hi Sameer (and OP),

 

Same issue here, and while there are many threads on various flavors of sync issues over the years, let's work on this thread as the most current. I am using Mac OS Sonoma 14.0 and LrC 13.1.

 

There have always been sync issues. Sometimes, it would take a long time for the updates to sync to or from cloud. Sometimes, there would be an endless "Syncing 2 photos" popup over the blue circle sync icon with nothing showing in the details window and no sync errors showing. This issuse seems to be new as of one or two weeks ago. It may be related to the most recent LrC version, or maybe OP and I got unlucky in the exact same way.

 

For the past week or so every time I add photos to LrC, the count of "Syncing X photos" goes up. The photos and updates eventually, though slowly, sync to and from the cloud, that behavior is no different from before. But the count of "Syncing X photos" eventually got to 2,500+ plus, so I decided to do something about it. 

 

Therte are no sync activities in the details screen. No "All sync erros" collection in LrC under Catalog and no Sync erros in Lightroom Web. 

 

After reading about it, I deleted (moved) the Lightroom Catalog v12-v13 Sync.lrdata file from the Lightroom folder. When I restarted LrC, the sync icon pop-up showed "Syncing 258,607 photos" -- that's all my synced photos. The count went down in spurts, then stabilized at "Syncing 252,135 photos" for 1/2 hour or so. Not what I was trying to achieve. 4 photos showed in "All sync errors". I deleted them and restarted LrC. "All sync errors" cleared, but the count stayed at "Syncing 252,135 photos". I repeated the procedure with deleting the Sync.lrdata file. The same process repeated. Now the count was stuck at another high number, just a few thousand below the total.

 

I read some more and found the "Rebuild sync data" button. I clicked it. It warned me that it can take time. I okayed it. I think it paused sync, restarted LrC, and sync remained paused. Nothing was visibly happening. I was not sure if I had paused sync, or if it was part of the rebuild, so I unpaused sync. It again started from "Syncing 258,607 photos" and got stuck at "Syncing 246,959 photos" where it has been ever since.

 

I checked the Lightroom folder. lrcat-wal file is slowly updating, so is Sync.lrdata, which is up to 1.43 Gb and going as of this writing. LrC is doing "something", but what and how long will it be doing it, and how long will it show "Syncing 246,959 photos"?

 

Did I do the wrong thing by unpausing sync after clicking "Rebuild sync data"? Should I do it again and leave it alone for -- how long?

Should I reinstall something? Is there anythjing to do in the Creative Cloud app? It has a sync, too, but I think it's a diffrerent one. At one point this week, now that I am checking everything, the sync in Creative Cloud app was showing an issue due to firewall. But for one, I am not running a firewall on this mac (there may be one in my router, I would need specific instructions to troubleshoot it), and besides the error went away. This error ONLY showed in the Creative Cloud App, not LrC.

I have rebooted the machine repeatedly in between the steps I listed above.

 

I am willing to provide any additional data and try anything short of deleting my photos from the cloud -- unless this is the ultimate and DEFINITIVE solution (which I am not convinced of). For the time being, my cloud librarries seem to be okay. But LrC is my go-to app, and my reliance on cloud sync is heavy.

 

Thanks!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Feb 04, 2024 Feb 04, 2024

Copy link to clipboard

Copied

LATEST

I ran sync diagnostic and it generated a 12 Gb file, 10 Gb zipped. I will try reading it and am happy to share it.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jan 30, 2024 Jan 30, 2024

Copy link to clipboard

Copied

Hi @Sameer K 

I have the latest version 13.1 which automatically downloads anyway. I am as far as I know up-to-date.

I have no flags or anything else set. There are no SYNC issues or errors in the Lr or LrC or on the Web version.

This is a problem because I have no pointer in what is going wrong here. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines