Welcome Dialog

Welcome to the Community!

We have a brand new look! Take a tour with us and explore the latest updates on Adobe Support Community.


Unable to Export: An internal error has occured: ?:0: attempt to compare two nil values

New Here ,
Nov 14, 2016 Nov 14, 2016

Copy link to clipboard

Copied

Hello,

I am trying to export a batch of photos (either by multiple selection -> right click -> export or by creating a Har Drive publish service) with the following settings:

  • Resize to Fit:
    • Megapixels, 16,0 (or 15,0)
    • Resolution: 300 pixels per inch

At some point during the 'Preparing to export...' process I am getting the following error:

lightroom error.JPG

It appears that I am getting this error no mather what Megapixel value I insert. Any other resize method (dimensions, longe edge) or export to full size seem to work fine.

OS: Windows 10 Pro (1607)

Lightroom Version: 2015.7 Release

Views

743

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Nov 14, 2016 Nov 14, 2016
Hi AndreiDragusanu,Please refer these thread and let us know if that helps.API error while exporting? Update LR CC error message If none of these helps,Restore Lightroom preferences after backing up your catalog.See Resetting Preferences in Lightroom CC/6 Regards,Akash

Likes

Translate

Translate
Nov 14, 2016 Nov 14, 2016

Copy link to clipboard

Copied

Hi AndreiDragusanu,

Please refer these thread and let us know if that helps.

API error while exporting?

Update LR CC error message

If none of these helps,Restore Lightroom preferences after backing up your catalog.See Resetting Preferences in Lightroom CC/6

Regards,

Akash

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 20, 2021 Aug 20, 2021

Copy link to clipboard

Copied

LATEST

I have been receiving this same message when trying to export my finished images. I tried many of the fixes listed in these threads. However, in my case, it turned out to be the catalog that had a problem. I was able to export the images by creating a NEW CATALOG, then importing the images from the original catalog into it, to then export it. Hopefully my sharing this will help someone else. Here are the steps.

File > New Catalog > (name it) Create > the new catalog will then open...

File > Import From Another Catalog > (find original catalog) Double Click to open or click Choose > (check box) Import.
Once the images have completed the import, you may export as you normally would.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines