• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
3

Unable to locate catalog after update

Community Beginner ,
Nov 15, 2023 Nov 15, 2023

Copy link to clipboard

Copied

I opened Lightroom Classic today and was informed that the catalog needed to be updated. Seemed a bit odd as it was updated recently. I keep the app updated and assume I was already on the most recent version 13.0.1 as I had access to the new Lens Blur and Point Color features.  I run LR on Windows 11 Pro 23H2.

 

The catalog update took a few seconds which also was unusual given it normally takes a little while and I have a large number of photos in the catalog.

 

When LR started it had no photos and ran me through the introductory help of where to click for the various features. I checked and was on the correct catalog but the size indicated there was nothing in it. All my other catalogs that were in this folder where older ones that LR had upgraded over time.

 

Luckily I backup my catalog almost everytime I use LR so I uncompressed my recent backup, copied it back to the normal location and gave it a new catalog number. Pleased to say all my photos are back but I needed to re-setup some of the basic views, not sure what else I still need to check in my preferences.

 

Hopefully this is an isolated issue but would like to understand what might have caused this. I had an Adobe support person remote connect to my machine but was quite uncomfortable with the steps being taken. If Adobe would like to investigate further please have a senior tech reach out.

TOPICS
Windows

Views

118

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Nov 15, 2023 Nov 15, 2023

Copy link to clipboard

Copied

Sometimes Lightroom loses the connection to the catalog during an upgrade. As a result, it will look for a catalog with the default name in the default location, and if it does not find one because your catalog has a non-default name and/or is stored in a non-default location, it assumes this is a new installation. It will then create a new catalog and welcome you with the dialog you saw. So it sounds like this happened to you too, although it does not explain everything you reported. The old catalog should still be where it was before, Lightroom never deletes catalogs (not even old catalog backups).

 

-- Johan W. Elzenga

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 15, 2023 Nov 15, 2023

Copy link to clipboard

Copied

LATEST

Thanks Johan, that makes sense, but as you mention not quite my experience. I can see an older catalog from about a month ago when LR likely did the catalog update. However, there should have been a catalog with a date from a day or two ago which wasn't there. The backup I had was from the expected timeframe. The newly created LR catalog seems to have the same name as the one that was deleted but that is a bit of an assumption from me as I don't actively keep track of the catalog names. 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines