Highlighted

Big Lag with Adjustment Brush

New Here ,
Apr 07, 2019

Copy link to clipboard

Copied

Hey folks, with this most recent update to LR Classic (8.2.1) I am seeing an old nemesis rear its ugly head. The dreaded lag while using the Local Adjustment Brush. It's so bad that I can't use the Local Adjustment Brush, it locks up LR. I'm on a 2015 Apple iMac with 2TB of storage, 24GB of RAM and an AMD Radeon R9 M395X with 4GB of VRAM. I edit BIG files - 16384 X 12288. Prior to the upgrade everything worked great. Here I was hoping to never ever ever see this again...

Is anyone else seeing this?
Adobe Community Professional
Correct answer by cmgap | Adobe Community Professional

Limit video cache size should be checked. Try 3.0 to start. The comma vs period must be due to the language version you are using. Also I would recommend Unchecking Use Smart Previews instead of Originals when editing as that has reportedly slowed performance.

Views

2.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Big Lag with Adjustment Brush

New Here ,
Apr 07, 2019

Copy link to clipboard

Copied

Hey folks, with this most recent update to LR Classic (8.2.1) I am seeing an old nemesis rear its ugly head. The dreaded lag while using the Local Adjustment Brush. It's so bad that I can't use the Local Adjustment Brush, it locks up LR. I'm on a 2015 Apple iMac with 2TB of storage, 24GB of RAM and an AMD Radeon R9 M395X with 4GB of VRAM. I edit BIG files - 16384 X 12288. Prior to the upgrade everything worked great. Here I was hoping to never ever ever see this again...

Is anyone else seeing this?
Adobe Community Professional
Correct answer by cmgap | Adobe Community Professional

Limit video cache size should be checked. Try 3.0 to start. The comma vs period must be due to the language version you are using. Also I would recommend Unchecking Use Smart Previews instead of Originals when editing as that has reportedly slowed performance.

Views

2.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Apr 07, 2019

Copy link to clipboard

Copied

Are you saying that in LR 8.2.0 you did not have this problem, but in v8.2.1 you now do have it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 11, 2019

Copy link to clipboard

Copied

Correct

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Apr 08, 2019

Copy link to clipboard

Copied

Is your Use GPU on or off in your preferences?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 08, 2019

Copy link to clipboard

Copied

Same problem here but with Windows (1809). The lag is not as hughe as RamblinLamb describes and LR doesn't crash but it's slow (again). Also switching between files takes longer before the preview is sharp.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Apr 08, 2019

Copy link to clipboard

Copied

Could you please answer the questions asked above?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 09, 2019

Copy link to clipboard

Copied

My software is updated automatically but I'm pretty shure that it started after I had the notification that LR was updated.

The use of GPU is off because it always worked better this way.

LR Pref perf.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Apr 09, 2019

Copy link to clipboard

Copied

Try turning on GPU processor. Also change the comma in the cache size so that it is 20.0 not 20,0. Restart Lightroom after making these changes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Apr 09, 2019

Copy link to clipboard

Copied

But having the GPU on is known to slow down brushing.

Anyway, if none of the suggestions help, you might have to revert to a previous version of Lightroom where it worked well (probably 8.2). Install previous version of your Creative Cloud app

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 09, 2019

Copy link to clipboard

Copied

cmgap  schreef

Also change the comma in the cache size so that it is 20.0 not 20,0.

LR changes the size itself to 20,0 if you type just 20!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Apr 09, 2019

Copy link to clipboard

Copied

Limit video cache size should be checked. Try 3.0 to start. The comma vs period must be due to the language version you are using. Also I would recommend Unchecking Use Smart Previews instead of Originals when editing as that has reportedly slowed performance.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 10, 2019

Copy link to clipboard

Copied

Screen Shot 2019-04-10 at 1.07.02 PM.png

My video cache was already set to 3.0. I did purge it.

This wasn't checked, so I checked it. "Use Smart Previews instead of Originals when editing" That has resolved my issues.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Apr 11, 2019

Copy link to clipboard

Copied

Well I spoke too soon! The changes I made worked, for awhile, then it came back for no apparent reason. ARGH. I'm now at a loss here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jun 29, 2019

Copy link to clipboard

Copied

Im in the same position with the D850 images, super super slow with adjustment brush!?? tried everything.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jun 30, 2019

Copy link to clipboard

Copied

Did you turn off Use GPU in preferences?

Sent from my iPhone

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jun 30, 2019

Copy link to clipboard

Copied

https://forums.adobe.com/people/justin+pt83894960  wrote

Im in the same position with the D850 images, super super slow with adjustment brush!?? tried everything.

My answers in your thread from a few months ago are still valid.

Lightroom 8.1 super slow with Large images from Nikon D850 on super fast iMac

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 07, 2019

Copy link to clipboard

Copied

Just move to capture one like all the pros do!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Apr 08, 2019

Copy link to clipboard

Copied

Please upload a screen shot of your Preferences > Performance tab.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Aug 07, 2019

Copy link to clipboard

Copied

So one issue is your 5K display (based on rig described).

Trying to remember all the tweaks to attempt to improve performance on MAC 4/5K displays

In Develop module, select 1:1 or smaller, 1:2, 1:3 (smaller view) to cut down on pixels in LR windows showing the image.

In Develop, make side, top, and bottom panels as large as possible, decreasing area available for the LR window showing the image.

In Develop, force use of Smart Previews (ahh, you are doing that)

Clear History panel?

use a smaller (resolution ) monitor

And for a Windows OS, just reduce the resolution

Just another Adobe customer; My Sys; APP: LRC 9.4, PS 21.2.1; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.6; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Aug 07, 2019

Copy link to clipboard

Copied

Also, although this issue has decreased in validity, even though you have that Camera RAW CACHE limit set higher than default, consider increasing it as an experiment, try 40 maybe more

Oh, and consider purging it.

Just another Adobe customer; My Sys; APP: LRC 9.4, PS 21.2.1; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.6; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...