Cannot Export Book to PDF...

New Here ,
Nov 17, 2020

Copy link to clipboard

Copied

I have create a Book in the Book Module. In Book Settings, it is set up as a Blurb Photo Book. There is a "Send Book to Blurb..." bottom right which works. There is a "Export Book to PDF..." bottom left which doesn't work. Usually a window pops up where you can "Save As:" and "Where", but nothing happens. Lightroom Classic V10, Mac OS Catalina 10.15.7

 

TOPICS
Mac, Problem or error

Views

153

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Nov 21, 2020

Copy link to clipboard

Copied

Can you try a test? Take any collection of a dozen images and open the book module - don't worry about layout etc. just  test the print to pdf, print to jpg. Is it just this book that won't print?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Feb 26, 2021

Copy link to clipboard

Copied

Let me piggy-back on your problem since I'm seeing similar issues with Lightroom Classic and a 52 page book I'm trying to create. In my case, neither "Send Book to Blurb..." nor "Export Book to PDF..." do anything at all - no dialog is shown, no errors are reported, buttons just appear dead. I tried creating a small book with 6 pages and see the same problem there so it's not likely related to size. I have successfully created books from Lightroom before but this is the first one with this particular update (10.1.1).

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Feb 26, 2021

Copy link to clipboard

Copied

Some more info. I opened a book I had previously exported both as PDF and to Blurb successfully and see the same problem there - I can no longer export it. The latest book was successfully exported to PDF when I last did an update back in December. That was on the same iMac but prior to my upgrading to Big Sur and on an earlier LR release.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Feb 26, 2021

Copy link to clipboard

Copied

Next attempt - I gave LR full disk access in System Preferences.../Security and Privacy. Still no luck.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Feb 28, 2021

Copy link to clipboard

Copied

Try using the Creative Cloud app to uninstall LrC 10.1.1, shutdown and restart your system, and reintsall LrC 10.1.1.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Feb 28, 2021

Copy link to clipboard

Copied

Thanks. That feels a bit draconian but it's better than "format your hard disk and reinstall the OS". I'll give it a try and see if anything improves.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Feb 28, 2021

Copy link to clipboard

Copied

No luck - exactly the same problem after uninstall/reboot/reinstall 😞

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Feb 28, 2021

Copy link to clipboard

Copied

A LrC uninstall and reinstall retains the old Preferences file, which may have become corrupted, which can happen during updates. Try resetting the LrC Preferences file as outlined at the below article. Renaming the file allows the old file to be restored if of no help. Make sure to close and reopen LrC to load the new Preferences file.

 

https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Mar 02, 2021

Copy link to clipboard

Copied

Sorry - still no luck after removing the Preferences file.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Mar 03, 2021

Copy link to clipboard

Copied

Since you are not the original poster here can you confirm what OS you are running?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Mar 04, 2021

Copy link to clipboard

Copied

Apologies - I only just saw this request! I got an email notification for your later one, though.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Mar 03, 2021

Copy link to clipboard

Copied

Also what LrC version you have installed. 10.1.1 is the latest.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Mar 04, 2021

Copy link to clipboard

Copied

From my initial post, 10.1.1.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Mar 03, 2021

Copy link to clipboard

Copied

I just found this post. Are you using Smart Previews with the original files offline (disconnected external drive, or no permissions).

https://community.adobe.com/t5/lightroom-classic/lightroom-exporting-book-why-or-why-can-i-not-expor...

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Mar 04, 2021

Copy link to clipboard

Copied

All files are online and accessible to LR, stored in the same Thunderbolt RAID drive that they were last time I managed to create a book.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Mar 04, 2021

Copy link to clipboard

Copied

What version of OS are you running?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Mar 04, 2021

Copy link to clipboard

Copied

macOS Big Sur 11.2.1 (20D74)

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more