Cannot import MP4 from DJI Mavic 2 Pro on iMac

Jul 06, 2020

Copy link to clipboard

Copied

I'm getting this error on just the videos from my Mavic 2 Pro when I try to import into my iMac - late 2013 3.2 Ghz Quad Core i5 on Catalina 10.15.5 OSX:

 

tcworldtraveler_0-1594097916795.png

 

However I can import perfectly fine on my newer Macbook Pro 16".  The versions of OSX and Lightroom Classic are exactly the same on both systems, but on the iMac, it is not working.  Even the prview is saying "Preview unavailable for this file".

 

Here's the LRC system info:

 

Lightroom Classic version: 9.3 [ 202005281810-476e492c ]
License: Creative Cloud
Language setting: en-US
Operating system: Mac OS 10
Version: 10.15.5 [19F101]
Application architecture: x64
Logical processor count: 4
Processor speed: 3.2 GHz
SqLite Version: 3.30.1
Built-in memory: 24,576.0 MB
Real memory available to Lightroom: 24,576.0 MB
Real memory used by Lightroom: 1,149.1 MB (4.6%)
Virtual memory used by Lightroom: 10,281.1 MB
Memory cache size: 0.0MB
Internal Camera Raw version: 12.3 [ 493 ]
Maximum thread count used by Camera Raw: 3
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 1MB / 12287MB (0%)
Camera Raw real memory: 2MB / 24576MB (0%)
Displays: 1) 2560x1440

Graphics Processor Info:
Metal: NVIDIA GeForce GT 755M

 

Application folder: /Applications/Adobe Lightroom Classic
Library Path: /Volumes/TC006-WD-2019/TCMedia/Pictures/Lightroom/LR Catalog Main A-2.lrcat
Settings Folder: /Users/tim/Library/Application Support/Adobe/Lightroom

Installed Plugins:
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Aurora HDR 2017
4) Export to Photomatix Pro
5) Facebook
6) Flickr
7) Nikon Tether Plugin
8) Teekesselchen

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: $$$/dvaaudiodevice/SystemDefaultAndEffectiveDeviceName=System Default (Built-in Output)#{comment}DVAAU-4201250: Open the audio hardware preferences page.
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100

 

 

I appreciate any help on solving this.  

 

 

I have SOLVED THIS ! 

 

The main cause I think was the association of .mp4 to VLC player and not the default Quicktime Player.  I had to reset it back to the standard association.   It seems LRC may be using QuickTime libraries to display the video.

 

I fixed my problem the long way (see steps later).  You can try for the shortcut / Hail-Mary pass - by resetting your .MP4 association back to QuickTime Player.  You can even try deleting the VLC Player jsut to be safe.   How to change the association ?  In Finder app, look for a .mp4 file.  Do right-mouse click and select "Get Info".  About midway - look for "Open With", and change it to QuickTIme Player.  It will ask if you want to Apply to all .MP4 files, and you select yes.   If that doesn't work - follow the steps below.

 

How I did it the long way (in OSX iMac):

1.  Backup your Lightroom library.

2.  Delete Lightroom App by moving to trash -

    - See additional manual steps at https://osxuninstaller.com/uninstall-guides/uninstall-lightroom-remove-traces-mac/

3.  Download Cleanup tool from Adobe and run that

4.  Rebooted.  Deleted my video VLC Player.  Reassociated with Quicktime. (see above on the steps)

5.  Download and reinstalled LR Classic.  Open back your saved Library with LRC.

 

and it works !  It imports my DJI videos and even plays them.  The old MP4s ones in my Library before the problem started - also plays.

 

I will no longer change the default association for .MP4s in OSX.

 

Good luck.

TOPICS
Bug, Import and export, Mac, Problem or error

Views

75

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Cannot import MP4 from DJI Mavic 2 Pro on iMac

Jul 06, 2020

Copy link to clipboard

Copied

I'm getting this error on just the videos from my Mavic 2 Pro when I try to import into my iMac - late 2013 3.2 Ghz Quad Core i5 on Catalina 10.15.5 OSX:

 

tcworldtraveler_0-1594097916795.png

 

However I can import perfectly fine on my newer Macbook Pro 16".  The versions of OSX and Lightroom Classic are exactly the same on both systems, but on the iMac, it is not working.  Even the prview is saying "Preview unavailable for this file".

 

Here's the LRC system info:

 

Lightroom Classic version: 9.3 [ 202005281810-476e492c ]
License: Creative Cloud
Language setting: en-US
Operating system: Mac OS 10
Version: 10.15.5 [19F101]
Application architecture: x64
Logical processor count: 4
Processor speed: 3.2 GHz
SqLite Version: 3.30.1
Built-in memory: 24,576.0 MB
Real memory available to Lightroom: 24,576.0 MB
Real memory used by Lightroom: 1,149.1 MB (4.6%)
Virtual memory used by Lightroom: 10,281.1 MB
Memory cache size: 0.0MB
Internal Camera Raw version: 12.3 [ 493 ]
Maximum thread count used by Camera Raw: 3
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 1MB / 12287MB (0%)
Camera Raw real memory: 2MB / 24576MB (0%)
Displays: 1) 2560x1440

Graphics Processor Info:
Metal: NVIDIA GeForce GT 755M

 

Application folder: /Applications/Adobe Lightroom Classic
Library Path: /Volumes/TC006-WD-2019/TCMedia/Pictures/Lightroom/LR Catalog Main A-2.lrcat
Settings Folder: /Users/tim/Library/Application Support/Adobe/Lightroom

Installed Plugins:
1) AdobeStock
2) Aperture/iPhoto Importer Plug-in
3) Aurora HDR 2017
4) Export to Photomatix Pro
5) Facebook
6) Flickr
7) Nikon Tether Plugin
8) Teekesselchen

Config.lua flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: $$$/dvaaudiodevice/SystemDefaultAndEffectiveDeviceName=System Default (Built-in Output)#{comment}DVAAU-4201250: Open the audio hardware preferences page.
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100

 

 

I appreciate any help on solving this.  

 

 

I have SOLVED THIS ! 

 

The main cause I think was the association of .mp4 to VLC player and not the default Quicktime Player.  I had to reset it back to the standard association.   It seems LRC may be using QuickTime libraries to display the video.

 

I fixed my problem the long way (see steps later).  You can try for the shortcut / Hail-Mary pass - by resetting your .MP4 association back to QuickTime Player.  You can even try deleting the VLC Player jsut to be safe.   How to change the association ?  In Finder app, look for a .mp4 file.  Do right-mouse click and select "Get Info".  About midway - look for "Open With", and change it to QuickTIme Player.  It will ask if you want to Apply to all .MP4 files, and you select yes.   If that doesn't work - follow the steps below.

 

How I did it the long way (in OSX iMac):

1.  Backup your Lightroom library.

2.  Delete Lightroom App by moving to trash -

    - See additional manual steps at https://osxuninstaller.com/uninstall-guides/uninstall-lightroom-remove-traces-mac/

3.  Download Cleanup tool from Adobe and run that

4.  Rebooted.  Deleted my video VLC Player.  Reassociated with Quicktime. (see above on the steps)

5.  Download and reinstalled LR Classic.  Open back your saved Library with LRC.

 

and it works !  It imports my DJI videos and even plays them.  The old MP4s ones in my Library before the problem started - also plays.

 

I will no longer change the default association for .MP4s in OSX.

 

Good luck.

TOPICS
Bug, Import and export, Mac, Problem or error

Views

76

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 06, 2020 0
Jul 10, 2020

Copy link to clipboard

Copied

If you upload a sample video to Dropbox or similar and post the sharing link here, we can see if the same issue occurs on other installations or is specific to your computer.

 

[Use the blue reply button under the first post to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 10, 2020 0
Sep 12, 2020

Copy link to clipboard

Copied

Here's the link:   https://www.dropbox.com/s/tpd3qhzct2hs188/DJI_0319.MP4?dl=0

 

Got a bit busy due to Calif fires, but hope someone can help solve this.

 

Tim.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 12, 2020 0
Oct 06, 2020

Copy link to clipboard

Copied

I have SOLVED THIS ! 

 

The main cause I think was the association of .mp4 to VLC player and not the default Quicktime Player.  I had to reset it back to the standard association.   It seems LRC may be using QuickTime libraries to display the video.

 

I fixed my problem the long way (see steps later).  You can try for the shortcut / Hail-Mary pass - by resetting your .MP4 association back to QuickTime Player.  You can even try deleting the VLC Player jsut to be safe.   How to change the association ?  In Finder app, look for a .mp4 file.  Do right-mouse click and select "Get Info".  About midway - look for "Open With", and change it to QuickTIme Player.  It will ask if you want to Apply to all .MP4 files, and you select yes.   If that doesn't work - follow the steps below.

 

How I did it the long way (in OSX iMac):

1.  Backup your Lightroom library.

2.  Delete Lightroom App by moving to trash -

    - See additional manual steps at https://osxuninstaller.com/uninstall-guides/uninstall-lightroom-remove-traces-mac/

3.  Download Cleanup tool from Adobe and run that

4.  Rebooted.  Deleted my video VLC Player.  Reassociated with Quicktime. (see above on the steps)

5.  Download and reinstalled LR Classic.  Open back your saved Library with LRC.

 

and it works !  It imports my DJI videos and even plays them.  The old MP4s ones in my Library before the problem started - also plays.

 

I will no longer change the default association for .MP4s in OSX.

 

Good luck.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2020 0