Highlighted

Connecting to Dynamic Link Server Failed

Enthusiast ,
May 16, 2020

Copy link to clipboard

Copied

This mostly happens with .mov and .mp4 files. And, come to think of it, large photoshop files. Anyway. no matter what I did to a .mov file, recently (it will play in quicktime; it will play in premiere pro, it will play in Compressor and VLC. I can take it through those programs and re-export it. No matter what I do, Lightroom doesn't like it. And if it was only this file. But there are lots of them. And lots and lots.

P.S. I've tried the following, too. Which I found in Adobe Support. (it didn't work).

 Correct answer by Gordon-Boloman (NOT FOR ME)

Adobe support fixed my issue On a Mac doing the following:

Quit LR

From the Finder type: (CMD-SHIFT_G) OR from GO Menu

Enter path: ~/Library/Preferences/Adobe/

Rename the following folders with a .old OR delete the directory

dynamiclinkmediaserver

dynamiclinkmanager

DyanmicLinkMediaServer

Open LR and Import Video files as usual. Worked for me!

 

Topics

How to, Import and export

Views

543

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Connecting to Dynamic Link Server Failed

Enthusiast ,
May 16, 2020

Copy link to clipboard

Copied

This mostly happens with .mov and .mp4 files. And, come to think of it, large photoshop files. Anyway. no matter what I did to a .mov file, recently (it will play in quicktime; it will play in premiere pro, it will play in Compressor and VLC. I can take it through those programs and re-export it. No matter what I do, Lightroom doesn't like it. And if it was only this file. But there are lots of them. And lots and lots.

P.S. I've tried the following, too. Which I found in Adobe Support. (it didn't work).

 Correct answer by Gordon-Boloman (NOT FOR ME)

Adobe support fixed my issue On a Mac doing the following:

Quit LR

From the Finder type: (CMD-SHIFT_G) OR from GO Menu

Enter path: ~/Library/Preferences/Adobe/

Rename the following folders with a .old OR delete the directory

dynamiclinkmediaserver

dynamiclinkmanager

DyanmicLinkMediaServer

Open LR and Import Video files as usual. Worked for me!

 

Topics

How to, Import and export

Views

544

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Enthusiast ,
May 17, 2020

Copy link to clipboard

Copied

FOUND THIS AND IT WORKED FOR ME.  

https://community.adobe.com/t5/lightroom-classic/import-error-connecting-to-dynamic-link-server-fail...SOLVED FOR ME -> For what it's worth, I was attempting to import 1000's of video files (short ones) into lightroom among my many photos and had the same issue.

After numerours trial and errors, the issues were only a few movie files that had 0sec run time.
These were basically video files I started and stopped right away for whatever reason.

It appears that adobe does not like that at all,especially when they are among many good video files, it will simply fail the complete import.

On a mac I ran the following command in terminal on the folder from where I was importing the files (

find . -type f -size -100000c)

to figure out which file sizes were below a certain value, and indeed based on that I tested the particular video files and these were all the 0sec videos. THERE IS A TRICK HOWEVER!, my process in case it got stuck again was:

1) Light room > Preferences > PURGE ALL CACHES.
2) Close Light room
3) Activity Monitor > Kill dynamiclinkmanager and dynamiclinkmediaserver
4) Start Light Room again
6) Import only the video files that DON'T have a 0sec Run time

Hope it helps someone

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...