Corrupted CR2 files with Lightroom

New Here ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

Hello there,

i have a corrupted CR2 files troubles. For long time, i used lightroom 6 with no problems at all. My camera are Canon EOS 1DX. But since last week, i acquired the new Canon EOS 1DX Mark 3 (cost me my right kidney!!), which uses CR3 files. So ive decided to update lightroom and now i use Lightroom Classic for PC. Since then, when i download CR2 files, i have corrupted files (only 2 or 3 photos), but AFTER the download in Lightroom. On the Canon camera screen, all photos appear to be correct, and even if i read the card with another software, like Fastone reader, the files are all still correct. Here what i've got, and only in Lightroom (version 10):_R7P7164.jpg

 

It happened with 2 different compact flash cards (Sandisk extreme pro 64 gb). And like i said, it never happened with old lightroom version.

Help me guys (and girls), you're my only hope...

TOPICS
Problem or error

Views

60

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

Your post is a bit confusing as you mention EOS 1DX MkIII which creates CR3 files but then go on to write that some downloaded CR2 files are corrupt. That being said, corruption of the type displayed in your example is usually due to a hardware issue, which in this case 'may' be the card reader or the USB cable. Can you try another card reader and/or USB cable?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2020 Oct 22, 2020

Copy link to clipboard

Copied

Hi,

sorry if i was not enough clear, but, even if i have a new camera, im using both of them, each one with a different zoom, so i download in lightroom both CR2 files and CR3 files. And i can tell that its NOT a hardware issue. Here's why: I just tried something: i copied / pasted the supposed corrupted CR2 files directly from the compact flash card, using the same card reader, then i launched Lighroom. in the Library, the  photo looks still corrupted, but once im in the develop module, i click on the preview corrupted photos, and hop! it changes into a fine photo which is no longer corrupted. How about that? For me, its a bug in the Matri..., in Lightroom, i mean.

_R7P7164-1.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

 

On the Canon camera screen, all photos appear to be correct

 

When you do that you are looking at an embedded JPEG file, not the RAW data. The JPEG can be just fine while the RAW data is corrupt.

 

Many viewer apps look at that JPEG not the RAW.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2020 Oct 22, 2020

Copy link to clipboard

Copied

No, i always look the Raw files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

Have you tried outside of LrC, deleting the preview files?

When you restart LrC, they will get recreated.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 22, 2020 Oct 22, 2020

Copy link to clipboard

Copied

you are right! i copied / paste the corrupted photos, directly from the compact flash card, and after launching lightroom again, the files are no longer corrupted, but only in the devellop module. they still look like corrupted in the library module.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 22, 2020 Oct 22, 2020

Copy link to clipboard

Copied

What was right?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 22, 2020 Oct 22, 2020

Copy link to clipboard

Copied

LATEST

Apparently some are finding that purging the ACR helps. In /preferences/performance/ purge the CACHE. Restart LrC.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 21, 2020 Oct 21, 2020

Copy link to clipboard

Copied

While probably a corrupt RAW, have you tried a different card reader?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines