Does Lightroom Classic work with Big Sur?

Adobe Employee ,
Nov 11, 2020

Copy link to clipboard

Copied

macOS Big Sur (version 11)macOS Big Sur (version 11)

With the release of macOS big Sur (version 11), you may wonder if Lightroom Classic is compatible, or if you should wait to install the new OS update.

 

For upgrade recommendations and a list of known issues that we're aware of thus far, see Lightroom Classic and Big Sur | macOS 11.

 

If you run into any issues while using Lightroom Classic in Big Sur that are not listed in the above article, please let us know here in the Lightroom Classic community.

TOPICS
Announcement, FAQ

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Does Lightroom Classic work with Big Sur?

Adobe Employee ,
Nov 11, 2020

Copy link to clipboard

Copied

macOS Big Sur (version 11)macOS Big Sur (version 11)

With the release of macOS big Sur (version 11), you may wonder if Lightroom Classic is compatible, or if you should wait to install the new OS update.

 

For upgrade recommendations and a list of known issues that we're aware of thus far, see Lightroom Classic and Big Sur | macOS 11.

 

If you run into any issues while using Lightroom Classic in Big Sur that are not listed in the above article, please let us know here in the Lightroom Classic community.

TOPICS
Announcement, FAQ

Views

1.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 11, 2020 1
New Here ,
Nov 13, 2020

Copy link to clipboard

Copied

Once clicked on Tethering, it just quit without any error messages

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 13, 2020 0
New Here ,
Nov 13, 2020

Copy link to clipboard

Copied

struggling to use LRC slideshow in any way shape or form!! Keeps crashing - adobe help have been no help 😞

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 13, 2020 1
New Here ,
Nov 15, 2020

Copy link to clipboard

Copied

I am now using a separate catalogue for each job and this seems to be working now. Guess let was overwhelmed. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 15, 2020 0
Adobe Community Professional ,
Nov 13, 2020

Copy link to clipboard

Copied

Upgraded my iMac today to Big Sur, experienced no issues. I have not been experiences problems with LrC 10 on macOS 10.15.7 and things appear to be functioning as normal. No issues on start up, no freeze or crash, no issues with GPU which is fully supported. I work almost exclusively with raw files from my camera and the edit in PS function works as expected.

Hope the nagging issues presently being experienced by a number of users will get resolved soon.

My system and equipment info is in my signature.

 

Regards, Denis: System iMac mid-2015, 5K 27”, Ram 24GB, HDD 3TB, macOS 11.1, LrC 10.1 (>10.0), Lr 4.1, Ps 22.1, Pr 14.8.0; Camera OM-D E-M1.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 13, 2020 0
Community Beginner ,
Nov 14, 2020

Copy link to clipboard

Copied

Bad news for me. I put a message up elsewhere hoping there is an answer.
 Screen Shot 2020-11-14 at 12.28.50 PM.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 14, 2020 0
New Here ,
Nov 14, 2020

Copy link to clipboard

Copied

I get the same error, but it is funky. Sometimes it works, and sometimes it does not. I have been on Big Sur betas since May, and now on RC 11.0.1, and Adobe is updated as well. For the longest time there were no problems at all, only lately, the last two weeks have I experienced the "Unexpected error opening catalog". Sometimes it works if I reboot, and sometimes it works if I create a new library, and then change to one of my old ones.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 14, 2020 0
New Here ,
Nov 28, 2020

Copy link to clipboard

Copied

In my case, sometimes it works and sometimes not...

It is very unpleasant when this happens, you have to restart the Mac. Quickly an update, it’s not as if Adobe knew it for months... I want to pay but for a sevice that works and updated!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 28, 2020 0
New Here ,
Dec 26, 2020

Copy link to clipboard

Copied

Same here,

As a photographer I manage my work in several catalogi, but failing to load, apparantly since upgrade to Big Sur.

With assistance of Adobe support, created new calatogue; that worked for a while. Now again, some catalogues work, others don't.

This is now jeopordising my work as it continues to fail and I cannot deliver my products to clients. I haven't seen an ETA for expected resolution by Adobe and reading this user community doesn't give me confidence in anything soon. Guidance appreciated.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 26, 2020 0
Community Beginner ,
Nov 14, 2020

Copy link to clipboard

Copied

I have Lightroom 6.14 and MBP 13" Early 2015. After installing (yesterday) Big Sur Lightroom has white banner top of the picture in develop mode. I won't get to disappear that banner.

 

Näyttökuva 2020-11-15 kello 9.21.31.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 14, 2020 0
New Here ,
Nov 16, 2020

Copy link to clipboard

Copied

Hi there, 

 

I faced the same issue and got it resolved by going in the Develop mode (D), selecting the menu View>View Options... and unticking the option "Show info overlay". 

 

I hope this helps !

Best

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 0
Community Beginner ,
Nov 16, 2020

Copy link to clipboard

Copied

Wow, it works! Thank you! There is still a small white banner but it doesn't matter.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 16, 2020 1
Community Beginner ,
Nov 19, 2020

Copy link to clipboard

Copied

Interesting I was told that ligthroom 6.14 no way will work with Big Sur!,,,, I use 6.14 on a MacBook Pro with Mojave. Received this week a new iMac with Big Sur and I did not load ligthroom 6.14 because I was told that woul not work.  Is it working ok for you ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 19, 2020 0