Error installing LR4 - digital signature is not trusted

Aug 17, 2020

Copy link to clipboard

Copied

Trying to install my old 4.0 version of Lightroom on my macBook Air and receive the error:  "Adobe Photoshop Lightroom 4.pkg can’t be installed because its digital signature is not trusted."

 

I have searched other posts and tried a few suggestions but have not been successfull.

 

Any  ideas?

While LR v4 may be a 64bit app, the installer is not. The installer is 32bit.

 

You can not run a 32bit app in Catalina.

 

TOPICS
Download and install

Views

211

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Error installing LR4 - digital signature is not trusted

Aug 17, 2020

Copy link to clipboard

Copied

Trying to install my old 4.0 version of Lightroom on my macBook Air and receive the error:  "Adobe Photoshop Lightroom 4.pkg can’t be installed because its digital signature is not trusted."

 

I have searched other posts and tried a few suggestions but have not been successfull.

 

Any  ideas?

While LR v4 may be a 64bit app, the installer is not. The installer is 32bit.

 

You can not run a 32bit app in Catalina.

 

TOPICS
Download and install

Views

212

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 17, 2020 0
Aug 17, 2020

Copy link to clipboard

Copied

Which version of MacOS is running on your MacBook?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2020 0
Aug 17, 2020

Copy link to clipboard

Copied

macOS Catalina 10.15.6

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2020 0
Aug 17, 2020

Copy link to clipboard

Copied

Lightroom 4 cannot be installed on Catalina.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2020 1
Aug 17, 2020

Copy link to clipboard

Copied

While LR v4 may be a 64bit app, the installer is not. The installer is 32bit.

 

You can not run a 32bit app in Catalina.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2020 1
Aug 17, 2020

Copy link to clipboard

Copied

Boot into an older OS that CAN support a 32-bit installer (like Mojave), install, then you should be able to run LR, at least I can run LR5, under Catalina. LR4? Maybe, maybe not. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 17, 2020 0