Highlighted

Export presets no longer remembering location

Community Beginner ,
Aug 24, 2020

Copy link to clipboard

Copied

I have only just encountered this problem so I am not sure when it started.

 

In the past export presets remembered the location set in the preset.  This no longer works.

 

Please fix, or am I doing something wrong?

 

Anyone else noticed this?

Correct answer by lensschool | Community Beginner

Thank you for all your support and suggestions...

With a bit of experiementation I figured out that the preset was corrupt.  So on deleting the preset and making new ones all worked again as it used too.

It seems it was a corrupt preset.

Topics

Problem or error

Views

86

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Export presets no longer remembering location

Community Beginner ,
Aug 24, 2020

Copy link to clipboard

Copied

I have only just encountered this problem so I am not sure when it started.

 

In the past export presets remembered the location set in the preset.  This no longer works.

 

Please fix, or am I doing something wrong?

 

Anyone else noticed this?

Correct answer by lensschool | Community Beginner

Thank you for all your support and suggestions...

With a bit of experiementation I figured out that the preset was corrupt.  So on deleting the preset and making new ones all worked again as it used too.

It seems it was a corrupt preset.

Topics

Problem or error

Views

87

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

Post your LR and brief OS specs thanks.

In the meanwhile this might help if it fits your issue, but it might depend on your current LR version.

 

Plugin to reset Presets & "Manage Presets"
Lightroom Classic doe not organise presets in physical folders anymore. You can organise them in groups in the presets panel like before, but you do that by using the 'Manage Presets' option within Lightroom. If you want the old behavior back, look at this plugin: http://www.johnrellis.com/lightroom/fixpresets.htm

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 25, 2020

Copy link to clipboard

Copied

Lightroom 9.4 release

 

Mac OS Catalina version 10.15.6

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

"In the past export presets remembered the location set in the preset."

 

What do you mean with 'location set'? Export plugins can either export to a specific folder, or leave it to you to choose the folder on export. Both still work.

-- Johan W. Elzenga, http://www.johanfoto.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 25, 2020

Copy link to clipboard

Copied

Prior to presets... I used to set a specific location folder and it would remain embedded in the preset.  I have two presets I use regularly... one is 2500 px and they live in a folder in my hard drive called 2500 px photographs.  I have a different preset called full size jpgs for printing, which I have set to go to a folder on my hard drive called 'Full sized jpgs for printing'.

 

I used to be able to click on one, export and then later click on the other and export, then back to the first and export and the exports would turn up in the right folders as specified in the preset.

 

Now, each time I choose the preset, I have to go back and navigate to the folder again. The preset does not remember the destination folder any more... I remembers the last one I used, despite which preset I use.  This behaviour has clearly changed recently. Though I am not sure with which build of lightroom it changed.

 

Thanks in advance...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

Can you show screenshots of these two presets? It should still work and does on my systems.

-- Johan W. Elzenga, http://www.johanfoto.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

Unexplained issues like this are often due to a corrupted LR Preferences file. Close LR and move the below Preferences file to your desktop so you can restore it if the issue persists. Restart LR and it will create a new Preferences file with default settings. Try the export presets again. If this fixes the issue you will need to reinstall your plugins and update your Preferences settings with any changes you made previously.

 

Windows—C: \ Users \ [your username] \ AppData \ Roaming \ Adobe \ Lightroom \ Preferences \ Lightroom Classic CC 7 Preferences.agprefs

 

Mac—Macintosh HD / Users / [your username] / Library / Preferences / com.adobe.LightroomClassicCC7.plist

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

Coming into this late but....

The OP is talking about presets, some are talking plug-ins. 

Presets can be found in one of two locations depending on preferences and OS. 

I always use "Store Presets with Catalog" preference and that's where they live. If I turn off that preference, then it isn't. 

There's also the issue of a Save location being sticky (and at least on MacOS, some use utilities like Default Folder X) that can override the OS. 

I agree that this still works so it could be 'user error' or something else but the preferences play a role as to where and how LR 'sees' presets.

FYI, on my Mac, using Symbolic Links makes finding and backing this all up really easy. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

Thanks so much... I have been exploring and playing....

It is only one preset that is forgetting the location file....

So I will try this fix tomorrow and create new presets...

 

Here is a screen shot..

 

I want the folder that was added as part of the preset to remain the same when I come back to the preset.  It should revert to the one in the preset, but it doesn't.... it stays on the last used one.  It is particular to one preset in I think..

 

Thank you.. I will try reseting the presets by removing the file and starting again.. and let you know how I go.

 

Screen Shot 2020-08-26 at 7.35.53 pm.pngScreen Shot 2020-08-26 at 7.35.30 pm.pngScreen Shot 2020-08-26 at 7.35.11 pm.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 26, 2020

Copy link to clipboard

Copied

The, Your, problem is with the newer LrC Export dialog you have to place a Check Mark in the box to the left of the Preset you want to use. Just Selecting, Highlighting, it doesn't work the same as it did before.

 

So for a Test place a check mark in the box to the left of one of those presets and then click the Export button.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 26, 2020

Copy link to clipboard

Copied

"Just Selecting, Highlighting, it doesn't work the same as it did before."

 

No, that isn't true. You only have to click the checkbox if you want to do a batch export, using more than one preset at the same time. Some presets cannot even be checked (the 'For Email' preset, for example). If you want to export an image using one single preset, then highlighting it should work as before. And -of course- you can still use the menu 'Export with preset'.

 

I noticed that all three presets are using synced folders as their destination. Two use the Creative Cloud Files folder, and the third one uses Apple's iCloud Drive synced folder. I wonder if that could be a reason, but it shouldn't be a problem. Except of course if the path to the folder is no longer valid! Could that be it? Did the username change, for example?

 

 

-- Johan W. Elzenga, http://www.johanfoto.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

If I understand it correctly (and I did ask the OP to explain it better), then the OP is not talking about the location of presets (or plugins) but about the location where an export preset saves the exported image.

-- Johan W. Elzenga, http://www.johanfoto.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 25, 2020

Copy link to clipboard

Copied

So when I use Context Menu, select a User Preset and select Export... the location is sticky; the last place I located for such a save from LR (not necessarily from another application also locating to a folder):

 

SaveLocation.jpg

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Aug 26, 2020

Copy link to clipboard

Copied

That is not what I think the OP means. I believe he means this: he has specified a specific folder in an export preset, and for some reason the export preset now does not save the exported image in that folder anymore, or it asks to select a folder. I'll let him reply however, because we are only speculating and (possibly) giving irrelevant answers.

-- Johan W. Elzenga, http://www.johanfoto.com

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Aug 26, 2020

Copy link to clipboard

Copied

Thank you for all your support and suggestions...

With a bit of experiementation I figured out that the preset was corrupt.  So on deleting the preset and making new ones all worked again as it used too.

It seems it was a corrupt preset.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Aug 26, 2020

Copy link to clipboard

Copied

Good job figuring out how to fix it.  I had this exact same problem a few months ago.  All of my export presets had folder locations pre-programmed and yet they would still ask me every time to select a folder for the exported images.  Didn't make any sense.  I ended up recreating all of them and the weird behavior stopped.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...