Highlighted

GPU Acceleration (processing) first worked, now its grayed out!?

New Here ,
Sep 24, 2019

Copy link to clipboard

Copied

Hello community, 

i own an iMac 2014 ultimo with max specs. The Radeon R9 295X is metal-compatible and for 4 weeks after release I was surprised over the great performance with the GPU boost image processing. However, I had to manually activate it with the custom settings.

Now After the 8.4.1 Update I cant use the GPU anymore. So I downgraded to 8.4 and surprisingly it doenst work also, its grayed out. Im 100% sure it worked fine before, so i dont know where the problem is. 

 

Can you help? 

Have a nice one and thank you.

Bildschirmfoto 2019-09-24 um 20.21.45.png

Topics

Bug, Mac, Performance

Views

446

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

GPU Acceleration (processing) first worked, now its grayed out!?

New Here ,
Sep 24, 2019

Copy link to clipboard

Copied

Hello community, 

i own an iMac 2014 ultimo with max specs. The Radeon R9 295X is metal-compatible and for 4 weeks after release I was surprised over the great performance with the GPU boost image processing. However, I had to manually activate it with the custom settings.

Now After the 8.4.1 Update I cant use the GPU anymore. So I downgraded to 8.4 and surprisingly it doenst work also, its grayed out. Im 100% sure it worked fine before, so i dont know where the problem is. 

 

Can you help? 

Have a nice one and thank you.

Bildschirmfoto 2019-09-24 um 20.21.45.png

Topics

Bug, Mac, Performance

Views

447

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Sep 24, 2019

Copy link to clipboard

Copied

Hi there,

 

The option to use the Graphic processor for image processing has been recently added to Lightroom classic in version 8.4. Prior to this, till version 8.3.1 the option for only available for Graphic acceleration. Please check the below mentioned link.

https://helpx.adobe.com/lightroom-classic/help/whats-new/2019-4.html

 

Would you mind sharing the macOS version that you are currently using and check if there is an update available for the macOS since the drivers of Graphic cards on Mac are installed with the OS updates.

 

Regards

Nikunj

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Sep 24, 2019

Copy link to clipboard

Copied

Im using the latest Version mac OS 10.14.6 and the Graphic processor for image worked fine in Lightroom 8.4 for about 4 weeks. After the 8.4.1. Update i cant use the "Graphic processor for image" (option is grayed out). A downgrade back to v8.4 didnt help here. MacOS version wasnt updated in meantime (its still the latest). Is this a Bug?

Lightroom Classic-Version: 8.4.1 [ 201909111355-eb9b68f0 ]
Lizenz: Creative Cloud
Spracheinstellung: de-DE
Betriebssystem: Mac OS 10
Version: 10.14.6 [18G95]
Anwendungsarchitektur: x64
Anzahl logischer Prozessoren: 8
Prozessorgeschwindigkeit: 4,0 GHz
Integrierter Speicher: 32.768,0 MB
Für Lightroom verfügbarer phys. Speicher: 32.768,0 MB
Von Lightroom verwendeter phys. Speicher: 1.884,4 MB (5,7%)
Von Lightroom verwendeter virtueller Speicher: 6.296,0 MB
Cache-Speichergröße: 109,3MB
Interne Camera Raw-Version: 11.4.1 [ 291 ]
Maximale Anzahl Threads, die Camera Raw verwendet: 5
Camera Raw SIMD-Optimierung: SSE2,AVX,AVX2
Virtueller Speicher in Camera Raw: 288MB / 16383MB (1%)
Physischer Speicher in Camera Raw: 289MB / 32768MB (0%)
Monitore/Anzeigegeräte: 1) 5120x2880

Informationen zum Grafikprozessor: 
Metal: AMD Radeon R9 M295X



Anwendungsordner: /Applications/Adobe Lightroom Classic
Bibliothekspfad: /Users/osman/Pictures/Lightroom/Lightroom.lrcat
Einstellungen-Ordner: /Users/osman/Library/Application Support/Adobe/Lightroom

Installierte Zusatzmodule: 
1) AdobeStock
2) Aperture/iPhoto-Import-Zusatzmodul
3) Facebook
4) Flickr
5) HDR Efex Pro 2
6) Nikon Tether-Zusatzmodul

Config.lua-Flags: None

AudioDeviceIOBlockSize: 512
AudioDeviceName: Ausgang (integriert)
AudioDeviceNumberOfChannels: 2
AudioDeviceSampleRate: 44100
Build: 12.1x4
CoreImage: true
GL_ACCUM_ALPHA_BITS: 0
GL_ACCUM_BLUE_BITS: 0
GL_ACCUM_GREEN_BITS: 0
GL_ACCUM_RED_BITS: 0
GL_ALPHA_BITS: 8
GL_BLUE_BITS: 8
GL_DEPTH_BITS: 24
GL_GREEN_BITS: 8
GL_MAX_3D_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_SIZE: 16384
GL_MAX_TEXTURE_UNITS: 8
GL_MAX_VIEWPORT_DIMS: 16384,16384
GL_RED_BITS: 8
GL_RENDERER: AMD Radeon R9 M295X OpenGL Engine
GL_SHADING_LANGUAGE_VERSION: 1.20
GL_STENCIL_BITS: 8
GL_VENDOR: ATI Technologies Inc.
GL_VERSION: 2.1 ATI-2.11.20
OGLEnabled: true
GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture GL_ARB_draw_buffers GL_ARB_draw_elements_base_vertex GL_ARB_draw_instanced GL_ARB_fragment_program GL_ARB_fragment_program_shadow GL_ARB_fragment_shader GL_ARB_framebuffer_object GL_ARB_framebuffer_sRGB GL_ARB_half_float_pixel GL_ARB_half_float_vertex GL_ARB_imaging GL_ARB_instanced_arrays GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_pixel_buffer_object GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_provoking_vertex GL_ARB_seamless_cube_map GL_ARB_shader_objects GL_ARB_shader_texture_lod GL_ARB_shading_language_100 GL_ARB_shadow GL_ARB_shadow_ambient GL_ARB_sync GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_compression_rgtc GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_crossbar GL_ARB_texture_env_dot3 GL_ARB_texture_float GL_ARB_texture_mirrored_repeat GL_ARB_texture_non_power_of_two GL_ARB_texture_rectangle GL_ARB_texture_rg GL_ARB_transpose_matrix GL_ARB_vertex_array_bgra GL_ARB_vertex_blend GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_bindable_uniform GL_EXT_blend_color GL_EXT_blend_equation_separate GL_EXT_blend_func_separate GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_clip_volume_hint GL_EXT_debug_label GL_EXT_debug_marker GL_EXT_depth_bounds_test GL_EXT_draw_buffers2 GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_framebuffer_blit GL_EXT_framebuffer_multisample GL_EXT_framebuffer_object GL_EXT_framebuffer_sRGB GL_EXT_geometry_shader4 GL_EXT_gpu_program_parameters GL_EXT_gpu_shader4 GL_EXT_multi_draw_arrays GL_EXT_packed_depth_stencil GL_EXT_packed_float GL_EXT_provoking_vertex GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_stencil_two_side GL_EXT_stencil_wrap GL_EXT_texture_array GL_EXT_texture_compression_dxt1 GL_EXT_texture_compression_s3tc GL_EXT_texture_env_add GL_EXT_texture_filter_anisotropic GL_EXT_texture_integer GL_EXT_texture_lod_bias GL_EXT_texture_mirror_clamp GL_EXT_texture_rectangle GL_EXT_texture_shared_exponent GL_EXT_texture_sRGB GL_EXT_texture_sRGB_decode GL_EXT_timer_query GL_EXT_transform_feedback GL_EXT_vertex_array_bgra GL_APPLE_aux_depth_stencil GL_APPLE_client_storage GL_APPLE_element_array GL_APPLE_fence GL_APPLE_float_pixels GL_APPLE_flush_buffer_range GL_APPLE_flush_render GL_APPLE_object_purgeable GL_APPLE_packed_pixels GL_APPLE_pixel_buffer GL_APPLE_rgb_422 GL_APPLE_row_bytes GL_APPLE_specular_vector GL_APPLE_texture_range GL_APPLE_transform_hint GL_APPLE_vertex_array_object GL_APPLE_vertex_array_range GL_APPLE_vertex_point_size GL_APPLE_vertex_program_evaluators GL_APPLE_ycbcr_422 GL_ATI_blend_equation_separate GL_ATI_blend_weighted_minmax GL_ATI_separate_stencil GL_ATI_texture_compression_3dc GL_ATI_texture_env_combine3 GL_ATI_texture_float GL_ATI_texture_mirror_once GL_IBM_rasterpos_clip GL_NV_blend_square GL_NV_conditional_render GL_NV_depth_clamp GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_texgen_reflection GL_NV_texture_barrier GL_SGI_color_matrix GL_SGIS_generate_mipmap GL_SGIS_texture_edge_clamp GL_SGIS_texture_lod 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Contributor ,
Sep 13, 2020

Copy link to clipboard

Copied

I am having the same issue.  Did an event and my computer's fan is going going.  Not a usual activity.  I cannot use the on board graphics.  This is a key issue.  Seems odd to me that Adobe allows these things to happen.

 

2015 MBP with Metal Iris Pro.

 

Grace and peace. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 13, 2020

Copy link to clipboard

Copied

Ok, so you are using macOS 10.14.6 and LrC 8.4.1?

LrC does not support GPU for all systems and graphic cards.

Another point that is relevant is there was an update in LrC 8.4 to the GPU feature that may be the cause of the change that you experience. 

  • 8.4 (August 2019) – Advanced GPU Improvements, Batch HDR/Panorama Merges, Book Auto-Create Cell, Export as PNG, Collection panel Color Labels, Filmstrip Index Numbers.

 

Regards, Denis: System iMac mid-2015, 5K 27” monitor, macOS10.15.6: LrC 9.4, Lr 3.4.1, Ps 21.2.2, Camera OM-D E-M1.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 13, 2020

Copy link to clipboard

Copied

Denis, I refer you to a previous discussion I had with this person. I don't know how to help him, and he's looking for real answers.

https://community.adobe.com/t5/lightroom-classic/gpu-grayed-out/td-p/11429685?page=1

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Sep 13, 2020

Copy link to clipboard

Copied

Ok thanks for the heads up I now see the post he started yesterday.

Regards, Denis: System iMac mid-2015, 5K 27” monitor, macOS10.15.6: LrC 9.4, Lr 3.4.1, Ps 21.2.2, Camera OM-D E-M1.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Contributor ,
Sep 13, 2020

Copy link to clipboard

Copied

The answer is I spoke with Adobe.

 

There appears to be a slight misinterpretation with the wording in Lr.  When “auto” is chosen, it says “basic” acceleration is enabled.  However, when in Ps, advanced is enabled.

 

Before the change I used the manual way with custom.  But this feature doesn’t seem to be enabled in the current version of Lr.

 

The list of compatible GPUs does list the one in my machine.  Plus, the additional checking via Ps reveals this.

 

So, the answer is use “auto” in Lr for now until they return the feature of custom. It performs much better.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...