Importing Video from Pixel 3 (HEIC)

Community Beginner ,
Apr 19, 2020

Copy link to clipboard

Copied

I'm having trouble importing videos from my Pixel 3 into Lightroom Classic 9.2.1 (current version).  I copied the content of my phone to a local hard drive (to avoid a bug in the LR/Phone interaction, that otherwise sorts images by date incorrectly), and then told LR Classic to import from that directory hierarchy.  Still image import fine, but .mp4's fail with the following message:  "The movie files contain no video frames."

 

It looks like some others have had trouble with HEIC files, that is H.265 encoded video.  However, according to Adobe this format has been supported on Windows 10 since LR Classic 7.5, released in August 2018: https://helpx.adobe.com/lightroom-cc/kb/heic-files-support.html.

 

I recently reinstalled Windows, and had to install an additional CODEC to get it to recognize and play the HEIC files.  That's working fine, but LR is not.  Is there an additional CODEC I need to load?  Or did Adobe drop support for HEIC after adding it?

 

Thanks!

TOPICS
Import and export, Problem or error, Windows

Views

233

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Importing Video from Pixel 3 (HEIC)

Community Beginner ,
Apr 19, 2020

Copy link to clipboard

Copied

I'm having trouble importing videos from my Pixel 3 into Lightroom Classic 9.2.1 (current version).  I copied the content of my phone to a local hard drive (to avoid a bug in the LR/Phone interaction, that otherwise sorts images by date incorrectly), and then told LR Classic to import from that directory hierarchy.  Still image import fine, but .mp4's fail with the following message:  "The movie files contain no video frames."

 

It looks like some others have had trouble with HEIC files, that is H.265 encoded video.  However, according to Adobe this format has been supported on Windows 10 since LR Classic 7.5, released in August 2018: https://helpx.adobe.com/lightroom-cc/kb/heic-files-support.html.

 

I recently reinstalled Windows, and had to install an additional CODEC to get it to recognize and play the HEIC files.  That's working fine, but LR is not.  Is there an additional CODEC I need to load?  Or did Adobe drop support for HEIC after adding it?

 

Thanks!

TOPICS
Import and export, Problem or error, Windows

Views

234

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 19, 2020 0
Most Valuable Participant ,
Apr 20, 2020

Copy link to clipboard

Copied

"It looks like some others have had trouble with HEIC files, that is H.265 encoded video."

 

You've confused HEIC (an image format) with HEVC (a video format). LR supports HEIC images on both Mac and Windows, but it supports HEVC videos on Mac only:

https://helpx.adobe.com/lightroom-cc/kb/heic-files-support.html

 

HEVC support was added to Mac LR in October 2018, and Adobe has said since then they're "working" on Windows LR support. Informed speculation and hints from those who have insider access suggests that it may be a long time before Windows support materializes, if ever.

 

You could add your constructive opinion and Me Too vote to this popular feature request in the official Adobe feedback forum:

https://feedback.photoshop.com/photoshop_family/topics/hevc-support-for-lightroom-cc-mac?topic-reply...

 

User feedback in that forum does indeed influence Adobe, though often on glacial time scales.

 

I gave up on LR video years ago. Adobe has always treated video as the unwanted stepchild -- it's unreliable and buggy and missing basic features.   Instead, I use my Any File plugin to catalog my videos, with a keyboard shortcut that plays the cataloged videos in the OS's native video player.

 

[Use the blue reply button under the first post to ensure replies sort properly.]

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 20, 2020 0
Community Beginner ,
May 08, 2020

Copy link to clipboard

Copied

i have same issue with dji mavic 2 pro hevc files, latest mac os, latest lr classic, adobe ignore this problem more than year.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 08, 2020 0