Highlighted

Incomplete EXIF with Nikon Z7

New Here ,
Jul 30, 2020

Copy link to clipboard

Copied

Hi, in addition to the manufacturer's lenses I also use some Sigma and Zeiss glass on my Nikons. When I import photos taken with the D800 into Lightroom Classic, it shows for instance that the lens used was the Zeiss Distagon ZF.2 35/1.4.

When I use the same lenses on my Z7, Lightroom will only report "35.0 mm f/1.4", so there is no way of distinguishing between, say, the Sigma 35/1.4 and the Zeiss 35/1.4.

Interestingly enough, when I import the same files into DxO PhotoLab 2, I get the correct lens info, so it must be embedded in the EXIF.

Is that a known problem? Anything I might be doing wrong during import? 

Topics

Import and export, Problem or error

Views

25

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Incomplete EXIF with Nikon Z7

New Here ,
Jul 30, 2020

Copy link to clipboard

Copied

Hi, in addition to the manufacturer's lenses I also use some Sigma and Zeiss glass on my Nikons. When I import photos taken with the D800 into Lightroom Classic, it shows for instance that the lens used was the Zeiss Distagon ZF.2 35/1.4.

When I use the same lenses on my Z7, Lightroom will only report "35.0 mm f/1.4", so there is no way of distinguishing between, say, the Sigma 35/1.4 and the Zeiss 35/1.4.

Interestingly enough, when I import the same files into DxO PhotoLab 2, I get the correct lens info, so it must be embedded in the EXIF.

Is that a known problem? Anything I might be doing wrong during import? 

Topics

Import and export, Problem or error

Views

26

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation