Is Lightroom 6.12 64-bit compatible

New Here ,
Jul 04, 2021 Jul 04, 2021

Copy link to clipboard

Copied

I am running LR version 6.12 on Mac with MacOS 10.13 (High Sierra). If I upgrade MacOS to a 64-bit only version (anything after High Sierra) will LR 6.12 still run? Has anyone tried it?

 

{Moved from Lightroom Cloud to Lightroom Classic Forum by Moderator} 

TOPICS
How to, Mac, Problem or error

Views

70

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 2 Correct Answers

Adobe Community Professional , Jul 05, 2021 Jul 05, 2021
Migration Assistant is not needed if you upgrade MacOS. It is only needed for transfering apps, docs and settings between computers, for example if you buy a new Mac. One word of warning: the license verification is also 32 bits. If Lightroom ever thinks it needs to verify your license again, you're in trouble if you've upgraded to a 64 bit only OS.

Likes

Translate

Translate
LEGEND , Jul 05, 2021 Jul 05, 2021
There have also been reports that after updating to Mac OS 10.15 or 11, LR 6 ran correctly for a while and then stopped (not related to the known problems with LR 6 face recognition no longer working). So if you do upgrade Mac OS, be prepared for a possible failure of LR 6 at any point.

Likes

Translate

Translate
Adobe Community Professional ,
Jul 05, 2021 Jul 05, 2021

Copy link to clipboard

Copied

Yes it will still run if it's still installed (i.e. if you use the Migration Assistant to bring over the currently-installed apps) on all the later MacOS versions. The problem will occur if you have to install the app, as the installer is 32-bit, so it cannot be installed on any MacOS version after Mojave (10.14).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jul 05, 2021 Jul 05, 2021

Copy link to clipboard

Copied

Migration Assistant is not needed if you upgrade MacOS. It is only needed for transfering apps, docs and settings between computers, for example if you buy a new Mac.

 

One word of warning: the license verification is also 32 bits. If Lightroom ever thinks it needs to verify your license again, you're in trouble if you've upgraded to a 64 bit only OS.

 

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Jul 05, 2021 Jul 05, 2021

Copy link to clipboard

Copied

LATEST

There have also been reports that after updating to Mac OS 10.15 or 11, LR 6 ran correctly for a while and then stopped (not related to the known problems with LR 6 face recognition no longer working). So if you do upgrade Mac OS, be prepared for a possible failure of LR 6 at any point.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines