Lighroom Classic starts slow and lags while editing on Windows 10

New Here ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

Greeting my Lightroom Classic does not crash but its starts slow and then when i start using tools like brushing etc starts lagging, ex the result of edit come after at least 10 sec or more and that is a constant state.

I tried turning GPU GPU use resetingting preferences which resulted to the program not hang for few second after every edit but only now like i wrote above lags for seconds and seconds. I tried photoshop did some basic staff with brushing etc and there was no problem a very smooth work from the start of the application to edit a photo. Butims im new to photography i prefer to start with using lightroom first so its vflustratingting when i cant do basic editing like brushing etc.

My laptop is with Windowsintelni7l i8ghz8ghz 16GB16GB RAM.

 

{Moved from Lightroom Cloud to Lightroom Classic Forum by Moderator} 

 

 

TOPICS
Crash or freeze, Performance, Problem or error, Windows

Views

223

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
May 07, 2021 May 07, 2021

Copy link to clipboard

Copied

Hi,

 

We're sorry about the performance issues while working in Lightroom Classic. Would you mind telling us the version of Lightroom Classic you're working on? Please ensure you have all available Windows updates installed on the computer along with the latest version of Lightroom Classic & the latest drivers for your computer.

 

You can try optimizing the Preferences of Lightroom Classic using the steps suggested here: https://helpx.adobe.com/lightroom-classic/kb/optimize-performance-lightroom.html

 

If the issue persists, please try creating a new catalog & import a few images into it to test if you still experience the same behavior.

 

Let us know if it helps!

Regards,

Nikunj

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
May 08, 2021 May 08, 2021

Copy link to clipboard

Copied

LATEST

Doing a lot of brushing on a photo is often a cause of Lightroom Classic slowing down. If you have a 4K or larger monitor, and/or a raw images that are larger than about 24MP, and/or an old or slow CPU, all of these things will make the lag due to brushing worse.

 

it's not clear from your words above if you tried turning off the GPU.

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines