Highlighted

Lightroom 9 agonizingly slow to launch and become ready

New Here ,
Dec 06, 2019

Copy link to clipboard

Copied

Hello,

 

I have Lightroom CC 9.0 and am having an issue where I open a catalog, any catalog regardless of size. My test catalog contains about 100 images.   It takes lightroom over 60 seconds after it show the Main Control screen be become responive and allow you to interact with the photos and menus.   The app never goes to not responding.   It just sits for 50-65 seconds then allows you to work with the files.  In previous version of lightroom the lag on launch was about 10-15 seconds.

 

System Specs

Windows 10 Pro Build 1909

CPU i7-7820X @ 3.60Ghz

32GB of Ram DDR4 3200Mhz

OS is on a Samsung 950 512GB NVME Drive

Catalog and photos are located on a  Samsung 970 EVO 1TB drive

Video Card Nvidia Gefore GTX 980

 

The iamges in the catalogs have minimal editing, usually only crop, or color balance adjustments made.  All edits to images are done in Photoshop and round tripped back to Lightroom in a TIFF file.

 

Can anyone give me some guidance to try to improve the launch speed and usability of Lightroom?  I dont belives there are any real hardware bottlenecks in the system that are causing the issue.  I believe its software related as it has become slower and slower with each release over the last 4 major releases.

Adobe Community Professional
Correct answer by Per Berntsen | Adobe Community Professional

Do you have a Logitech mouse?

The Logitech Options software installs a plugin for Lightroom, which is known to cause very long startup times.

Go to File > Plugin manager to disable it.

 

LR-plugin-manager.png

Topics

Crash or freeze, Performance, Problem or error, Windows

Views

131

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lightroom 9 agonizingly slow to launch and become ready

New Here ,
Dec 06, 2019

Copy link to clipboard

Copied

Hello,

 

I have Lightroom CC 9.0 and am having an issue where I open a catalog, any catalog regardless of size. My test catalog contains about 100 images.   It takes lightroom over 60 seconds after it show the Main Control screen be become responive and allow you to interact with the photos and menus.   The app never goes to not responding.   It just sits for 50-65 seconds then allows you to work with the files.  In previous version of lightroom the lag on launch was about 10-15 seconds.

 

System Specs

Windows 10 Pro Build 1909

CPU i7-7820X @ 3.60Ghz

32GB of Ram DDR4 3200Mhz

OS is on a Samsung 950 512GB NVME Drive

Catalog and photos are located on a  Samsung 970 EVO 1TB drive

Video Card Nvidia Gefore GTX 980

 

The iamges in the catalogs have minimal editing, usually only crop, or color balance adjustments made.  All edits to images are done in Photoshop and round tripped back to Lightroom in a TIFF file.

 

Can anyone give me some guidance to try to improve the launch speed and usability of Lightroom?  I dont belives there are any real hardware bottlenecks in the system that are causing the issue.  I believe its software related as it has become slower and slower with each release over the last 4 major releases.

Adobe Community Professional
Correct answer by Per Berntsen | Adobe Community Professional

Do you have a Logitech mouse?

The Logitech Options software installs a plugin for Lightroom, which is known to cause very long startup times.

Go to File > Plugin manager to disable it.

 

LR-plugin-manager.png

Topics

Crash or freeze, Performance, Problem or error, Windows

Views

132

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Dec 07, 2019

Copy link to clipboard

Copied

Do you have a Logitech mouse?

The Logitech Options software installs a plugin for Lightroom, which is known to cause very long startup times.

Go to File > Plugin manager to disable it.

 

LR-plugin-manager.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 07, 2019

Copy link to clipboard

Copied

Thank you Per Berntsen.

 

This was the exact problem!  I did not even know Logitech Options installed its own 3rd party plugin.   After disabling the plugin Lightroom is loaded in about 7 seconds.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...