Lightroom Classic CC 7.3 update crashes all the time

Community Beginner ,
Apr 03, 2018

Copy link to clipboard

Copied

I have  big problem with the new update of Lightroom Classic CC 7.3 and it is crashing a lot. It has crashed when I used the Profiles browser and also when I used ordinary presets. I´m not doing anything else with LR but with this new version seems very unstable, the 7.2 was very stable. I have checked so I dont have GPU acceleration on plus I have updated with the latest graphicscard drivers.

One other problem is with the converted development presets is rearranged in a total chaos order. I can not find any logic behind how it is organized. Is there a easy way to have it back in the order I hade it version 7.2. In the filesystem it looks ok but LR is doing something else.

Br

Mats

Views

18.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lightroom Classic CC 7.3 update crashes all the time

Community Beginner ,
Apr 03, 2018

Copy link to clipboard

Copied

I have  big problem with the new update of Lightroom Classic CC 7.3 and it is crashing a lot. It has crashed when I used the Profiles browser and also when I used ordinary presets. I´m not doing anything else with LR but with this new version seems very unstable, the 7.2 was very stable. I have checked so I dont have GPU acceleration on plus I have updated with the latest graphicscard drivers.

One other problem is with the converted development presets is rearranged in a total chaos order. I can not find any logic behind how it is organized. Is there a easy way to have it back in the order I hade it version 7.2. In the filesystem it looks ok but LR is doing something else.

Br

Mats

Views

18.5K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 03, 2018 1
200 Replies 200
New Here ,
Apr 03, 2018

Copy link to clipboard

Copied

same problems with mac (last version)

I open a file

I applied a Profiles browser (modern for example)

lightroom crashed and exit without explanation

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2018 3
Explorer ,
Apr 03, 2018

Copy link to clipboard

Copied

Same problem. Constant crashing after recent profiles update. Crashes even if no profile applied other than default Adobe.

Crashes occurring right on start up or within a minute of start up.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2018 3
Community Beginner ,
Apr 03, 2018

Copy link to clipboard

Copied

Having the same issue and additional issues. Problems include:

1)  Lightroom is now extremely slow on startup, 1 minute or more to open a catalog with 140 images in it, this is even after all the presets have been converted to XMP files (yet seemingly still retain their ".lrtemplate" suffix.

2) Slow to go from Library to Develop or the reverse... 30 seconds or more

3) Random crashing, on several different catalogs of different sizes. This is obviously the the worst thing, rendering Lightroom completely unstable and unusable.

Running Mac OS Sierra on MacBook Air with 8 GB of RAM. Previous 7.2 version was rock solid stable. Even turning GPU off it still crashes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2018 1
Explorer ,
Apr 03, 2018

Copy link to clipboard

Copied

For me 7.3 is hanging up on synchronize folder and eventually crashing.  Very similar behavior as 7.2, so I am going back to 7.1 which is last stable version for me.

Windows 10, 64 bit, 16 mb ram

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2018 3
New Here ,
Apr 03, 2018

Copy link to clipboard

Copied

Same issue, crashing on Mac OS. I reinstalled and the same issue persists. I had to reinstall version 7.2 to be able to work...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2018 3