Lightroom Classic CC latest release (10.0) has serious problems on my MacBook Pro

New Here ,
Oct 23, 2020 Oct 23, 2020

Copy link to clipboard

Copied

Lightroom Classic CC latest release (10.0) has serious problems on my MacBook Pro running Catalina 10.15.7.

 

When it first starts up, the menus across the top are absent except for just a few items. Then about 2 minutes later, the menus all appear.

When I click on a photo in the film strip, the selected photo does not display.  It is like it is stuck on just the same photo.

This software appears to be so "buggy".  Very frustrating.

 

 

TOPICS
Mac, Problem or error

Views

41

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 23, 2020 Oct 23, 2020

Copy link to clipboard

Copied

No bugs or slowness here.

 

Make sure all your plug-ins are valid for Lightroom Classic 10.0. If you have any Logitech plugins, uninstall them.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Oct 23, 2020 Oct 23, 2020

Copy link to clipboard

Copied

LATEST

I recommend that you post your problem over at the official Adobe Feedback site, where Adobe Techs pay attention. They may provide you with a private email invite to send the catalog over to them for analysis Appears to be a MAC vs Adobe issue???

 

https://feedback.photoshop.com/topics/lightroom-classic/5f5f2093785c1f1e6cc40872?cType=PROBLEM&page=...

 

 

Recommend that you include your system information as LrC reports it, in the post.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines