Highlighted

Lightroom Classic encountered user permission issues on Launch on Catalina

New Here ,
Apr 11, 2020

Copy link to clipboard

Copied

Note: I think I fixed the problem described here. My solution is given in an UPDATE below.

 

MacOS Catalina 10.15.4

Adobe Creative Cloud / Lightroom Classic 9.2

MacBook Pro (Retina, 15 inch, Late 2013)

 

 

After updating Lightroom Classic to v 9.2 from the Creative Cloud,  Lightroom Classic opens with the following error messages shown at the end of this entry.  I am assuming I need to fix this error before I can use the program. Previous versions of updates worked reliably without errors on launch.  I got the same errors booting my userid in Safe Mode.  The program opened without errors in a newly created test user.  

 

What permissions need fixing and how does one fix them in MacOS Catalina. Any suggestions on how to restore Lightroom Classic so that it is usable will be much appreciated.

 

The messages on launch are as follows (images of error panels attached):

First Message: Lightroom encountered user permission issues.

 

Lightroom does not have write permission to some standard user folders.  Please click the ‘Repair to Continue’ button to grant permissions.  Lightroom might not work correctly if you continue without correcting the issues.

 

Select -Repair to Continue- button

 

Second Message after selecting Repair to Continue button: Lightroom encountered user permission issues.

 

Lightroom cannot fix the permission issue for you automatically.  Please check the link below to learn more and correct the problem manually.  Lightroom might not work correctly if you continue without correcting the issues.

 

Thanks in advance for any suggestions.

 

Link: https://helpx.adobe.com/lightroom-classic/kb/lightroom-basic-troubleshooting-fix-most-issues.html#Tr...

 

The link to repair said to boot in Safe Mode and to try a test user which I did.  It said to use Disk Utility to repair permissions however I believe the process to fix permissions in Catalina is different from previous versions of the OS which did use Disk Utility to repair permissions. What are the permissions that need fixing for Lightroom Classic and how does one fix permissions in Catalina.

 

First Error MessageFirst Error Message

Second Error MessageSecond Error Message

 

UPDATE 4/12:   Yesterday while I was still having the permission issues I ignored them and tried to proceed and when I selected my Catalog 9.2 converted the catalog which produced another error message after the catalog conversion which is shown just below.  

Third ErrorThird Error

 

This morning I ran First Aid in Disk Utility on every level of container on my main disk and my external disk where I store my images.  I also removed an old version of a stand alone Adobe Lightroom app using the AppCleaner app and Lightroom Classic opened without the error message. (I tried using the Creative Cloud Cleaner Tool first but this only resulted in "not responding").  After Lightroom Classic opened without any error messages I selected the converted catalog produced yesterday and it looks like everything is working again.   🙂

 

(One last thought about this experience.  I found that my preview file was large (65 GB) and the smart previews 2 GB.  Maybe the error messages were coming during the conversion of the catalog and preview files and then stopped when it completed.  There were no clear progress indications and if this was running in the background once it was done things started to work.   I would be interested in hearing if anyone actually understands what might of happened.)

Topics

Problem or error

Views

109

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lightroom Classic encountered user permission issues on Launch on Catalina

New Here ,
Apr 11, 2020

Copy link to clipboard

Copied

Note: I think I fixed the problem described here. My solution is given in an UPDATE below.

 

MacOS Catalina 10.15.4

Adobe Creative Cloud / Lightroom Classic 9.2

MacBook Pro (Retina, 15 inch, Late 2013)

 

 

After updating Lightroom Classic to v 9.2 from the Creative Cloud,  Lightroom Classic opens with the following error messages shown at the end of this entry.  I am assuming I need to fix this error before I can use the program. Previous versions of updates worked reliably without errors on launch.  I got the same errors booting my userid in Safe Mode.  The program opened without errors in a newly created test user.  

 

What permissions need fixing and how does one fix them in MacOS Catalina. Any suggestions on how to restore Lightroom Classic so that it is usable will be much appreciated.

 

The messages on launch are as follows (images of error panels attached):

First Message: Lightroom encountered user permission issues.

 

Lightroom does not have write permission to some standard user folders.  Please click the ‘Repair to Continue’ button to grant permissions.  Lightroom might not work correctly if you continue without correcting the issues.

 

Select -Repair to Continue- button

 

Second Message after selecting Repair to Continue button: Lightroom encountered user permission issues.

 

Lightroom cannot fix the permission issue for you automatically.  Please check the link below to learn more and correct the problem manually.  Lightroom might not work correctly if you continue without correcting the issues.

 

Thanks in advance for any suggestions.

 

Link: https://helpx.adobe.com/lightroom-classic/kb/lightroom-basic-troubleshooting-fix-most-issues.html#Tr...

 

The link to repair said to boot in Safe Mode and to try a test user which I did.  It said to use Disk Utility to repair permissions however I believe the process to fix permissions in Catalina is different from previous versions of the OS which did use Disk Utility to repair permissions. What are the permissions that need fixing for Lightroom Classic and how does one fix permissions in Catalina.

 

First Error MessageFirst Error Message

Second Error MessageSecond Error Message

 

UPDATE 4/12:   Yesterday while I was still having the permission issues I ignored them and tried to proceed and when I selected my Catalog 9.2 converted the catalog which produced another error message after the catalog conversion which is shown just below.  

Third ErrorThird Error

 

This morning I ran First Aid in Disk Utility on every level of container on my main disk and my external disk where I store my images.  I also removed an old version of a stand alone Adobe Lightroom app using the AppCleaner app and Lightroom Classic opened without the error message. (I tried using the Creative Cloud Cleaner Tool first but this only resulted in "not responding").  After Lightroom Classic opened without any error messages I selected the converted catalog produced yesterday and it looks like everything is working again.   🙂

 

(One last thought about this experience.  I found that my preview file was large (65 GB) and the smart previews 2 GB.  Maybe the error messages were coming during the conversion of the catalog and preview files and then stopped when it completed.  There were no clear progress indications and if this was running in the background once it was done things started to work.   I would be interested in hearing if anyone actually understands what might of happened.)

Topics

Problem or error

Views

110

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 11, 2020 0

Have something to add?

Join the conversation