Highlighted

Lightroom Classic Glitching Out, Freezes, Crashes, Take Forever to Load Images

New Here ,
Jul 19, 2020

Copy link to clipboard

Copied

Hello

 

I have a very new, quite high spec computer. 

i7-9700K 3.60Ghz Intel Processor

32GB DDR4 Memory

NVIDIA GeForce RTX 2070 8GB GPU

Windows 10 64bit

2TB Samsung 970 Evo Plus SSD

 

Still, with all this my Lightroom Classic is terrible. It constantly glitches out, freezes and crashes, and even scrolling through images (24Megapixel or 42 Megapixel) it can take up to 20 seconds to load a single image in the develop module. This is extremely frustrating as I'm a professional photographer and need to edit large amounts of images in a short amount of time. 

 

Can anyone please advise what the heck is going on here?

TOPICS
Crash or freeze, Performance, Problem or error, Windows

Views

138

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lightroom Classic Glitching Out, Freezes, Crashes, Take Forever to Load Images

New Here ,
Jul 19, 2020

Copy link to clipboard

Copied

Hello

 

I have a very new, quite high spec computer. 

i7-9700K 3.60Ghz Intel Processor

32GB DDR4 Memory

NVIDIA GeForce RTX 2070 8GB GPU

Windows 10 64bit

2TB Samsung 970 Evo Plus SSD

 

Still, with all this my Lightroom Classic is terrible. It constantly glitches out, freezes and crashes, and even scrolling through images (24Megapixel or 42 Megapixel) it can take up to 20 seconds to load a single image in the develop module. This is extremely frustrating as I'm a professional photographer and need to edit large amounts of images in a short amount of time. 

 

Can anyone please advise what the heck is going on here?

TOPICS
Crash or freeze, Performance, Problem or error, Windows

Views

139

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 19, 2020 0
Adobe Community Professional ,
Jul 19, 2020

Copy link to clipboard

Copied

Hi

Please make sure you are using the latest version of the driver for your graphic card (don't rely on Windows Update).

If that does not help, try to deactivate the GPU acceleration and post back your mileage.

https://helpx.adobe.com/lightroom-classic/kb/lightroom-gpu-faq.html

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 19, 2020 0
New Here ,
Jul 20, 2020

Copy link to clipboard

Copied

I am using the latest driver for my graphics card. I'll try deactivation the GPU acceleration, but I don't see why my GPU, which is fully supported by Adobe Lightroom, would be causing it to completely glitch out like this. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2020 0
New Here ,
Jul 20, 2020

Copy link to clipboard

Copied

As a follow up, I tried your suggestion by disabling GPU acceleration - no help or improvement whatsoever.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2020 0
LEGEND ,
Jul 20, 2020

Copy link to clipboard

Copied

Explain "glitches out". Be specific an detailed. What actions cause this to happen?

 

When it freezes or crashes, is taht just Lightroom Classic freezing or crashing but the rest of the computer still runs properly? Or does nothing work and you have to restart the computer?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2020 0
New Here ,
Jul 20, 2020

Copy link to clipboard

Copied

It can happen with just about any action - creating a virtual copy, selecting a brush/radial filter/graduated filter, even just scrolling to the next photo. What happens usually is that for example, I will select the brush tool, then LR will 'freeze' where I can move the mouse but not select anything or use any sliders, then the entire screen will go black for a second or two, and then it'll come back on. That whole glitch can take anywhere between 4 to 20 seconds. Sometimes it's worse than that - after the black screen it may have skipped ahead of the photos, taken me out of the develop module or entirely crashed and needs to be started up again. 

It's just LR that is crashing, the rest of the computer still works fine.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2020 0
LEGEND ,
Jul 20, 2020

Copy link to clipboard

Copied

Your brushing problem is a common problem. it is made worse by large size monitors (4K or larger) and it is made worse by high megapixel originals, and by doing lots of brushing. So, what size is your monitor (in pixels, width and height) and what size are your original images (in pixels or megapixels)?

 

You can try turning off the graphics processor in Lightroom Classic (Preferences->Performance->"Use Graphics Processor" should be set to off.

 

If that doesn't help, I'm not aware of other solutions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2020 0
New Here ,
Jul 20, 2020

Copy link to clipboard

Copied

My monitor is not even 4K, it's QHD 2560x1440. And I'm not doing lots of brushing, only a little, and it's from the very start, not after I've done a lot of editing. 
The images I'm editing are usually 24 megapixels - so nothing crazy there either. 
And yes the guy above suggested switching off the GPU acceleration, which didn't help at all. 

So, very good spec'd computer, Windows10 64bit, not even a 4K monitor, working with average megapixels, and Lightroom just cannot handle it. 

I've checked out some other people on this forum and it seems a lot of folk are having very similar issues. I'm just shocked I have a $2000+ machine and can barely even edit a batch of images. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2020 0
LEGEND ,
Jul 20, 2020

Copy link to clipboard

Copied

More debugging: try editing a few photos with no brushing, does the problem happen then?

 

When you say you are not doing a lot of brushing, how many different brushing steps do you perform on a typical photo (a brushing step ends when you click on "Done" or "new" or close the brushing dialog)?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2020 0
LEGEND ,
Jul 20, 2020

Copy link to clipboard

Copied

1. 

Please post your System Information as Lightroom Classic (LrC) reports it. In LrC click on Help, then System Info, then Copy. Paste that information into a reply. Please present all information from first line down to and including Plug-in Info. Info after Plug-in info can be cut as that is just so much dead space to us non-Techs.

 

davidg36166309_0-1595266991365.png

 

davidg36166309_1-1595266991366.png

 

 

davidg36166309_2-1595266991366.png

 

 

Just another Adobe customer; My Sys; APP: LRC 10.0, PS 22.0; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.7; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2020 0
LEGEND ,
Jul 20, 2020

Copy link to clipboard

Copied

2.

 

Where is your catalog placed? What hard drive?

 

How much free space in % exists on that hard drive? Looking for 20% or better.

 

 

Just another Adobe customer; My Sys; APP: LRC 10.0, PS 22.0; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.7; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2020 0
LEGEND ,
Jul 20, 2020

Copy link to clipboard

Copied

3

 

Where do you keep your photos? What hard drive?

 

Just another Adobe customer; My Sys; APP: LRC 10.0, PS 22.0; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.7; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 20, 2020 0