Highlighted

Lightroom Classic has slowed

Community Beginner ,
Aug 19, 2020

Copy link to clipboard

Copied

I have just taken the recent update for Lightroom Classic and it now runs rather slowly. For example, using the Previous button to import the settings from the previous picture takes over 30 seconds.

 

I am runing a MacBook Pro (2012) with an i7 2.7 GHz Quad core processor, 8Gb RAM, 1TB SSD and graphics are provided by NVIDIA GeForce GT 650M 1 GB and Intel HD Graphics 4000 1536 MB.

I know it is getting to be old tech, but it ran fine up until the update.

 

Any ideas on how to fix it?

 

Thanks.

 

{Moved from Lightroom Cloud to Lightroom Classic Forum by Moderator}

TOPICS
Mac, Performance

Views

41

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lightroom Classic has slowed

Community Beginner ,
Aug 19, 2020

Copy link to clipboard

Copied

I have just taken the recent update for Lightroom Classic and it now runs rather slowly. For example, using the Previous button to import the settings from the previous picture takes over 30 seconds.

 

I am runing a MacBook Pro (2012) with an i7 2.7 GHz Quad core processor, 8Gb RAM, 1TB SSD and graphics are provided by NVIDIA GeForce GT 650M 1 GB and Intel HD Graphics 4000 1536 MB.

I know it is getting to be old tech, but it ran fine up until the update.

 

Any ideas on how to fix it?

 

Thanks.

 

{Moved from Lightroom Cloud to Lightroom Classic Forum by Moderator}

TOPICS
Mac, Performance

Views

42

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 19, 2020 0
Adobe Community Professional ,
Aug 21, 2020

Copy link to clipboard

Copied

HI StephenB, I have a MacBookPro 2013, with 16 GB RAM 1 TB ssd...and my version according to the try I just did, seemed fine. I am on Mac OS Catalina. Which OS are you using? maybe that makes a difference?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 21, 2020 0
dj_paige LATEST
LEGEND ,
Aug 21, 2020

Copy link to clipboard

Copied

I can't duplicate this issue. The Previous button works very quickly, almost instantaneously, for me. Lightroom 9.4, Windows 10.


Can you check your resource monitor when this is happening and see if any of your computer's resources are heavily used?

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 21, 2020 0