Lightroom Classic NOT compatible with mac OS Big Sur

New Here ,
Feb 11, 2021

Copy link to clipboard

Copied

Adobe needs to issue an update for Lightroom classic to make it compatible with mac OS Big Sur program. We should not have to pay rent for Lightroon Classic if we can not use it on our mac computers. 

TOPICS
Problem or error

Views

54

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Feb 11, 2021

Copy link to clipboard

Copied

Don't tell us, we're not Adobe here, we're just other Lightroom Classic users who can't issue an update.

 

Tell Adobe: https://feedback.photoshop.com/photoshop_family/categories/photoshop_family_photoshop_lightroom

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Feb 11, 2021

Copy link to clipboard

Copied

The problem is that not everybody is having issues with Lightroom Classic and MacOS Big Sur. For lots of us it runs just fine.

 

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Feb 11, 2021

Copy link to clipboard

Copied

Absoutly no such issues with LR on this end with Big Sur. 

Now if you want help, from users (because Adobe isn't here to listen to you), describe fully your issue, hardware etc. 

What to move forward with some assistance? 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more