Lightroom Classic Not Opening

New Here ,
Oct 20, 2020

Copy link to clipboard

Copied

I just upgraded to LR Classic 10 on my iMac. The application will not make it past the splash screen. The splash screen sometimes disappears. I can hear my computer fan cranking away in the background and have waited as much as 15 minutes before forcing the application to quit.

Steps I've taken have been (in no particular order)

  • Restarting the computer
  • Logging out/in of my Adobe CC account
  • Renaming the SLCache & SLStore folders

I downgraded to LR Classic 9.4 and now that won't even open - same behavior, stuck on the splash screen.

TOPICS
Crash or freeze, Mac, Problem or error

Views

64

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 20, 2020

Copy link to clipboard

Copied

I also moved my primary catalog to a temporary folder and was able to open Lightroom with a "blank" catalog. However, when I try to open my primary catalog from Lightroom, it still freezes on the relaunch.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Oct 20, 2020

Copy link to clipboard

Copied

Somebody reported the same thing and said the splash screen noted the preferences loading. I recommended to reset/fully delete the preferences. That did the trick. 

https://www.lightroomqueen.com/how-do-i-reset-lightrooms-preferences/

 

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Oct 20, 2020

Copy link to clipboard

Copied

That got my hopes up but it's still exhibiting the same behavior after both moving the preferences file and resetting all preferences.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
target180 AUTHOR LATEST
New Here ,
Oct 20, 2020

Copy link to clipboard

Copied

FIXED: It appears that sometime between using version 9.4 yesterday and updating to 10.0 today, the gremlins corrupted my catalog. I was able to open a backup catalog from a few days ago with no problem. Just leaves me wondering what happened to the original catalog.

Good lesson in always keeping backups 🙂

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more