Highlighted

Lightroom Classic not synching keywords

Community Beginner ,
May 18, 2020

Copy link to clipboard

Copied

 I imported images into Lightroom Classic recently and assigned them the wrong keywords.

I'm trying to correct the problem by synching metadata. I've corrected the first image, entering keywords in the keyword box, selected all the images and hit the synch button. Keywords is selected in the Synchronize Metadata box that pops up. Nothing happens - the keywords aren't updated, the original keywords are still there.  What am I doing wrong?

 

Thanks

Most Valuable Participant
Correct answer by johnrellis | Most Valuable Participant

Sync Metadata and Copy/Paste Metadata only add keywords to the target photos -- they don't remove any previous keywords.

 

To remove the wrong keywords, you can select all the wrongly keyworded photos and delete those keywords from Keyword Tags panel, or you can uncheck them in the Keyword List panel.

 

Or if all the mistagged photos are supposed to have the exact same keywords, you can use WobertC's suggestion: Select all the mistagged photos, remove all the current keywords, then type or copy/paste the list of keywords you want them to have.

 

[Use the blue reply button under the first post to ensure replies sort properly.]

TOPICS
How to, Mac, Problem or error, Sync

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lightroom Classic not synching keywords

Community Beginner ,
May 18, 2020

Copy link to clipboard

Copied

 I imported images into Lightroom Classic recently and assigned them the wrong keywords.

I'm trying to correct the problem by synching metadata. I've corrected the first image, entering keywords in the keyword box, selected all the images and hit the synch button. Keywords is selected in the Synchronize Metadata box that pops up. Nothing happens - the keywords aren't updated, the original keywords are still there.  What am I doing wrong?

 

Thanks

Most Valuable Participant
Correct answer by johnrellis | Most Valuable Participant

Sync Metadata and Copy/Paste Metadata only add keywords to the target photos -- they don't remove any previous keywords.

 

To remove the wrong keywords, you can select all the wrongly keyworded photos and delete those keywords from Keyword Tags panel, or you can uncheck them in the Keyword List panel.

 

Or if all the mistagged photos are supposed to have the exact same keywords, you can use WobertC's suggestion: Select all the mistagged photos, remove all the current keywords, then type or copy/paste the list of keywords you want them to have.

 

[Use the blue reply button under the first post to ensure replies sort properly.]

TOPICS
How to, Mac, Problem or error, Sync

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 18, 2020 0
Adobe Community Professional ,
May 18, 2020

Copy link to clipboard

Copied

I have never used the {Sync Metadata] command -

Instead I Copy& Paste the keywords in the Keywording Panel. ie. Copy the 'Correct' keywords from one image, select many others, and Paste to all in the Keywording panel.

Or I use the check boxes in the Keyword List panel to Add/Remove keywords from selected photos.

 

Controlling Keywords - Lightroom Killer Tips

 

 

Regards. My System: Lr-Classic 10.0, Photoshop 22.0.1, Lightroom 4.0, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2020 1
Most Valuable Participant ,
May 18, 2020

Copy link to clipboard

Copied

Sync Metadata and Copy/Paste Metadata only add keywords to the target photos -- they don't remove any previous keywords.

 

To remove the wrong keywords, you can select all the wrongly keyworded photos and delete those keywords from Keyword Tags panel, or you can uncheck them in the Keyword List panel.

 

Or if all the mistagged photos are supposed to have the exact same keywords, you can use WobertC's suggestion: Select all the mistagged photos, remove all the current keywords, then type or copy/paste the list of keywords you want them to have.

 

[Use the blue reply button under the first post to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 18, 2020 1
Participant ,
May 19, 2020

Copy link to clipboard

Copied

Hi,

You have to remove the un wished keywords first.

1) select one or multiple keywords on the list of keywords on the right panel
2) right click on the mouse
3) select remove from images.

That's it. Done. To select multiple keywords use the CMD key on a Mac.

Goodluck
K

Best Regards
Eric Pecquerie
Sent from my iPad Pro

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 19, 2020 1
Community Beginner ,
May 19, 2020

Copy link to clipboard

Copied

Thanks for the suggestions. Selecting the photos and right clicking to remove the keywords didn't work. It still only removed the keywords from the first photo selected. I ended up deleting the keywords, which removed them from all the photos. 

thanks again. This was making me crazy

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 19, 2020 0
Most Valuable Participant ,
May 19, 2020

Copy link to clipboard

Copied

"Selecting the photos and right clicking to remove the keywords didn't work. It still only removed the keywords from the first photo selected."

 

Were you in Loupe view (single photo showing) or grid view?  When in Loupe view, LR is very confusing -- some commands apply only to the currently displayed photo even when multiple photos are selected in the filmstrip. It's impossible to remember which commands are restricted, so it's simpler just to always switch to grid view before modifying mulitple photos.

 

[Use the blue reply button under the first post to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 19, 2020 0