Lightroom Classic slow (multiple) selection

Feb 16, 2020

Copy to clipboard

Copied

When I select single images or click from one image to another there is a delay that builds up in Library module. First click quickly changes selection and them as you go the selection slows down. The same happens if you hold the ctrl and multi select images. Anyone exeriencing this issue? I have a Win10 with 48 Gig ram and Fast SSD and great graphic card before you send me checking the hardware. And graphic acceleration is on etc'. The 2020 cataloge I currently working on is local and small. 😞

Topics

Performance, Problem or error, Windows

Views

42

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lightroom Classic slow (multiple) selection

Feb 16, 2020

Copy to clipboard

Copied

When I select single images or click from one image to another there is a delay that builds up in Library module. First click quickly changes selection and them as you go the selection slows down. The same happens if you hold the ctrl and multi select images. Anyone exeriencing this issue? I have a Win10 with 48 Gig ram and Fast SSD and great graphic card before you send me checking the hardware. And graphic acceleration is on etc'. The 2020 cataloge I currently working on is local and small. 😞

Topics

Performance, Problem or error, Windows

Views

43

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Feb 16, 2020

Copy to clipboard

Copied

You could try resetting LR's preferences: 

https://www.lightroomqueen.com/articles-page/how-do-i-reset-lightrooms-preferences/

 

LR often soils its preferences file, and resetting it can fix all sorts of wonky behavior.

 

[Use the reply button under the first post to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 17, 2020

Copy to clipboard

Copied

Good advice. Seemed to help. I moved the prefernce files out of the folder and restarted. I'm starting to thing that apart from some under the hood software issue my selection of too many details on the grid view thumb nail was a culprit. Having said that it's a software issue that there is no effcient database for images details...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...