Highlighted

Lightroom classic starts slowly, freezes for quite a while

New Here ,
Jul 27, 2020

Copy link to clipboard

Copied

Everytime my lightroom classic (on windows) starts really slow before loading files on the hard drive, it freezes for quite q while, reading nothing. The network is not used, the CPU is idle.

 

I suggest adobe adding some tracing program to this app to help diagnosing this problem.

 

 

{Moved from Lightroom Cloud to Lightroom Classic Forum by Moderator} 

Topics

Problem or error

Views

105

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lightroom classic starts slowly, freezes for quite a while

New Here ,
Jul 27, 2020

Copy link to clipboard

Copied

Everytime my lightroom classic (on windows) starts really slow before loading files on the hard drive, it freezes for quite q while, reading nothing. The network is not used, the CPU is idle.

 

I suggest adobe adding some tracing program to this app to help diagnosing this problem.

 

 

{Moved from Lightroom Cloud to Lightroom Classic Forum by Moderator} 

Topics

Problem or error

Views

106

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Jul 27, 2020

Copy link to clipboard

Copied

Hi there,

 

Sorry that Lightroom Classic is freezing and running slowly while loading. 

 

Would you mind checking that you are using the latest version of Lightroom Classic from the Creative Cloud desktop app? See https://helpx.adobe.com/lightroom-classic/kb/keeping-lightroom-up-to-date.html

 

As Lightroom is running slow, could you please try turning off the GPU option from Lightroom's preferences? Go to Lightroom > Preferences > Performance tab > Uncheck "Use Graphics Processor", restart Lightroom and let us know if it helps?

 

Also, Does the app freezes while performing a specific task? To get started, you may checkout the steps mentioned here: https://helpx.adobe.com/lightroom-classic/kb/lightroom-basic-troubleshooting-fix-most-issues.html 

 

Thanks,

Akash

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 28, 2020

Copy link to clipboard

Copied

It seems turning off the gpu helps. I will keep watching to see if this is consistent.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jul 28, 2020

Copy link to clipboard

Copied

That's great. Glad to know it worked. If you have any other query or need further assistance, feel free to get back to us anytime. 

 

Thanks,

Akash

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 30, 2020

Copy link to clipboard

Copied

It's not working. It seems the first launch of lightroom after a system reboot is the slowest, disregarding whether I turned the GPU off or not.

 

I have the latest version of Windows and lightroom.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
LEGEND ,
Jul 30, 2020

Copy link to clipboard

Copied

What anti virus is in use?

 

Just another Adobe customer; My Sys; APP: LRC 9.4, PS 21.2.1; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.6; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 30, 2020

Copy link to clipboard

Copied

The built-in Windows 10 anti-virus software. No other.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 30, 2020

Copy link to clipboard

Copied

If you have your cell phone attached via USB cable, disconnect it and see what happens.

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 30, 2020

Copy link to clipboard

Copied

No cell phones or cameras were attached during the startup of lightroom.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 30, 2020

Copy link to clipboard

Copied

I suggest Adobe to add some tracing code to lightroom to help debugging this type of performance issue. Or, give me a thread dump program, and I will dump it for you guys the next time I start lightroom.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 30, 2020

Copy link to clipboard

Copied

In fact, I will dump this one for you the next time I restart. I will generate a *.dmp file. Your programmer can analyse it using WinDbg.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Community Professional ,
Jul 31, 2020

Copy link to clipboard

Copied

Do you have a Logitech mouse or keyboard, and have you installed Logitech Options?

Go to File > Plugin manager and check if there is a LogiOptions plugin in Lightroom, if there is, disable it.

This plugin in known to cause very long startup times.

 

LR-plugin-manager.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Aug 02, 2020

Copy link to clipboard

Copied

Thank you! I do have this plugin. I will disable it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...