Highlighted

Lightroom Classic totally slow macOS Catalina 10.15.1

Dec 11, 2019

Copy link to clipboard

Copied

Lightroom totally slower image construction
My system components:
iMac (Retina 5K, 27 inches, 2019)
Catalina 10.15.1 (19B88
3.7GHz 6-Core Intel Core i5
40 GB 2667 MHz DDR4
Radeon Pro 580X 8GB.
Lightroom starts normally.
 The scrolling in the images in the library mode (magnifying glass (E)) is halting slower image construction, not liquid.
 Scrolling through images in library mode (Full Page Preview (f)) is halting, not even. Image construction 3-4 sec. A liquid work not possible.
These errors always occur even after several reboots.
In developing mode, the tools work so far without any problems.
No problems in Photoshop, Bridge, and Apple Photo. Even in the bridge fluid work in the full page preview.
No other programs except Apple's own on the calculator.
On my old Mac with Mojave (27 ", late 2013), 3.2GHz Intel Core i5, NVIDIA GeForce GT 755M 1GB and 24GB of RAM, everything is much faster (less than a second image build).

 

{Thread renamed by moderator}

Topics

Performance, Problem or error

Views

511

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lightroom Classic totally slow macOS Catalina 10.15.1

Dec 11, 2019

Copy link to clipboard

Copied

Lightroom totally slower image construction
My system components:
iMac (Retina 5K, 27 inches, 2019)
Catalina 10.15.1 (19B88
3.7GHz 6-Core Intel Core i5
40 GB 2667 MHz DDR4
Radeon Pro 580X 8GB.
Lightroom starts normally.
 The scrolling in the images in the library mode (magnifying glass (E)) is halting slower image construction, not liquid.
 Scrolling through images in library mode (Full Page Preview (f)) is halting, not even. Image construction 3-4 sec. A liquid work not possible.
These errors always occur even after several reboots.
In developing mode, the tools work so far without any problems.
No problems in Photoshop, Bridge, and Apple Photo. Even in the bridge fluid work in the full page preview.
No other programs except Apple's own on the calculator.
On my old Mac with Mojave (27 ", late 2013), 3.2GHz Intel Core i5, NVIDIA GeForce GT 755M 1GB and 24GB of RAM, everything is much faster (less than a second image build).

 

{Thread renamed by moderator}

Topics

Performance, Problem or error

Views

512

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Dec 11, 2019

Copy link to clipboard

Copied

Hi there,

Sorry to hear about the slow performance of Lightroom Classic, could you please let us know the version of Lightroom you're on? You can check that by going to Help > System Info

 

Have you tried turning off the GPU option from Lightroom's preferences? Go to Lightroom > Preferences > Performance tab > Uncheck "Use Graphics Processor" > Restart Lightroom.

 

Also, you may try optimizing the performance of Lightroom and see if it helps: https://helpx.adobe.com/in/lightroom-classic/kb/optimize-performance-lightroom.html

 

Let us know how it goes.

Regards,
Sahil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2019

Copy link to clipboard

Copied

Hello,
I use version 9.1 Lightroom CC.
Disabling the GPU does not help, making the program even slower.
All other optimization attempts were also negative.

Your welcome
Klaus

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2020

Copy link to clipboard

Copied

Is there any update on this? I finally upgraded to Catalina last week and so far Photoshop and Lightroom Classic are both slower than they were under Mojave. Lightroom Classic is almost unbearable. Multiple seconds to do ANYTHING.

 

I'm on a Mac Pro, 6-core 3.5 Ghz XEON, 32 GB of RAM.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 12, 2019

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 13, 2019

Copy link to clipboard

Copied

I have exact same problem as you have with Catalina and slow previews. Sorry 10.15.2 doesnt fix it. Was lucky one year ago with Mojave 10.14.1, everything was fine after that. But recently in Catalina ive discovered choosing ICC SRGB profile on Eizo monitor, my previews i F mode is faster than ever!! Amazing?? Seems like a ICC monitor problem. Wide gamut doesnt work??IMG_0642.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 22, 2019

Copy link to clipboard

Copied

Same-Including exporting 22 small files did not actaully start for close to 60 seconds. I have never seen this before. Everything is slow sometimes requires a restart which does little to nothing. Good thing I am not relying on Lightroom to run a business at this point because this is not really usable with too many bugs to count. Can Adobe provide an eta?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 07, 2020

Copy link to clipboard

Copied

10.5.3 didn't fix it either.  I'm on a 2019 Mac Pro with 96GB RAM and M.2 drives for storage/cache.  Scrolling my library is frustrating.  I tried building standard and smart previews, but of course that had no effect on the library scrolling.  Disabling GPU only made the problem worse, if anything.  Am currently on Classic v9.1.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 07, 2020

Copy link to clipboard

Copied

hmm thats very interesting, your exellent hardware are also slow. Can I ask about the monitor you use? Wide gamut monitor? I discovered if I use an simple cheap SRGB monitor, the library-browsing is just fine in Catalina. I guess its something wrong with color management / colorsync (I really dont know) in Catalina

However, in develop everything is OK

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...