Lightroom Classic Upgrade Catalog issue

Community Beginner ,
Nov 02, 2020

Copy link to clipboard

Copied

About 3 weeks ago, I tried to open my catalog and was prompted with the message that I needed to upgrade the catalog.  I did that.  I have folders for every year...all of them disappeared except for 2015, 2016, 2017.  I tried opening other previous catalogs.  Same issue...except most times none of the folders/keywords/collections/presets did NOT appear.  I created an entirely NEW catalog last week. Imported all my folders/keywords/presets.  Tried to open that catalog today and was again prompted to upgrade. You have no other choice except to upgrade the catalog.  So I did.  ALL folders/pictures disappeared.  It seems there is a bug that I cannot get rid of!  Every catalog, every time...loses everything.  HELP!  I can't keep working like this.

 

[Moved from Using the Community (which is about the forums) to a better forum... Mod]
[To find a forum for your program please start at https://community.adobe.com/]

TOPICS
Bug, How to

Views

53

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
LEGEND ,
Nov 02, 2020

Copy link to clipboard

Copied

Importing the photos never solves these situations, because Lightroom Classic thinks there are brand new photos it has never seen before with no edits and no user provided metadata.

 

Please use your operating system's search feature to find all files whose name ends with .LRCAT. Open each one in Lightroom Classic until you find the one that shows all of your folders.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jeanf AUTHOR LATEST
Community Beginner ,
Nov 03, 2020

Copy link to clipboard

Copied

Every catalog I try to open ... Lightroom says it needs to be upgraded.  This happens even to catalogs I upgraded 2 days ago, 4 days ago, 2 weeks ago.  EVERY time EVERY catalog.  As soon as it upgrades...all my folders in the Library module are gone.  Nothing gets retained from the previous catalog.  All folders, all photos.  No question marks no nothing.  That's why I created an entirely new catalog and re-imported ALL my folders.  This was about 2 weeks ago.  When I opened that catalog again...Lightroom said it needed to be upgraded.  I can't open the catalog unless it gets upgraded.  So I clicked ok.  Catalog opened after upgrading...ALL folders were gone...again.  This continues to happen.  I went to my Cloud list of apps and it showed 2 versions of Lightroom still on the computer.  I deleted the older one.  Still have the same issue.  This is getting beyond frustrating!!!!  Should I delete and re-install Lightroom?  This happens on both my desktop and laptop computer.  

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more