Lightroom not recognizing photos on external hard drive

Dec 03, 2020

Copy link to clipboard

Copied

Running Mac Big Sur,  updated lightroom classic 10.  I have my photos on an external hard drive.  I select import, select the external drive and lightroom delivers the message " no photos found"

TOPICS
Import and export

Views

34

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lightroom not recognizing photos on external hard drive

Dec 03, 2020

Copy link to clipboard

Copied

Running Mac Big Sur,  updated lightroom classic 10.  I have my photos on an external hard drive.  I select import, select the external drive and lightroom delivers the message " no photos found"

TOPICS
Import and export

Views

35

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 03, 2020 0
Dec 03, 2020

Copy link to clipboard

Copied

What is your version NUMBER of Lightroom? Please tell us the NUMBER and not words like "up-to-date" or "current".

 

Have the photos previously been imported into this Lightroom catalog?

 

In the Import dialog box, are the photos greyed? Can you show us a screen captures before you click Import and after you click Import? (Include the screen capture in your reply by clicking on the "Insert Photos" icon, do not include the screen captures as attachements).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 03, 2020 0
Dec 03, 2020

Copy link to clipboard

Copied

Check that Lightroom Classic has permission to access the volume. Here's how that looks in Catalina, it should be the same in Big Sur.

catalinasecurity.png

 

-- Johan W. Elzenga

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 03, 2020 0
Jan 09, 2021

Copy link to clipboard

Copied

The "no photos found" issue for me was for all types of import, from iPhone, Canon 5D to external drives.  I read 100s of articles and arrived at the simplest "solution" that nobody seems to mention.  After doing the below that JohanElsenga suggests (which is a necessary step by the way) I was still getting the "no photos found" issue.  However after walking away for 2 minutes I came back to find all of my images had populated the import window.  I did it again with an external volume that had a lot more images to import and it took a little longer, maybe 3-4 minutes of the "no photos found" screen, but they do finally come in.

I think if you have a large volume it just needs some time to scan and plan before generating the thumbnails.

I wish I had those three days of frustration back but glad it works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 09, 2021 0