Highlighted

Lightroom painfully slow

New Here ,
Mar 03, 2020

Copy link to clipboard

Copied

Lightroom seems to be running painfully slow and has been for the last week or so - both on my personal laptop and on the University macs. There is ample storage available on both devices, I have tried restarting the application and optimizing catalog to no avail. 

 

It takes forever to complete a command and it is extremely laggy when trying to use any adjustment layers.

I've checked for updates and there are none available. Photoshop seems to be mostly unaffected and is running slower than usual but definitely not as bad as Lightroom.

 

Please someone help me before I throw myself out of a window.

 

 

Topics

Crash or freeze, FAQ, Performance, Problem or error

Views

95

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lightroom painfully slow

New Here ,
Mar 03, 2020

Copy link to clipboard

Copied

Lightroom seems to be running painfully slow and has been for the last week or so - both on my personal laptop and on the University macs. There is ample storage available on both devices, I have tried restarting the application and optimizing catalog to no avail. 

 

It takes forever to complete a command and it is extremely laggy when trying to use any adjustment layers.

I've checked for updates and there are none available. Photoshop seems to be mostly unaffected and is running slower than usual but definitely not as bad as Lightroom.

 

Please someone help me before I throw myself out of a window.

 

 

Topics

Crash or freeze, FAQ, Performance, Problem or error

Views

96

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 03, 2020 0
Adobe Employee ,
Mar 03, 2020

Copy link to clipboard

Copied

Hi there,

 

We are sorry about the experience with Lightroom Classic. Would you mind sharing the version of Lightroom Classic you are using on both machines and the operating system versions on both?

 

You can try the steps mentioned below on one of the machines and test how things go? If it helps, you can perform the steps on the other computer as well.

 

  1. Go to Preferences > Performance and increase the Camera Raw Cache size to 10.0GB or more.
  2. On the same tab, check the option to Use Smart Previews instead of Original for image editing and uncheck the option to Generate Previews in Parallel.
  3. On the Performance tab itself, select off from the drop down for Use Graphic Processor
  4. Go to the General tab and check the box to Replace Embedded previews by standard previews during idle time.

Once you have made the above-mentioned changes, quit and relaunch Lightroom Classic prior to testing the application.

 

Regards,

Nikunj

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2020 0
dj_paige LATEST
LEGEND ,
Mar 03, 2020

Copy link to clipboard

Copied

It takes forever to complete a command

 

Specifically, what command?

 

it is extremely laggy when trying to use any adjustment layers

 

Do you mean "adjustment brushes"? Yes, laggy adjustment brush performance is a known problem, made worse by 4K or larger monitors and/or very large image sizes. How big are your images (in megapixels or pixels)? Is your monitor 4K or larger?

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 03, 2020 0