Highlighted

Lightroom uses all memory during sync

Community Beginner ,
Mar 30, 2018

Copy link to clipboard

Copied

Hi

When syncing Lightroom CC it ends up stalling with around 430 images to go and - after a period - my Mac warns me that I have insufficient memory, Lightroom stalls and I have to force shut down. Checking the activity monitor something strange is happening: Before reaching the last 430 images, the memory usage is around 4 GB, but then it slowly starts creeping upwards until it reaches the max 8 GB that I have. And it is all caused  by Lightroom (I run no other programs at the same time).

I have tried resetting preferences, deleting Sync.lrdata file and going back to an older catalogue. None of them resolved the issue.

Other users seem to have issue caused by them using Dropbox etc. I am using none of those.

I use a MacBook Pro 2.6 GHz, 8 GB RAM, OS X 10.11.6

Any ideas?

Thanks

Peter

Views

5.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Lightroom uses all memory during sync

Community Beginner ,
Mar 30, 2018

Copy link to clipboard

Copied

Hi

When syncing Lightroom CC it ends up stalling with around 430 images to go and - after a period - my Mac warns me that I have insufficient memory, Lightroom stalls and I have to force shut down. Checking the activity monitor something strange is happening: Before reaching the last 430 images, the memory usage is around 4 GB, but then it slowly starts creeping upwards until it reaches the max 8 GB that I have. And it is all caused  by Lightroom (I run no other programs at the same time).

I have tried resetting preferences, deleting Sync.lrdata file and going back to an older catalogue. None of them resolved the issue.

Other users seem to have issue caused by them using Dropbox etc. I am using none of those.

I use a MacBook Pro 2.6 GHz, 8 GB RAM, OS X 10.11.6

Any ideas?

Thanks

Peter

Views

5.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 30, 2018 3
Adobe Employee ,
Apr 02, 2018

Copy link to clipboard

Copied

Hi Peter,

We're sorry to hear about the memory usage, let us help make this right. Thank you for providing the information, could you please make sure that you're using the latest version of Lightroom CC which is version 1.2 by going to Help > System Info?

Regards,
Sahil

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 02, 2018 0
Community Beginner ,
Jul 09, 2018

Copy link to clipboard

Copied

Hi. Is there any news here on this issue? I have been experiencing the same thing. I just came back from Peru and needed to import around 5k photos from various camera devices. I had no problem importing images with my GoPro, but from my iPhone, iPad, and Sony Xperia phone the software kept pausing saying I was running out of memory, even when no other programs were running.

Specs

Computer: MacBook Pro 15in 2016 with 16gb RAM

OS: macOS Sierra version 10.12.6

Software: Adobe Lightroom 6 (version 6.12, Camera raw 9.12)

My catalogue has 24,500 photos in it and was originally created back in 2016. I suspect that there is some bug/leak in lightroom which is causing it to overuse memory as I recently deleted every file on my computer except for my lightroom library. Would rebuilding the library help or creating a new one? I see that there are several articles online regardless lightroom leaks but would like an official answer as to how to fix it. Thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2018 1
Community Beginner ,
Jul 09, 2018

Copy link to clipboard

Copied

I should note that when I say transferring photos with my GoPro, I mean that I imported the photos/videos directly from the SD card, not that that should make any difference...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2018 0
Community Beginner ,
Dec 06, 2018

Copy link to clipboard

Copied

Sahil, any news on this. I also ran into the same problem and from what I gather from all the above you, meaning Adobe, has gone silent ever since your initial reply not solving the problem. Can we get to a workable solution please? Your advise would be most appreciated...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 06, 2018 0
New Here ,
Apr 14, 2018

Copy link to clipboard

Copied

Same thing happens to me. I'm syncing lots of pics from mobile (around 4500 raw images). I'm using Lightroom Classic CC Version 7.3. I've had to force quit LR 3 times now in the process of syncing, and I'm still not done. It's taking days. All 16 GB of memory eventually ends up allocated to LR and my OS (Mac OS 10.13.4) warns me that I'm out of memory.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 14, 2018 5
Community Beginner ,
Jul 09, 2018

Copy link to clipboard

Copied

Have you rebuilt your library? I was thinking of doing that when I get the time...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 09, 2018 0
New Here ,
Sep 28, 2018

Copy link to clipboard

Copied

I am experiencing the same issue. Lightroom Classic takes up all free memory while (suddenly) attempting to sync thousands of photos. In fact, syncing has gone completely bonkers. The status in the corner says "syncing x,xxx" (some number in the thousands) photos. That number and the Sync Errors collection photo count jump around, up and down. It never needed to do this previously. I didn't just add thousands of photos to my library, they've been there all along. I only have a few hundred photos set to sync to lightroom mobile. When I look in the sync preferences, in the sync activities pane, there are 0 activities, 0 pending. Nothing reported at all. Meanwhile Lightroom is cranking away and sucking down all the memory, until it becomes unresponsive. It seems like this process will never complete. It also holds up the syncing of the photos that I actually want to be synced!

This is a major bug. Adobe, we need to hear from you about this problem. Sync operations should not be this opaque and disruptive. This is supposed to be a professional product, but I can't work like this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 28, 2018 5
Community Beginner ,
Oct 18, 2018

Copy link to clipboard

Copied

Sounds like the same issue I just started having yesterday. I thought it might be from the 8.0 update released on 10/15 but from this thread it seems people have had the problem before the update. All my photos were sync'd as of 10/16 and when I imported some new photos to Classic on 10/17 it's as if the entire sync process started over again, only never finishes. Lightroom Classic either freezes up midway through syncing, gets stuck in a loop counting up then counting down or uses ALL APPLICATION MEMORY and I have to force quit.

The Creative Cloud desktop app meanwhile says "All files up to date" and the sync status in Lightroom Classic has ZERO ITEMS IN THE QUEUE. The only indication any sync is happening at tall is the small text above the nameplate in Lightroom Classic.

It seems to me like Adobe has changed something (behind the scenes) on their end requiring users to rebuild their sync database but that's just a hunch. Since most of my original files are stored on my desktop using Lightroom Classic (in sync'd collections) that is the machine that is most heavily impacted by syncing. All my other devices, laptop (using Lightroom CC) and iPad, iPhone are sync'd with no issues except their sync will not update with any new images imported with Classic- most likely because the sync on Classic never finishes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 18, 2018 0
Explorer ,
Oct 18, 2018

Copy link to clipboard

Copied

Fully agree with all your statements below. Specially for the one that “Adobe has change something behind the scenes specially for the sync part. The reason that I agree so that all this issue has started suddenly without any change for my part except the upgrade of the macOS to the latest version, or at least it any an incompatibility between macOS and Lightroom was

Αριστοτέλης

Στάλθηκε από το iPhone μου

18 Οκτ 2018, 9:20 μμ, ο χρήστης «timothym44529554 <forums_noreply@adobe.com>» έγραψε:

Lightroom uses all memory during sync

created by timothym44529554 in Lightroom Classic CC — The desktop-focused app - View the full discussion

Sounds like the same issue I just started having yesterday. I thought it might be from the 8.0 update released on 10/15 but from this thread it seems people have had the problem before the update. All my photos were sync'd as of 10/16 and when I imported some new photos to Classic on 10/17 it's as if the entire sync process started over again, only never finishes. Lightroom Classic either freezes up midway through syncing, gets stuck in a loop counting up then counting down or uses ALL APPLICATION MEMORY and I have to force quit.

The Creative Cloud desktop app meanwhile says "All files up to date" and the sync status in Lightroom Classic has ZERO ITEMS IN THE QUEUE. The only indication any sync is happening at tall is the small text above the nameplate in Lightroom Classic.

It seems to me like Adobe has changed something (behind the scenes) on their end requiring users to rebuild their sync database but that's just a hunch. Since most of my original files are stored on my desktop using Lightroom Classic (in sync'd collections) that is the machine that is most heavily impacted by syncing. All my other devices, laptop (using Lightroom CC) and iPad, iPhone are sync'd with no issues except their sync will not update with any new images imported with Classic- most likely because the sync on Classic never finishes.

If the reply above answers your question, please take a moment to mark this answer as correct by visiting: https://forums.adobe.com/message/10689886#10689886 and clicking ‘Correct’ below the answer

Replies to this message go to everyone subscribed to this thread, not directly to the person who posted the message. To post a reply, either reply to this email or visit the message page:

Please note that the Adobe Forums do not accept email attachments. If you want to embed an image in your message please visit the thread in the forum and click the camera icon: https://forums.adobe.com/message/10689886#10689886

To unsubscribe from this thread, please visit the message page at , click "Following" at the top right, & "Stop Following"

Start a new discussion in Lightroom Classic CC — The desktop-focused app by email or at Adobe Community

For more information about maintaining your forum email notifications please go to https://forums.adobe.com/thread/1516624.

This email was sent by Adobe Community because you are a registered user.

You may unsubscribe instantly from Adobe Community, or adjust email frequency in your email preferences

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 18, 2018 1
New Here ,
Oct 28, 2018

Copy link to clipboard

Copied

I have the same problem. It’s unbelievable frustrating. I’ve bought a new computer, problem persists, gone to old LR backups, still there, opened LR and turned all preferences off, turned off GPU, deleted all Lightroom modules, reinstalled LR, started from fresh. Nothing works. Adobe support surfed in, had a look around, and left, problem unsolved. Looking at forums this is a widespread problem. Currently LR is unusable and I’m looking at alternatives, although with a heavy heart, with worries about a learning curve.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 28, 2018 1
Community Beginner ,
Oct 03, 2018

Copy link to clipboard

Copied

Same here, after rebuilding sync data.
It use all of my 64GB memory and more than 100GB on disk, all cleaned after a reboot.

Lightroom Classic version: 7.5 [ 1186149 ]

License: Creative Cloud

Language setting: en

Operating system: Mac OS 10

Version: 10.13.6 [17G65]

Application architecture: x64

Logical processor count: 12

Processor speed: 3,5 GHz

Built-in memory: 65 536,0 MB

Real memory available to Lightroom: 65 536,0 MB

Real memory used by Lightroom: 960,9 MB (1,4%) >> going up to 60GB

Virtual memory used by Lightroom: 3 693,3 MB

Memory cache size: 101,5MB

Internal Camera Raw revision: 1001

Maximum thread count used by Camera Raw: 5

Camera Raw SIMD optimization: SSE2,AVX

Camera Raw virtual memory: 46MB / 32767MB (0%)

Camera Raw real memory: 47MB / 65536MB (0%)

Displays: 1) 5120x2880, 2) 900x1440, 3) 1440x900

Graphics Processor Info:

Metal: AMD Radeon HD - FirePro D500

Application folder: /Applications/Adobe Lightroom Classic CC

Library Path: /Volumes/<ExternalDrive>/<Folder>/Image/Lightroom/2016-LightroomCatalogue/2016-LightroomCatalogue-2.lrcat

Settings Folder: /Users/<UserFolder>/Library/Application Support/Adobe/Lightroom

Installed Plugins:

1) AdobeStock

2) Facebook

3) Loupedeck2

Config.lua flags: None

AudioDeviceIOBlockSize: 512

AudioDeviceName: Scarlett 2i2 USB

AudioDeviceNumberOfChannels: 2

AudioDeviceSampleRate: 48000

Build: Uninitialized

CoreImage: true

GL_ACCUM_ALPHA_BITS: 0

GL_ACCUM_BLUE_BITS: 0

GL_ACCUM_GREEN_BITS: 0

GL_ACCUM_RED_BITS: 0

GL_ALPHA_BITS: 8

GL_BLUE_BITS: 8

GL_DEPTH_BITS: 24

GL_GREEN_BITS: 8

GL_MAX_3D_TEXTURE_SIZE: 16384

GL_MAX_TEXTURE_SIZE: 16384

GL_MAX_TEXTURE_UNITS: 8

GL_MAX_VIEWPORT_DIMS: 16384,16384

GL_RED_BITS: 8

GL_RENDERER: AMD Radeon HD - FirePro D500 OpenGL Engine

GL_SHADING_LANGUAGE_VERSION: 1.20

GL_STENCIL_BITS: 8

GL_VENDOR: ATI Technologies Inc.

GL_VERSION: 2.1 ATI-1.68.20

OGLEnabled: true

GL_EXTENSIONS: GL_ARB_color_buffer_float GL_ARB_depth_buffer_float GL_ARB_depth_clamp GL_ARB_depth_texture

<..>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 03, 2018 1