Lightroom won't recognise my fuji lenses anymore

Community Beginner ,
Feb 01, 2021

Copy link to clipboard

Copied

It seems Lightroom doesn't recognize my Fuji lenses. Fuji lenses have a built in profile. The lens corrections tab would read that the "built-in lens profile had been applied." Now it reads that it cannot automatically apply a lens profile. So what has happened. 

I never noticed this before, because I didn't check it anymore, it just worked. I automatically apply the settings via an import preset. But not anymore. Lens profiles are not being applied as the differences between my jpgs and raws show me. 

Lightroom doesn't have the profiles, maybe because they are just built in.  Enclosed 2 files (pardon my dutch): the current one and a file from a previous Lightroom version.

TOPICS
Bug, Mac, Problem or error

Views

102

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Most Valuable Participant , Feb 02, 2021
johnrellis Most Valuable Participant , Feb 02, 2021
I imported your sample .raf into my LR and it behaved normally, with the message "Built-in Lens Profile applied" appearing as expected ("Ingebouwd lensprofiel toegepast").   I think you're tripping over a user-interface bug that has struck other users in the past:   https://feedback.photoshop.com/conversations/lightroom-classic/lightoom-builtin-lens-profile-applied-doesnt-appear-for-nikon-z-lenses/5f5f46074b561a3d426f4827  https://feedback.photoshop.com/conversations/lightroom-classic/lightroom-classic-93-not-preserving-lens-correction-for-files-imported-with-previous-versions/5f5f46274b561a3d42767e7d...

Likes

Translate

Translate
Jump to answer Jump to answer
Most Valuable Participant ,
Feb 01, 2021

Copy link to clipboard

Copied

The message in the Lens Corrections tab is, "Kan niet automatisch een passend profiel vinden", for which the Google translation is, "Cannot automatically find a suitable profile".

 

[Use the blue reply button under the first post to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Feb 01, 2021

Copy link to clipboard

Copied

Troubleshooting steps:

 

1. Please copy here the first ten lines from the menu command Help > System Info.

 

2. Please upload a sample raw to Dropbox or similar and post the sharing link here.  From that, we can see the specific camera model and test whether this is a general issue with LR or something specific to your LR installation.

 

[Use the blue reply button under the first post to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Feb 01, 2021

Copy link to clipboard

Copied

https://helpx.adobe.com/camera-raw/kb/supported-lenses.html

 

Regards, Denis: iMac mid-2015, 5K 27”, GPU 2GB, Ram 24GB, HDD 3TB, macOS 11.2.1, LrC 10.1.1 (>10.0), Lr 4.1, Ps 22.1, Pr 14.8.0; Camera OM-D E-M1.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Feb 02, 2021

Copy link to clipboard

Copied

This is the screen print of the system info:

 

Schermafbeelding 2021-02-02 om 11.06.53.png

And this is the link to Dropbox: https://www.dropbox.com/s/ti5bkl1noxddppu/_XT30909.RAF?dl=0

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Feb 02, 2021

Copy link to clipboard

Copied

One addition: ACR works correctly!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Most Valuable Participant ,
Feb 02, 2021

Copy link to clipboard

Copied

I imported your sample .raf into my LR and it behaved normally, with the message "Built-in Lens Profile applied" appearing as expected ("Ingebouwd lensprofiel toegepast").

 

I think you're tripping over a user-interface bug that has struck other users in the past:

 

https://feedback.photoshop.com/conversations/lightroom-classic/lightoom-builtin-lens-profile-applied... 

https://feedback.photoshop.com/conversations/lightroom-classic/lightroom-classic-93-not-preserving-l...

 

LR is actually applying the built-in lens profile but not updating the message.  I see in your screenshot that it says Merk: Geen, Model: Geen, Profiel: Geen (Make: None, Model: None, Profile: None).  Normally, when you import a raw with a built-in lens profile, you see Make, Model, and Profile all set to None temporarily for a fraction of a second, before it finishing applying the built-in profile and displays the message.  But this bug prevents the update of the user interface for Make, Model, and Profile and the display of the message, even though the built-in profile was actually applied.

 

Try these steps, which worked around the issue for others:

 

1, In Develop, zoom to 100% and back to Fit. Does the message now appear?

 

2. Import a fresh .raf (never before imported) without applying your import preset. Does the message now appear?

 

3. Try resetting LR's preferences: 
https://www.lightroomqueen.com/articles-page/how-do-i-reset-lightrooms-preferences/

LR sometimes soils its preferences file, and resetting it can fix all sorts of wonky behavior. That article explains how to restore the old preferences if resetting doesn't help.

 

[Use the blue reply button under the first post to ensure replies sort properly.]

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
BoudewijnV AUTHOR LATEST
Community Beginner ,
Feb 03, 2021

Copy link to clipboard

Copied

Thanks for your trouble shooting guide. It helped. Zooming in and out worked. But I did a reset on my preferences file. That did also work. Thanks!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more