Highlighted

LR CC (7.1) Mac osx 10.13.x jumpy spaces

Explorer ,
Feb 04, 2018

Copy link to clipboard

Copied

I use with a couple of different virtual desktops (spaces) on my Mac.

When working in Lighroom Classic CC (v7.1) all of a sudden the mac jumps to another space.

I'd have to manually switch back to the space where Lightroom is sitting.

This is super annoying and I haven't found a solution to this.

This makes me look very unprofessional, when I have clients around.

Same thing by the way on my MacBookPro.

This never occurred on older operating systems.

Has anyone had the same issue?

Thanks for your help!

System:

MacPro (late 2013)

osx 10.13.3

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

LR CC (7.1) Mac osx 10.13.x jumpy spaces

Explorer ,
Feb 04, 2018

Copy link to clipboard

Copied

I use with a couple of different virtual desktops (spaces) on my Mac.

When working in Lighroom Classic CC (v7.1) all of a sudden the mac jumps to another space.

I'd have to manually switch back to the space where Lightroom is sitting.

This is super annoying and I haven't found a solution to this.

This makes me look very unprofessional, when I have clients around.

Same thing by the way on my MacBookPro.

This never occurred on older operating systems.

Has anyone had the same issue?

Thanks for your help!

System:

MacPro (late 2013)

osx 10.13.3

Views

1.7K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 04, 2018 0
Adobe Community Professional ,
Feb 04, 2018

Copy link to clipboard

Copied

Is this on a Mac notebook? Or if you are using a trackpad there is a Swipe motion that switched between desktops.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 04, 2018 0
Explorer ,
Feb 04, 2018

Copy link to clipboard

Copied

It's both MacBookPro and desktop Mac.
Both do have trackpads and swiping activated.
I also have a wacom tablet attatched.

The issue occurs though when I hit keys on the keyboard.

Trackad, mouse or tablet are inactive at that moment.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 04, 2018 0
New Here ,
Apr 23, 2018

Copy link to clipboard

Copied

Same problem here, and it just began with the most recent LR update.

Happening frequently and consistently, both on my iMac (single display), and my macBook pro with external monitor.  I have LR on Desktop 3, and it jumps right back to Desktop 1 frequently, repeatedly, consistently...and annoyingly.

Also note it happens regardless of built in keyboard and track pads, or external bluetooth keyboard and mice.  It seems to happen - may just be coincidence but SEEMS to happen - on interface changes in LR, For example, I'll hit D to go to develop, then G to go back to the Library grid, and boom- there goes the desktop back to Desktop 1.  So I'll swipe back over, and it'll happen again when I hit D for develop, or when I select a few and then hit N to compare them...  So interface changes that like that seem to trigger it nearly every time.

But it also just happened when I went to manually enter an exposure value in the Develop module, AND when I went to switch back to Desktop 1 to type this paragraph, it jumped BACK to Desktop 3 (where LR is) 3 times!

OS and all Adobe products fully up to date on both systems.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 23, 2018 0
New Here ,
May 30, 2018

Copy link to clipboard

Copied

desperately looking or a fix for this as well

its driving me frikking nuts!

latest lightroom and osx, flash imac.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 30, 2018 0
New Here ,
Jul 15, 2018

Copy link to clipboard

Copied

Nothing to add other than I am also experiencing this issue. It is driving me insane!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 15, 2018 0
New Here ,
Aug 15, 2018

Copy link to clipboard

Copied

In the same boat. Adobe needs to do something about this.

No other work around have helped. For reference here's everything I've tried that has not worked:

  • uncheck "Automatically rearrange Spaces based on most recent use" in the Mission Control settings panel
  • ensure that when right clicking on Lightroom dock icon, "None" is selected under options
  • ensure that all other apps have "None" selected as above
  • open Lightroom in a new Space with no other windows
  • ensure Lightroom is the only app running

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 15, 2018 0
New Here ,
Sep 02, 2018

Copy link to clipboard

Copied

I'm not sure this is an Adobe issue but a MacOS issue; I have issues with my apps set to a certain desktop and turning my Mac on and my apps being on the wrong desktop.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 02, 2018 0
Adobe Community Professional ,
Sep 02, 2018

Copy link to clipboard

Copied

Spaces are activated with Full Screen mode - nothing to do with Adobe - this is a mac OS feature.

You can edit the settings via the preferences in Mission Control:

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 02, 2018 0
New Here ,
Oct 06, 2018

Copy link to clipboard

Copied

Nope, this is not the "correct answer". I disagree, and respectfully note that you haven't read my post completely.

It's not an issue that occurs on open or solely when switching to the Lightroom application. It occurs within Lightroom as well, when changing modules. Additionally, as noted, I have made changes in Mission Control many times to no avail.

I've made small video illustrating the issue. In the video I click on different modules, and when I do the Mac OS space changes. Take a look: Lightroom Mac OS spaces issue. - YouTube

I make no claim to whether it's an Adobe or an Apple issue but it does only happen with Lightroom.

edit: word order

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2018 0
Adobe Community Professional ,
Oct 06, 2018

Copy link to clipboard

Copied

I'm unable to replicate this and have to compare your settings. Are you

the original poster?

Email Signature

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2018 0
New Here ,
Oct 06, 2018

Copy link to clipboard

Copied

Thank you. I am not the original poster. Should I start a new thread?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2018 0
Adobe Community Professional ,
Oct 06, 2018

Copy link to clipboard

Copied

Yes - I think it will be helpful to include your video. I've tried a few

settings and simply can't reproduce the event. Perhaps you can share the

adjustments you've made in Mission Control. If we can create the same

result one would hope we can undo it as well.

Email Signature

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 06, 2018 0
New Here ,
Oct 07, 2018

Copy link to clipboard

Copied

OK will do shortly. Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2018 0
New Here ,
May 19, 2020

Copy link to clipboard

Copied

This is not solved. It is still happening in Catalina and LR classic 9.2.1

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 19, 2020 1
ntompson LATEST
Community Beginner ,
Aug 05, 2020

Copy link to clipboard

Copied

Same here - this drives me nuts. Has been an intermittent issue for as long as I can remember. When will it be fixed?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 05, 2020 0