Highlighted

LR Classic Book Module BUGGY AS HELL costing me hours of productivity

Community Beginner ,
Apr 10, 2020

Copy link to clipboard

Copied

Hi all, I'm coming to you today from a 2019 MBP running Recently updted Catalina 10.15.04 and running LR Classic 9.2

 

A few times a year I use The book module to put together a wedding album and wither save as a pdf and upload to a printer, or order stright through the blurb option.

 

The problems I have been encountering have been vast and very annoying. They have been ongoing for atleast the last 8 months on a  number of versions of LR and on multiple computers with newer and older versions of OSX.

 

Problem 1.

Enter collection, it has 130 photos.

Switch to book module for first time.

Autolayout makes a 130 page book, I clear the book and start fresh, jump out of the module to take care of somehtingelse, when i come back to it my collection of 130 photos now includes every photo from the previous collection I used to make an album. so now I have 540 photos from two different weddings. Now I have to clear out all the pages again and start over becuase it has also redone the autolayout.

 

As a safety measure I tried to clear the book, then create a saved book to begin the project with only the photos I care about in the 130 photo collection. Once I go to the newly saved "blank" book it has 240 pages from a fresh autolayout once again including all the photos from the other collection and I am unable to use the clear book option so I have to delete the whole book and start over.


Problem 2.

Saved books vanish once I begin a new book.
Yesterday I completed two albums and attempted to begin a third. The first two albums were in the same collection set. I made a saved book for each of them and exported jpegs for approval form the client.

I then jumped over to a different collection set with the next wedding I needed to work on, I click the book module, experience all of the issues in Problem 1, but also notice the previous book I had saved no longer existed. 

After a few expletives I command Z until the book has comeback from whereever it vanished to. 

 

I once again try to create a new book in the other collection and immediately check to see the status of the previous book.

Again it is gone.

command Z the book back to life

right click the saved book, copy book

 

now I have two copies.

quit lightroom, restart computer

open lightroom, original and copy of book are listed in the collection set

 

I go to the collection set for the next album, switch to book module and the original and the copy of the previously completed book are gone.

 

I command Z until they are back, quit lightroom and call it quits for the day.

 

This must have also happened to previous albums because two that I completed and saved in the last month are no longer listed in my saved books, but since I didnt work on both in the same day I must have missed the moment when they vanished. The first one I had to rebuild from the low res jpegs I sent out to the clients for approval. The book module has cost me atleast 8 hours of productivity because of troubleshooting or rebuilding books that vanished. 

 

What is going on with this?

 

{Moved from Lightroom Cloud to Lightroom Classic Forum by Moderator}

TOPICS
Bug, Mac, Problem or error

Views

167

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

LR Classic Book Module BUGGY AS HELL costing me hours of productivity

Community Beginner ,
Apr 10, 2020

Copy link to clipboard

Copied

Hi all, I'm coming to you today from a 2019 MBP running Recently updted Catalina 10.15.04 and running LR Classic 9.2

 

A few times a year I use The book module to put together a wedding album and wither save as a pdf and upload to a printer, or order stright through the blurb option.

 

The problems I have been encountering have been vast and very annoying. They have been ongoing for atleast the last 8 months on a  number of versions of LR and on multiple computers with newer and older versions of OSX.

 

Problem 1.

Enter collection, it has 130 photos.

Switch to book module for first time.

Autolayout makes a 130 page book, I clear the book and start fresh, jump out of the module to take care of somehtingelse, when i come back to it my collection of 130 photos now includes every photo from the previous collection I used to make an album. so now I have 540 photos from two different weddings. Now I have to clear out all the pages again and start over becuase it has also redone the autolayout.

 

As a safety measure I tried to clear the book, then create a saved book to begin the project with only the photos I care about in the 130 photo collection. Once I go to the newly saved "blank" book it has 240 pages from a fresh autolayout once again including all the photos from the other collection and I am unable to use the clear book option so I have to delete the whole book and start over.


Problem 2.

Saved books vanish once I begin a new book.
Yesterday I completed two albums and attempted to begin a third. The first two albums were in the same collection set. I made a saved book for each of them and exported jpegs for approval form the client.

I then jumped over to a different collection set with the next wedding I needed to work on, I click the book module, experience all of the issues in Problem 1, but also notice the previous book I had saved no longer existed. 

After a few expletives I command Z until the book has comeback from whereever it vanished to. 

 

I once again try to create a new book in the other collection and immediately check to see the status of the previous book.

Again it is gone.

command Z the book back to life

right click the saved book, copy book

 

now I have two copies.

quit lightroom, restart computer

open lightroom, original and copy of book are listed in the collection set

 

I go to the collection set for the next album, switch to book module and the original and the copy of the previously completed book are gone.

 

I command Z until they are back, quit lightroom and call it quits for the day.

 

This must have also happened to previous albums because two that I completed and saved in the last month are no longer listed in my saved books, but since I didnt work on both in the same day I must have missed the moment when they vanished. The first one I had to rebuild from the low res jpegs I sent out to the clients for approval. The book module has cost me atleast 8 hours of productivity because of troubleshooting or rebuilding books that vanished. 

 

What is going on with this?

 

{Moved from Lightroom Cloud to Lightroom Classic Forum by Moderator}

TOPICS
Bug, Mac, Problem or error

Views

168

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 10, 2020 1
Adobe Community Professional ,
Apr 10, 2020

Copy link to clipboard

Copied

Problem 1) has been a bugbear for many. Here is my suggestion- Try a different workflow to start a new book-

 

*For all future books- Set the ‘Book Preferences’ option to NOT Autofill when a new book is started-

ScreenShot341.jpg (Book Preferences only appears on the top menu when the Book module is active)

 

I am suggesting to Create an ‘empty’ “Saved Book Collection”, then add photos to this-

 

1) De-select all Photos.  [Ctrl+D]

2) Open the Book Module from the top menu (Note- Autofill does not create pages by the Preference set.). Ignore any photos on the filmstrip!

3) Immediately click the tab to Create a saved Book with the option to “Include only used photos”. (Note: you have NO photos selected or used in the book, yet!)  Give this Saved Book Collection a Descriptive name.

ScreenShot343.jpg

4) Now you have an ‘empty’ Saved Book Collection. (no photos whatsoever!)

5) From the Library Grid (either Folder view or a Collection view)- Drag and Drop selected photos, that you want in your new Book, into the Saved Book Collection. (even make it the 'Target Collection' to add photos [B].)

6) Open the ‘Saved Book’ from the Collection panel -ALWAYS!  Never again from the top menu!

ScreenShot344.jpg

7) Now use Autofill with a Preset, or manually create pages for the book design.

 

As for Problem 2)

Sorry, I have no answer. I have never seen my Saved Book Collections disappear from the Collection panel. (they sometimes are created within Collection Sets that I forgot to note when saved!)

Catalog corruption? Try a new Catalog as a test.

 

 

Regards. My System: Lr-Classic 10.0, Photoshop 22.0.1, Lightroom 4.0, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2020 0
New Here ,
Apr 16, 2020

Copy link to clipboard

Copied

I have the same problem as the OP in problem 1.  Posted to DPReview and received same advice as you gave above (maybe it was you)?  Did not work.  Cleared the book, created a new book with no photos and it includes 37-38 photos from previous book.  If I don't tag include selected photos, I get the entire folder!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
Adobe Community Professional ,
Apr 16, 2020

Copy link to clipboard

Copied

Yes the advice might have been me at DPReview.

Cleared the book, created a new book

My question is- HOW did you create a new book?

Did you click on the Module picker menu a second time?  This is the wrong thing to do!

Did you create the SAVED BOOK COLLECTION? 

Is there a Collection in the Collection panel that has no photos?

Did you start your new book FROM THIS SAVED BOOK COLLECTION?

The seven steps in my post above should be followed closely.

 

I have a rough video in Dropbox-  https://www.dropbox.com/s/a0ytjne4k7yl168/Create%20a%20new%20book.mp4?dl=0

 

 

 

 

Regards. My System: Lr-Classic 10.0, Photoshop 22.0.1, Lightroom 4.0, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
New Here ,
Apr 16, 2020

Copy link to clipboard

Copied

Could you please elaborate on "did you click on the Module picker menu a second time?"  I'm not sure what this means, so perhaps I am guilty.

 

Thanks

 

Bob

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
Adobe Community Professional ,
Apr 16, 2020

Copy link to clipboard

Copied

This is the Module picker-

ScreenShot024.jpg

and I added a video in the post above.

Regards. My System: Lr-Classic 10.0, Photoshop 22.0.1, Lightroom 4.0, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2020 0
New Here ,
Apr 30, 2020

Copy link to clipboard

Copied

Same problem here as OP's problem #1.  WobertC, followed your directions exactly (also checked out your dropbox video)... however at your step 4, my book still gets created with a random selection of photos... 21 of them to be exact.  However, I was able to select all at the filmstrip on the bottom, "Remove From Collection"... and they stayed out.  After that I continued to add photos in as your directions and it works! Thank you very much for this work around...   Another issue I was finding is the book not saving after I set up type on the cover and title pages, and had made font selections etc.  If I clicked into another module at this point all those changes were lost.  This was solved after I added a photo to the book. For some reason after that it saves.  Wish they would fix these bugs! 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 30, 2020 0
WobertC LATEST
Adobe Community Professional ,
Apr 30, 2020

Copy link to clipboard

Copied

Nice to hear you are managing a work-around.

A couple of comments-

1)

step 4, my book still gets created with a random selection of photos..

If you have 'cleared' the book layout and created a "Saved Book Collection" with the option to “Include only used photos” (and none are selected on filmstrip [Ctrl+D] ), then this (new) collection in the Collections panel will have no photos in the Collection. (I am not talking about the Book in the Book module here!) and nothing to do with the Filmstrip. At this stage I exit the Book Module and add the photos I want to this new Book Collection, and 'open' my new book by a [double-click] on the new Book Collection.

Viewing any Book Collection in Library grid view and Deleting all photos from this collection achieves the same result- an empty book with no photos.

2)

all those changes were lost.

I cannot reproduce this problem- tried text only, changed modules, back to Book and all text remains.

Be very wary of fonts though. The Book module does not 'like' unusual fonts- stick to the default or other commonly used fonts.

3)

Strangely the problem of unwanted photos in the Book filnstrip does not seem to be happening for me now! I select a folder of images in the Library module, go to the Book module, only the photos in the folder show.

Maybe Adobe have made some changes??

(Don't ever go from 'All Photographs' to the Book module- a filmstrip with 59,000 photos is not pretty!)

4)

My best advice?- ALWAYS edit a Book from a Saved Book Collection in the Collection panel. Only ever click the top Module Menu when starting a very new book.

Regards. My System: Lr-Classic 10.0, Photoshop 22.0.1, Lightroom 4.0, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 30, 2020 0