Highlighted

LR Classic v9.4 - Can't open ANY catalog. Please help!

New Here ,
Aug 20, 2020

Copy link to clipboard

Copied

First time visit to this forum.

I am using Windows 10.

After the lastest upgrade v9.4, I encountered following problem. I had uninstalled and re-installed to no avail.

I even did a System Restore to a previous update, nothing works.

 

Error message: Unexpected error opening catalog

The catalog could not be opened due to an unexpected error.

"Choose a Different Catalog", still does not work!

 

Appreciate any help. Thanks.

TOPICS
Problem or error, Windows

Views

55

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

LR Classic v9.4 - Can't open ANY catalog. Please help!

New Here ,
Aug 20, 2020

Copy link to clipboard

Copied

First time visit to this forum.

I am using Windows 10.

After the lastest upgrade v9.4, I encountered following problem. I had uninstalled and re-installed to no avail.

I even did a System Restore to a previous update, nothing works.

 

Error message: Unexpected error opening catalog

The catalog could not be opened due to an unexpected error.

"Choose a Different Catalog", still does not work!

 

Appreciate any help. Thanks.

TOPICS
Problem or error, Windows

Views

56

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 20, 2020 0
LEGEND ,
Aug 20, 2020

Copy link to clipboard

Copied

Find a recent backup of your catalog file. Unzip the catalog and place it in a different folder than the original and try to open it from this different folder. If that doesn't work, unzip the catalog again and put it on a different disk, and open it from this different disk.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2020 0
New Here ,
Aug 20, 2020

Copy link to clipboard

Copied

Thank you for your quick suggestion.

In fact, I had done exactly as you suggested, but to no avail!

In other words, LR Classic does not even open by itself without a file (.lrcat).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2020 0
LEGEND ,
Aug 20, 2020

Copy link to clipboard

Copied

In other words, LR Classic does not even open by itself without a file (.lrcat).

 

I'm not sure what this means, but it doesn't sound like you did what I suggested. When you unzipped the backup catalog and placed it somewhere on a different disk than the original, did you double-click on the backup catalog to open it?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2020 0
New Here ,
Aug 20, 2020

Copy link to clipboard

Copied

Yes, I got what you said.

Unzipped file from one disk, drageed it to another disk and double click to open it. Immediately I got the error message as stated in first post.

Sorry that I was not clear about this, "In other words, LR Classic does not even open by itself without a file (.lrcat)."

 

When I had trouble opening the lrcat file (already unzipped) by double clicking OR right click on file name and select "open with" Lightroom Classic, I sometimes just click open Lrw (the app icon), from there go to File, => open (followed by browsing and locating the subject lrcat file to open). Sometimes this works for me.

 

Separately, I tried to open a different catalog, following what you had suggested, now this file gave me a different error message, "The Lightroom catalog name "xxxx" cannot be opened because it is too new to be used by this version of Lightroom. Would you like to select a different catalog? If I click "Choose a Diffeent Catalog", then the entire process repeated itself again.

 

Bottom line, I can not open any catalog in all manners that I knew how. I have been using LR for years.

 

Thanks again for you offer of help.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2020 0
LEGEND ,
Aug 20, 2020

Copy link to clipboard

Copied

Verify what version of Lightroom you are using.

 

Also verify that you do not have more than one version installed

 

The issue with a catalog being too new implies you have or had a newer version of Lightroom, one that was a major upgrade, and now you are trying to use an older version of Lightroom to open a catalog from the newer version.

 

For example, you had v9, and now you have v8 or older. 

 

Just another Adobe customer; My Sys; APP: LRC 10.0, PS 22.0; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.7; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2020 0
New Here ,
Aug 20, 2020

Copy link to clipboard

Copied

David,

Thanks for chiming in. Yes, I do have 2 older versions of LR. I will uninstall them.

I had been using v9.3. Trouble came when I upgraded to v9.4

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2020 0
LEGEND ,
Aug 20, 2020

Copy link to clipboard

Copied

And try creating a new cstalog.

 

Just another Adobe customer; My Sys; APP: LRC 10.0, PS 22.0; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.7; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2020 0
New Here ,
Aug 20, 2020

Copy link to clipboard

Copied

Good news to report:

 

I performed another (did one before) System Recovery (or Restore). Uninstall and re-install v9.4. Now Lrw is working.

Thank you everyone for helping. Appreciate your time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 20, 2020 0