LR Classic Windows 10 Book Module Changing Collections

New Here ,
Dec 21, 2020

Copy link to clipboard

Copied

I have been a LR user sine the first beta version about 16 years ago but only switched to LR Classic earlier this year.  I am using it on a Windows 10 desktop.  I used the Book Module quite a lot in freestanding LR and have produced 3 more books since converting to LR CC.

 

My methodology is, I imagine, similar to everybody else's - I start a new collection and put into it all the images that I might want to use.  I edit these down in the Library Module until I have only the ones that I think I want to use, and then go into the Book Module and start working on the book.  During the book production, I occasionally go into Library Module to add an image that I had initially omitted and into Develop for some final image editing.  This was the workflow that I used in LR 6 and earlier, and I expected it to work with LR Classic as well.

 

All went well with the first book and I used about 120 images.  Went I started on the second book, also with about 120 images, I found that the photo strip in the book module has pulled in the images from the first book as well, giving me 240 images.  When I came to the third book, I had 360 images in the photo strip.

 

What an I doing wrong.  Do I need to do some kind of clear and reset before starting a new book?

 

Thanks in advance for any help.

 

{Moved from Lightroom Cloud to Lightroom Classic Forum by Moderator}

TOPICS
How to, Problem or error, Windows

Views

50

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

LR Classic Windows 10 Book Module Changing Collections

New Here ,
Dec 21, 2020

Copy link to clipboard

Copied

I have been a LR user sine the first beta version about 16 years ago but only switched to LR Classic earlier this year.  I am using it on a Windows 10 desktop.  I used the Book Module quite a lot in freestanding LR and have produced 3 more books since converting to LR CC.

 

My methodology is, I imagine, similar to everybody else's - I start a new collection and put into it all the images that I might want to use.  I edit these down in the Library Module until I have only the ones that I think I want to use, and then go into the Book Module and start working on the book.  During the book production, I occasionally go into Library Module to add an image that I had initially omitted and into Develop for some final image editing.  This was the workflow that I used in LR 6 and earlier, and I expected it to work with LR Classic as well.

 

All went well with the first book and I used about 120 images.  Went I started on the second book, also with about 120 images, I found that the photo strip in the book module has pulled in the images from the first book as well, giving me 240 images.  When I came to the third book, I had 360 images in the photo strip.

 

What an I doing wrong.  Do I need to do some kind of clear and reset before starting a new book?

 

Thanks in advance for any help.

 

{Moved from Lightroom Cloud to Lightroom Classic Forum by Moderator}

TOPICS
How to, Problem or error, Windows

Views

51

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 21, 2020 0
New Here ,
Dec 21, 2020

Copy link to clipboard

Copied

I see that in error I used LR CC in the first paragraph.  I am using LR Classic only

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 21, 2020 0
Adobe Community Professional ,
Dec 21, 2020

Copy link to clipboard

Copied

When starting a new book click on the 'Clear Book' button in the left upper side of the screen.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 21, 2020 0
Adobe Community Professional ,
Dec 21, 2020

Copy link to clipboard

Copied

You are not doing anything wrong!

There seems to be several ways to overcome this seemingly annoying 'extra images' syndrome that appeared about v7.2 IIRC.

You could try this-

1) Start a NEW book from the top Module menu [Book] with your 'Standard Collection' of photos

2) [Clear Book] as suggested by @Todd Shaner 

3) Click the [Create Saved Book] tab.

4) Press [G] to exit to the Grid view

5) Select and delete any photos you do NOT want in the book.

6) [Double-Click] the Saved Book Collection to re-open the Book design

7) Click on [AutoLayout] or proceed to add pages manually.

You can now delete the Standard Collection you started from- the Saved Book Collection is now the Collection for the book where you can add more photos if needed.

 

Regards. My System: Lr-Classic 10.1, Photoshop 22.1, Lightroom 4.1, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 21, 2020 0
Adobe Community Professional ,
Dec 21, 2020

Copy link to clipboard

Copied

WobertC that's enough to choke a horse. I switched to using InDesign with the Blurb plugin years ago. Is this documented anywhere? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 21, 2020 0
Adobe Community Professional ,
Dec 21, 2020

Copy link to clipboard

Copied

Hi Todd,

Your good suggestion to click on [Clear Book]  does not seem to work in every case. Sometimes it does- Great!

Adobe does not document anywhere, just the frequent forum posts from Book makers about this annoyance.

per_folkessen at this link suggests that Adobe have admitted a 'bug'.-

  https://www.lightroomqueen.com/community/threads/book-module-brings-in-photos-from-previous-book.414...

And with this suggested procedure, which is (in long script) your suggested concise answer!-

1. Run Auto layout (you might need to choose or create a preset). This will populate your new book with the images from you new selection, as well as unwanted photos "inherited" from you previous book.
2. Run Clear layout directly after. This will not only clear the layout, but also clear out those unwanted old photos from the film strip.

 

My favoured (always works) work-around is to Create a Saved Book WITHOUT any photos, then add the ones I want, to this new Book Collection from Library or Standard Collection Grid View as the next step.

 

Regards. My System: Lr-Classic 10.1, Photoshop 22.1, Lightroom 4.1, Windows-10 Nikon DSLR.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 21, 2020 0
New Here ,
Dec 22, 2020

Copy link to clipboard

Copied

Thanks for all the replies.  I will try WobertC's suggestion.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 22, 2020 0