Highlighted

LR is slow and sometimes hangs on filters

New Here ,
Jul 23, 2020

Copy link to clipboard

Copied

My catalog consists of 102k images across 550 plus folders.  I am running the most recent build of LR Classic and I am running into issues with the filters.  If I try to filter on any of the color filters, I wind up getting the spinning circle and the program hangs 50% of the time at which time I have to close out the program via the taskbar.  The other 50% if I open a browser and then go back to LR it will unfreeze.  Yeah I know that sounds crazy.  I have optimized my catalog and I'm not sure where else to look for a solution.  Prior to the newest release of LR Classic, I've never had this problem before.     

TOPICS
Crash or freeze, Problem or error

Views

35

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

LR is slow and sometimes hangs on filters

New Here ,
Jul 23, 2020

Copy link to clipboard

Copied

My catalog consists of 102k images across 550 plus folders.  I am running the most recent build of LR Classic and I am running into issues with the filters.  If I try to filter on any of the color filters, I wind up getting the spinning circle and the program hangs 50% of the time at which time I have to close out the program via the taskbar.  The other 50% if I open a browser and then go back to LR it will unfreeze.  Yeah I know that sounds crazy.  I have optimized my catalog and I'm not sure where else to look for a solution.  Prior to the newest release of LR Classic, I've never had this problem before.     

TOPICS
Crash or freeze, Problem or error

Views

36

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 23, 2020 0
Adobe Community Professional ,
Jul 23, 2020

Copy link to clipboard

Copied

"Most recent" or "newest release" are not really relevant descriptions. We prefer having actual numbers. In fact, it would be well if you would list the system info for Lightroom and copy/paste the first 10 lines of that dialog in a message so that we can see what your system consists of.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2020 0
New Here ,
Jul 23, 2020

Copy link to clipboard

Copied

Here you go!

 

Lightroom Classic version: 9.3 [ 202005281810-476e492c ]
License: Creative Cloud
Language setting: en
Operating system: Windows 10 - Home Premium Edition
Version: 10.0.18363
Application architecture: x64
System architecture: x64
Logical processor count: 8
Processor speed: 3.4 GHz
SqLite Version: 3.30.1
Built-in memory: 16286.6 MB
Real memory available to Lightroom: 16286.6 MB
Real memory used by Lightroom: 1044.5 MB (6.4%)
Virtual memory used by Lightroom: 2366.6 MB
GDI objects count: 817
USER objects count: 2725
Process handles count: 2184
Memory cache size: 5.9MB
Internal Camera Raw version: 12.3 [ 493 ]
Maximum thread count used by Camera Raw: 5
Camera Raw SIMD optimization: SSE2,AVX,AVX2
Camera Raw virtual memory: 289MB / 8143MB (3%)
Camera Raw real memory: 296MB / 16286MB (1%)
System DPI setting: 96 DPI
Desktop composition enabled: Yes
Displays: 1) 1920x1080
Input types: Multitouch: No, Integrated touch: No, Integrated pen: No, External touch: No, External pen: No, Keyboard: No

Graphics Processor Info:
DirectX: NVIDIA GeForce GTX 750 Ti (26.21.14.4587)

 

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2020 0
LEGEND ,
Jul 23, 2020

Copy link to clipboard

Copied

Graphics Processor Info:
DirectX: NVIDIA GeForce GTX 750 Ti (26.21.14.4587)

GPU driver v445.87 Not current GPU driver, you should update, might not fix anything, but keep that up to date. per NVIDIA website, current is v451.67

 

 

 

Just another Adobe customer; My Sys; APP: LRC 10.0, PS 22.0; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.7; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2020 0
LEGEND ,
Jul 23, 2020

Copy link to clipboard

Copied

Displays: 1) 1920x1080

 

So, not 4K

If in /preferences/performance/  you turned in the option to use Graphics Processor, consider turning that off. Sub 4K you are probably not getting any benefit. Lots of users with NVIDIA GPU's 700 series and older, have had issues. Turning on use Graphics Processor might be causing issues.

 

Just another Adobe customer; My Sys; APP: LRC 10.0, PS 22.0; CMP: WIN WS 16GB OS 10 v1909 (18363), mid 2015 MBPr 15” 16GB MACOS 10.15.7; 4K EXT DSPY; CAM: Canon 5D Mk III, Fuji X-T3

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2020 0
Adobe Community Professional ,
Jul 23, 2020

Copy link to clipboard

Copied

Are you using Smart Previews? If so, you might benefit from deleting Smart Previews and 1:1 previews as those can slow a system. Library > Previews

Also, Face Detection and Address Lookup can slow the performance.

warmly/j

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2020 0